X86 Hardware issues (Graphics, WiFi, Onboard Sound, external DACs, Disks, BIOS/UEFI Boot problems etc.)

Ok, normal cds come thru well. Thanks for the help.

Will check out various hires recordings and find out where the card works

Feedback from Tests.

I flashed a complete new version of Volumio 3 onto a usb stick, booted the system with a DeLock PCI Express Card 7.1 Soundcard.

All i needed to do to enable the soundcard is to unmute it with following command

amixer -c 1 set IEC958 unmute

Then a signal was available on the toslink link after selecting output onto the HDA C-Media option.

Sound was scratchy and not good with a a 44,1 khz recording. With a 192 KHZ recording sounding was totally scratchy.

I then reflashed the sytem down and replaced the sound card with a Terratec Aureon 7.1 PCIe soundcard.

Here again only the unmute command was necessary to get the card working. Sound was clear and good on 44,1khz

1 Like

I’m having problems booting from x86 image as well.
I have created the bootable USB drive on a 16GB memory stick with BalenEtcher.
I have tried booting from the drive with two different machines:

  • A mini PC - fairly new with both UEFI and legacy BIOS options. Its has an AMI BIOS from 2018

  • A Lenovo Thinkpad T430s - also with both BIOS options and also 2018 era.

I have tried several different versions of the Volumio image, up to the most recent 3.139, and the current version 2 - all have the same problem, which probably means I’m doing something wrong.

The machines are booting, and then the SYSLINUX 6.04 copyright message comes up, then the Booting Volumio … please wait…
then three lines:
findfs: unable to resolve ‘UUID=ca3c3350-7d70-4ac2-9dbc-b5208eb0ee59’
findfs: unable to resolve ‘UUID=8DC6-FD91’
findfs: unable to resolve ‘UUID=bcc2822b-b951-4715-b84e-9da027a7d3db’
then this:
BusyBox v1.30.1 (Debian 1:1.30.1-4) built-in shell (ash)
Enter ‘help’ for a list of built-in commands.

sh: can’t access tty; job control turned off

This message is identical on both machines. Have the machines booted correctly? and if so, how do I find them on the network?

no, boot failed in the init process and was reported before.
Happened on hardware normally booting linux and so far I have not been able to reproduce and fix the problem. The only known: it is linked to the way the image is flashed with a given partitioned device.
Could you make sure the usb disk you are booting from is absolutely empty and all partitions removed before flashing the image?
@Robert.Hecht can confirm this happened to him a few times

yes, I can confirm that. Erasing the medium did help. In a linux environment you might use:

dd if=/dev/zero of=/dev/sdx

where sdx is the mounted medium (sda, sdb, whatever).
But handle this command with care! It will erase every block on the specified device!
After done that I flashed the volumio image zu the device and it worked fine.

Take care,

after some research on the cause of occasional crackling noise from an AORUS B450 PRO WIFI motherboard (affecting both internal analog audio and external USB DAC Topping D70S), I decided to update the AMD firmware in /lib/firmware/amd/ folder. I downloaded a newer version of the firmware from Debian Bookworm site (this package). I then uncompressed the folder, extracted the two files and overwrote the ones in Volumio 3.139 (at least, they are different in size).


Finally, I ran “sudo update-initramfs -u -k all” command and rebooted. The issue seems to be gone. In the hope of providing more objective data than my ears, I also prepared two logs, before and after the patch.

Before the cure:

After the cure:

I didn’t spot any meaningful difference, but maybe you will.

So, my request is: could you please consider substituting the two firmware files with the ones suggested for a better support of AMD family 17h mother boards? Thanks.

Have a nice weekend :wave: :wave:

currently I am reluctant to replace cpu microcode by a version which is not part of the current kernel and corresponding firmware package as I do not know whether it will cause issues for other boards. Let me do some research first.

Btw, running update-initramfs has no effect, we are loading our own initrd.

Ok, thanks for considering my proposal. Let me know how it goes…

due to the way I handle firmware inclusion during the build, I cannot pick 2 specific binaries from a 2nd firmware tar unless I change the build process, which I’m not willing to, shortly before Volumio 3 release. Replacing the complete firmware tar to a version august 21 or later is the only way to solve your issue, and can be done. But again, not now shortly before release.

Started with a private build today and it seems a build with kernel 5.10.79 with firmware 20211027 is ok on an Intel Atom. When you’re interested in a pre-version (without myVolumio), let me know by PM.

Hi Robert,
Although I’m a fairly experienced IT professional, I’m not a programmer, and I have a limited amount of knowledge of Linux.
Same back ground info = the 16GB flash drives are newly bought and, I have to say, were very cheap - they only arrive a couple of days ago, and are USB 2.0 devices They arrived formatted with FAT32.
On my main PC, BalenaEtcher kept on failing to flash the drives (I have 2), so I cleaned the drives using DiskPart; and this did not fix the problem. Maybe something to do with the USB hub device being 3.0 with backward compatibility, but that does seem a bit tenuous! Also, I have been able to flash SD cards with the RPi image without any problems, and now that stopped working, so something is clearly not right with the flashing components on my main PC.
I then perform tied the whole process with the BalenaEtcher on my Lenovo Yoga Laptop, which appeared to work fine. I initially produced two V3.139 flash drives - neither of which works.
The target machine to run Volumio is a mini PC from a company called BeeLink it has an AMD bios, which worryingly says Evaluation Copy on the flash screen at boot up.
I have tried both legacy and UEFI boot options, and neither drive worked.
I then tested on the Lenovo Thinkpad - same result.
I’m wondering if better quality USB 3 flash dives might be required?
Any ideas?

Hi Richard,

Here are old and cheap USB2 and USB3 sticks on board as well - and they all are working well. Speed performance does vary a lot of course. The first boot sequence of a freshly flashed image is always taking a long time because volumio resizes the file system according to the size of the stick. Larger sticks take longer time. You have to be very patient though. This process can take several minutes!

If you already have an existing, running volumio system you can use it to log into it via puTTY (a terminal tool for M$) and perform the “dd” command I mentioned above. On M$ systems I recently hade better results in using “Rufus” rather than "BalenaEtcher ". May be this is worth an attempt?


Good luck and take care,

Was going to suggest the same. I only use Rufus. I find Balena pretty useless.

True, an electron based app (400+ MB) for simple stuff is the classic “get stuff done, the hardware is powerful enough anyway”.
But in my books they killed it when they added non optional telemetry + sponsored content :wink:

These days, I prefer bzt / usbimager · GitLab

@Robert.Hecht I bought a known brand Sandisk 32GB drive, and it worked immediately, and was really quick, so shonky flash drives may be a problem to watch out for, or I may have caused a problem trying to flash them on my other PC. I bought 2 of the Sandisks, so I will now try flashing this on my other PC.
I will now see how well Volumio v3 works on X86!


Got to the bottom of not being able to flash on my main PC - Windows Security (defender as was) I was getting Protected Memory Access Blocked messages. I had these messages:
So I clicked on the Actions button, then Allow on Device.
Also, clicking the Controlled Folder Access Settings link takes you to where the blockage can be unblocked by clicking on Allow an app through controlled folder access:

I have now been able to flash the drive. Gonna try with the cheap memory sticks now see if it makes a difference.


I’m running the Volumio 3.139 on a Z86 box (atom) and everything is running ok, except the analog audio input. I’d like to connect my turntable to the analog port.
It appears on the web interface as bytcr-rt5651 and I’m able to select the input but do not have any audio input.

Does anyone have any idea why is it happening?

Thank a lot.


Here is the log: http://logs.volumio.org/volumiobuster/Ivc3oK1.html

I also tried to connect a M-Audio Fasttrack USB interface and also no audio input.

Any ideas?

Sorry for the confusion, I only read analog, not the “in” part :frowning:
Audio in is only supported with a select group of devices.
bytcr-rt5651 should not have been shown, that is still a bug.
Same for usb audio in, this is not supported either.

Hi Gkkpch,

Thanks for the update. Do you know which audio card is compatible?

I used the M-Audio Fasttrack on version 2 and worked fine. It is a little bit frustrating not to be compatible with version 3.


Are you sure we are talking about the same thing? You want to use an M-Audio Fasttrack to feed a Volumio setup with audio?
Can you repeat the log for the M-Audio?
Did you use mic-in on your intel atom box? If so, did you use amixer to enable and raise volume levels?