X86 Hardware issues (Graphics, WiFi, Onboard Sound, external DACs, Disks, BIOS/UEFI Boot problems etc.)

My Creative soundblaster x5 works but when I use a input device with toshlink than I get only one audio channel. Is this a premium future, an issue or incompatible problem?
I use volumio free X86 v3.611 on intel nuc10.

I hate to admit this, but we cannot help you here.
There is no soundblaster test equipment to work with, so x86 support in this case comes as limited as it does.
In other words, the x5 is unsupported input wise.

I connected Wyse to TV and works but Waveshare 11.9 have not signal. Is It problem with DP - HDMI adapter?? I ordered another but maybe Wyse and 11.9 is not good pair??

that is to bad than I can not use volumio as a reveiver for my tv device. Can you do something when I send you the log file? Or is there an other way to provide you data?I give you the logfile than you have more data about the soundblaster: http://logs.volumio.org/volumio/ED60WcP.html

this is what I get when I select audio input (premium):
error: Failed to execute browseSource, failure: TypeError: Cannot read property ‘then’ of undefined
info: sendMpdCommand stop took 3 milliseconds
pam_unix(sudo:session): session closed for user root
info: Successfully Stopped Audio Input
info: Enabling Audio Input 5
volumio : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/bin/systemctl restart audioinput.service
pam_unix(sudo:session): session opened for user root by (uid=0)
Started Audio Input Service.
pam_unix(sudo:session): session closed for user root
info: Successfully Started Audio Input
info: Notifying AUDIO INPUT
info: CoreStateMachine::setConsumeUpdateService undefined
info: CoreCommandRouter::servicePushState
info: CoreStateMachine::pushState
info: CoreCommandRouter::executeOnPlugin: volumiodiscovery , saveDeviceInfo
info: CoreCommandRouter::volumioPushState
info: MRS: Pushing multiroomSync output update for this device
info: MRS: Pushing multiroomSync output
info: CorePlayQueue::getTrack 0
info: Received update from a service different from the one supposed to be playing music. Skipping notification.Current ytmusic Received smart_inputs
info: CoreCommandRouter::volumiosetSourceActiveaudio_input/5
info: CoreCommandRouter::executeOnPlugin: my_music , getDisabledSources

But thank you for the information anyway.

Sounds to me it is an adapter issue, but can’t say for sure as mine are used headless. I only tried with a normal monitor for configuration purposes.

I’ve used this one:

Which worked with the Wyse 3040 and a old Dell monitor. No guaranties…
Not sure if connections are missing for a WS screen.

I tried with monitors and TV and worked but always with standard resolution.

Today I should have another adapter to check, if not works I change LCD to some standard format.

EDIT: I checked with another one bought by me and one more from my friend.

All three the same. After start Wyse blink 4 orange 2 orange it is code that means:
“Generic POST Video Error—Old LED pattern 1110”

Because I want to make some Wyse LCD Volumio streamer I find this:

P.S. I put this table to Wyse thread too.

The only thing I can think of is to open a terminal and start alsamixer.
Check whether L or R spdif is muted (displays ‘M’), press ‘m’ to unmute.

1 Like

I had to turn on the left channel in spdif in the alsamixer (arow)
I do not know what I did but the arow I had to turn down (echo), but now both channels are working.

Thanks for the support!


how do I save alsamixer settings?

update; I turned off system in stead of reboot than settings are safed ( I hope)

1 Like

alsamixer settings are kept automatically, nothing to worry about.

Is this a bug?
Volumio does not close and start always the right way. I have to disconnect powercord to fix things. I hope the log file does store this problem. So here my log:

I think this is only a problem with rebooting

When you shut down, press “ESC” to close the splash window.
Then you should see what Volumio is doing/ waiting for.
In certain situations (network down before other services??), I have seen the system waiting for a service stop job for 1min30secs.
Eventually it will shutdown.

that 1m30sec is only with rebooting. Than it hangs on the login screen. No splash screen. I did a live log but can not find the cause.
But any whay thanks for the info now I just wait longer after reboot.

No, no , don’t give up yet. Can you tell me the wait job message, perhaps make me a screenshot (picture)?

It is very strange the more I reboot the faster the reboot goes. The login screen is even to short to take a screenshot.
Can it be that the wait job is that the system sometimes have to wait for the extern hardrive? It is not always detected.

I also disconnected the usb-c hub and connected the extern drive directelly. That is what I changed today. Also I do not need a mouse and keyboard if volumio runs properly. So no usb hub any more

It does not always happen, when it does, press “ESC” and let us know what shutdown is waitng for. Bet it is the NAS connection, but need more proof.

From cold start the usb hard drive is not detected. Think that is causing the delay. After that the reboot 1:30 delay, and the content is back. After that normal reboot.

Sometimes youtube music is not login properly also. But think that is plugin issue.

Other conlcusion; Maybe the usb harddrive comes to late out of standby modus and volumio starts before the hardisk is out standby.

…I changed some bios settings, for example boot usb device first enabled I hope this helps

update: problem is still there.

I may have the wrong end of the stick here. but

When you select restart, is there any music playing ?

I see from your log you have FusioDSP installed.

I have noticed with my system that if I try and shutdown or restart while music is playing that it will hang for ~90 secs before doing so.
This started happening after FusioDSP was updated to 1.0.51.
Click stop or pause wait 3 second then restart and it stops it happening for me.

As said may be a completely different issue, but worth mentioning …I think

PLEASE press “ESC” after you shut down and let us know what you see.
We can’t solve it without your help, so it is important that you follow our advice.