X86 Hardware issues (Graphics, WiFi, Onboard Sound, external DACs, Disks, BIOS/UEFI Boot problems etc.)

Give us the specs of the pc then we can see :slight_smile:
First boot is the harddisk ,then your nvme after that your usb stick
On boot you could press f8 and select your usbstick

But nvme should be 1? Now it goes strait to windows on the rom drive
In this link is al the info I have about specs.


I already flashed the SSD But it does not boot.

To avoid a lot back and forward talking. Just take out the SSD, connect it to your PC and flash the Volumio image to it. Put ik back and boot the system.

Did he pick the good version the x86 ?

I don’t think he did.
He’s telling that he used the flash to disk option form Volumio’s System page, but he’s still booting windows. So nothing was flashed to the SSD.
As Volumio will overwrite what is on the SSD.

But volumio should be fully functional from usbstick am i right?
And his wifi doesn’t work …

If he boots from USB => Yes.
prob this is new WiFi hardware, for which no drivers are present in the kernel.

And will not be added? so he needs a dongle for that. (Ask if can be added )
Or use ethernet

And he has to take harddisk out.
Boot from sandisk ( set in bios as boot option #1)
Then from volumio press button to write image to nvme
After that set boot prio 1 to nvme in bios
Reboot and he should boot from nvme

Not sure, if he mention the hardware and drivers can be added to the kernel.
The x68/64 image is official supported.

I flashed the x86 image on my pc to ssd same result. Still booting to windows. NVME I do not use that is M2 SSD. So is hardisk selection the right option on 1? And I think bios has to be on Legacy?

I guess you’ve flashed to the wrong disk. Please boot from NVME.

But the Guru is responding below :slight_smile:

I flashed on my kingston SSD. I tried nvme # 1 but still no luck. By the way booting to USB goes with no problems

Unlikely, unless he’s using some odd external wifi dongle. V3.3 has support for all existing wfi chips, with drivers and firmware.
Hardware specs you need, otherwise you’ll be guessing until eternity…
If it shows I missed something, then I’ll add it (still doing x86 kernel/ firmware maintenance until someone else jumps in).

he posted a link to the manufacturer but with no details. No clue, it’s embedded on the board.

You might have to change device boot order in the bios when you have more than one ssd/hdd in it. Note: be very carefull in case you want to retain multiboot, that can get tricky.
We’re not installing Volumio, meaning not adding Volumio to an existing boot configuration, which in your case seems to be on one of the disks.

the disk where windows boot from is eMMC/SD. I do not want that to flash to volumio.

Do I need to flash ssd with rufus using balena till now.

there are few things wrong with this thread, too many issues for different platforms. Please seperate DAC and platform, post x86 issues in the x86 support thread. The first post there describes exactly which information is NEEDED.

now I am confused. Do not understand what information you need for the boot problem with ssd

This is exactly where the remark of gkkpch was leading to. DAC/WiFi/Disk/Boot issue.
it becomes very diffficult to support :wink:

Please do the following.

  • Get the details of the WiFi card
  • Remove the disk that contains the windows installation.
  • Boot from the USB thumb and setup volumio
  • Go to Volumio => System and flash to the availble disk
  • reboot without the USB Thumb. If this still won’t work, do the next steps while booting from the USB thumb again.
  • Enable SSH
  • Enable the logging
  • execute: lspci and post the results
  • Execute: inxi -Fxxxz and post the results
  • Post the url to the log

Remember dual boot will be a difficult job to accomplish.

I ca not remove the Rom drive with windows on it. Do not understand how to access the mainboard. I can remove and add the ssd and that is it.

Maybe I have to flash the rom drive from usb thumb?