Wireless Adapter Compatibility List

any ideas?

  • tripwr1964

I’m afraid I don’t have any ideas but I am also struggling with the exact same wifi dongle! I’m hoping that someone can help us out.

I have the Edimax EW7811Un in my Pi A+ right now but I also had the same problem in the B+. Volumio is v1.55 and it has been working faultlessly with a generic wifi dongle! I can get the Edimax to stream FLAC files from my NAS, this seems to be quite stable, but as soon as I activate AirPlay from an IOS Device it fails and disconnects. I also noticed the signal strength listed in Volumio webUI is only 14% despite being a few metres from the router?

After a failed AirPlay connection I struggle to connect to the Pi even using the webUI. I hope all this info can inspire one of you to come up with a solution.

I bought the Edimax as it is branded and came recommended for the Raspberry Pi! Not too impressed yet.


Adapter Name: Realtek RTL8191su
Chipset: Realtek RTL8191su
Driver/Firmware: Included in Volumio
Working with Volumio: Yes
Tested Versions and Platforms: Volumio 1.55
Comments: It cost only 12 euros but needs external USB power
Buying Link: http://www.amazon.it/gp/product/B00LASERXC
More on my Volumio project in my blog here (in italian): https://cfpmanfredini.wordpress.com/2015/08/02/crea-il-tuo-internet-music-player-con-raspberry-pi/
For make it running simple install wicd-curses like this:

sudo apt-get update sudo apt-get install wicd-curses sudo wicd-curses

Got it working!!
Got into my router settings and broadcasted my SSID. Works now! yeah
Didn’t like the hidden SSID for some reason.

Adapter Name: Edimax ew-7811un
Chipset: Realtek RTL8188cus
Driver/Firmware: 8192cu (per sudo lsmod)
Working with Volumio: Yes
Tested Versions and Platforms: Volumio 1.55
Comments: wouldn’t work with SSID hidden

I’ve just bought this usb dongle, but with Volumio 1.5 on Udoo quad the driver isn’t included.
I download the driver RTL8191su from dlink (it has some product with the same driver) and I followed this guide: wiki.debian.org/rtl819x#supported-r8712u
and also this: ubuntuforums.org/showthread.php?t=2164161 but the wifi dongle don’t work. I tried with openelec and it work well!
How can I do?


No one can help me?

I tryed with the raspberry of my brother to see which driver are installed and on which folder, I donwload some different driver and try to put inside the right folder, but still not work.


This is a compatibility list not a help and support page for dongles, please use an other thread.


I got this usb dongle: ebay.com/itm/161880385181?_t … EBIDX%3AIT
And it listed at first page but i couldnt make it work.
I have found some script they didnt work.
my dongle acts properly On windows and openelec running on raspberry
But couldnt success on volumio on raspberry pi b 1st gen

Please help

Adapter Name:TP-LINK Archer T1U AC450
Driver/Firmware: dl.dropboxusercontent.com/u/802 … 748.tar.gz
Working with Volumio: Yes 1.55
Tested Versions and Platforms: RPi2 & PiDAC+ (iqaudio)
Buying Link: amazon.co.uk/gp/product/B0159ED6L6

howto intsall
connect putty to ssh IP wired connction
login: root password: volumio

wget https://dl.dropboxusercontent.com/u/80256631/mt7610-3.18.5-v7-748.tar.gz tar xzf mt7610-3.18.5-v7-748.tar.gz ./install.sh

connect wireless:) via web interface

works ok with mp3 not with flac files
prefer to use wired connection

Official dongle does not work in 1.55 out of the box, but can be made to work.
shop.pimoroni.com/products/offi … ifi-dongle
Official Raspverry Pi Wifi dongle is based on BCM43143 chipset.

Thanks @ Jerry

the following steps worked for me.
step 1 was about 40MB so make take a little time to download.

THE below URL gets trunkated and you can’t copy and paste it so I’ve split the single command accross two lines breaking at the P char
sudo git clone --depth 1 git.kernel.org/p <----
—> ub/scm/linux/kernel/git/firmware/linux-firmware.git

full link is:
git://git.kernel.org/pub/scm/linux/kern … rmware.git

cd linux-firmware
cd ./brcm (only copy these firmwares)
sudo cp -R * /lib/firmware

remove the dongle.
Plug it back in after 10 seconds and you shoudl now see a device recognised as a network but it didn’t work until after a reboot for me.

TP-LINK TL-WDN4200 N900 Wireless Dual Band USB Adapter
worked out of the box on 1.55 on a 2.4 Ghz wifi with WPA2

Adapter Name: Cisco Linksys AE3000
Chipset: RT3573
Driver/Firmware: wikidevi.com/files/Ralink/dr … x_1005.zip
Working with Volumio: NO
Tested Versions and Platforms: Volumio 1.5
Comments: Didn’t succeed in compiling the driver mentioned above (see here)
Buying Link:

1 Like

Adapter Name: unbranded
Chipset: unknown
Driver/Firmware: unknown
Working with Volumio: NO
Tested Versions and Platforms: Volumio 1.5
Comments: works on Raspberry Pi 2, with OpenElec / Kodi, but not with Volumio.
Buying Link: aforyou.nl/wifi-adapter-usb-802.11-n

(VERSION: 0.976 - when did 2 turn into 0.X ???)

Official Raspberry Pi dongle working after installing extra drivers.
See previous update.

To get this working in the above version my previous instructions in this thread didn’t work.
Instead I copied the entire of the git cloned firmware folder into /lib/firmware/ and rebooted.

This fixed it. not idea, but quicker than looking for the specific driver.

Sorry I have a Digicom Wave 54, i found this link:
blogs.dotnethell.it/imaginsystem … 19397.aspx

My set-up:
Raspberry Pi 2
amazon.it/Raspberry-Pi-Mode … berry+pi+2

VERSION: 2.041
RELEASE DATE: 12-12-2016

problem with this zd1211-firmware
any idea to solve?


Adapter Name: TP-LINK Archer T2U AC600
Chipset: N/A
Driver/Firmware: 11/21/2013,
Working with Volumio: 2.118
Tested Versions and Platforms: Raspberry Pi 3, HiFiBerry DAC+ Pro
Comments: worked out of the box, no extra drivers needed. Did not work with USB-Data-Stick beside, took cable to put adapter to position with best connection. Then worked with USB-Data-Stick. Tested with Web Radio, Spotify and Spotify Connect, NAS (flac).
Buying Link: https://www.amazon.de/TP-Link-Archer-T2U-Adapter-AC-Speed/dp/B00K11UIV4/ref=sr_1_1?s=computers&ie=UTF8&qid=1490187644&sr=1-1&keywords=TP-Link+Archer+T2U+AC600 (TP-LINK: http://www.tp-link.de/products/details/Archer-T2U.html)

Adapter Name: ANEWISH Wifi Dongle AC Dual Band
Chipset: RTL8811AU
Driver/Firmware: bit.ly/2irNQhA (not needed with newer versions)
Working with Volumio: Yes
Tested Versions and Platforms: Volumio 2.141
Comments: Works out of the box on 2.141 (presumably driver has made it into the mainline kernel), however previous versions required modules compiled
Buying Link: amazon.co.uk/gp/product/B01G77I46G

Intermittent functionality upon reboot on 2.175, using USB hub works around the issue. Many messages similar to “Transfer to device 5 endpoint 0x1 frame 825 failed - FIQ reported NYET. Data may have been lost”. Couldn’t be bothered to debug further - fairly obviously an upstream issue.

Csl wlan 300 wifi dongle:

This cheap wifi dongle (about 10€) is working good in my audio system (Volumio 2.185 - rpi3 - Kali - Piano 2.1) without problems.
Works good with big DSD128 files…
is not enough for DSD256, I experienced stuttering audio…

Can you find the chipset (eg. from lsusb) please, so I can add it to list? I did Google it, but there seems to be more than one chipset in use. Cheers :slight_smile:

Same problems with my pc desktop… ill try again this evening… sorry…