[Bug? / Compatibility with Wifi USB dongle TP-LINK Archer T2U]

I would like to report a bug/compatibility issue i am having with a TP-Link Archer T2U.

  1. It is mentionned as compatible with Volumio out of the box here https://community.volumio.com/t/wireless-adapter-compatibility-list/1996/34
    Hence i purchased one.

  2. Yet, it doesn’t work with Volumio current stable version, nor Volumio development version (i tried a December version)
    Weirdly, when doing a “lsusb”, only “TP-LINK” is mentionned, not the chipset in the USB dongle.
    On the dongle, i can see written “TE7T2UV3”

  3. On the other hand, the same usb dongle is working out of the box with Moode Player 7.0 latest release.
    (That’s why i tried the development version of Volumio, just to see if an updated kernel from the 5.xx series would help compared to Moode Player. I might be totally wrong in my thinking)

  4. I see different versions being mentionned for TP-LINK Archer T2U, see http://en.techinfodepot.shoutwiki.com/wiki/TP-LINK_Archer_T2U
    which might explain the problem.

=> Is there something that could be done to improve the situation with Volumio, at least in future version ?
or is it better to consider other dongles ?

Thanks in advance
Hope the location of the post is OK as bug/compatibility for future versions