Wifi boot issues?

Anyone able to help me understand what might be going on here please?
Running Volumio 3.198 on a Raspberry Pi 4B 2G.
Having connected via an ethernet cable I have set a static IP on wifi and able to connect to GUI over wifi(after removing the ethernet cable) and all appears to works fine.
In the network settings I have enable hotspot “on” and hotspot fallback “on”.
When I reboot volumio(hard or soft) it does not reconnect to my ssid.
When I connect to the hotspot or via ethernet cable my wifi ssid is being seen and I can connect to the ssid and then to the GUI.
If I turn the hotspot off it would appear that the wifi just does not start.
Any pointers or guidance please?

Hi dippy1
Try to set the wifi channel on volumio to the same channel your wifi router is using. Then it should work.

Thanks for suggestion but short answer is no - does not make any difference.
To keep it short the only way I have found that wifi seems to connect to my ssid when booting up is to turn off the hotspot capability and use dhcp for the wifi!
As far as I can see other settings combinations won’t connect to wifi at boot.
Very odd…I may dig into network config files at a later date…

CORRECTION - Volumio does not connect to wifi at all !!! After a number of more reboots (power cycle) I cannot get it to connect to wifi consistently. If I connect via an ethernet cable and then manually connect to the wifi all is good …till the next reboot.
I have tested using the latest raspios and don’t appear to have any wifi issues at all with that OS on the hardware so I think I can eliminate hardware issues.

As an aside I am on channel 13 for wifi (uk based) but I did tests on a lower channel too with the same results. Builtin hotspot will only go up to channel 10 meaning it does not pay any attention to the settings that enable channel 13 as detailed here [SOLVED] RPi WLAN Channel 13.

Hi @dippy1 not sure what it is in your settings that is causing this. In this post I explained my way of making my wifi stable. It now works every time.

EDIT: click on the message link to read it, otherwise it’s all squashed up!

Hi @SimonE that did not work for me.
For those that might be interested I have now got it working well enough.
Basically I changed the SD card I was using!
I was using a class 4 one! I know! I know! Don’t shoot me!
I changed to a class 10 one and things got better BUT
if you have a fixed IP set for ethernet and no ethernet connection the wireless will not connect at boot but you can start it up manually from the GUI.
Leave the ethernet setting on dhcp and all is fine!
So I now have a fixed ip on wireless and it connects to my ssid at boot - happy days!

My guess is that the sd card issue is a timing and start up of services issue.

Great that you got it working.

Volumio works fine on a class 4 sd card.
I now believe it was this that was causing the issue;
“if you have a fixed IP set for ethernet and no ethernet connection the wireless will not connect at boot but you can start it up manually from the GUI.”