[SOLVED] RPi WLAN Channel 13


Tried to connect my WiFi to a Raspberry Pi 3 running newest volumio image.
The RPi WLAN module is not able to see my 2,4Ghz or 5Ghz WLAN. After trying several times, I found out my Fritzbox WLAN is configured to automatic channel search, which is at channel 13 at the moment.

Is there a workaround to teach the RPi 3 to connect to channel 13 or 5Ghz ?

1 Like

Okay, little dissapointing.

Turns out, rpi has to be set to european union to use channels 12/13.

For this, I have to execute rpi-update and afterwards sudo rpi-update 41f8b4812ad653abf321b8c54cb4bee57ebdb129.

This changes to a different linux tree.

After executing this, I am not able to reach volumio (browser, ssh).

Is there a way to execute rpi-update and using volumio?

Yes, it’s recommended to stay away from rpi-update in Volumio!

For wifi regional settings, you can do it under ssh or console for now.
2 options:

  • (preferred) set proper xx country code as REGDOMAIN=xx in /etc/default/crda
  • add country=xx (same 2 letter code as previous) in /etc/wpa_supplicant/wpa_supplicant.conf
    and restart
1 Like

Worked, thanks.