Volumio2 and Hifiberry-amp3

Volumio2 and HifiBerry-amp3

My experience:
Recently I bought a HifiBerry amp3 for my Raspberry3b with Volumio2, version 2.917.
Normally I use the HifiBerry-amp2, but it was not (anymore) available. Hifiberry-amp3 should just work with the setting HifiBerry-amp2, I was told.

After the first configuration of Volumio2, I had sound. Beautiful, I was happy again; until I restarted the Raspberry. I had no sound anymore but got the well-known alsa errors.

Solution: Insert the SD-card into your PC/laptop. Go to the “config” file. On the last line you can see that Volumio2, after the restart, changed your setting “hifiberry-amp2” to “hifiberry-dacplus”.
Alter “dacplus” to “amp2” (not “amp3”) and write the modified config-file back to the SD-card and everything is ok, also after a restart.

1 Like


I had an AMP2 successfully in use. Have now built a second system. RPI4 and AMP3. Unfortunately the AMP3 needs at least the kernel 5.15.24. When will Volumio bring this kernel?

Otherwise, is there an alternative solution? Update the kernel manually maybe? I do not know Linux unfortunately.

You can use temporarily the amp3 as an amp2.
Therefore alter, after the first boot, the config file on your sdcard with your pc. In one of the last lines you will see HifiBerry-xxx. Change that in HifiBerry-amp2 and save the sdcard. From now on your amp3 acts as an amp2.

1 Like

Unfortunately, this trick was not successful.


Everything looks good on the software side, but no sound comes out of the speakers.

Try different Mixer type (s.a. “no”) under volume options in the settings.

I have tried, no success.

Now I noticed that I already have Volumio 3 installed.

Tonight I’ll try the Volumio 2 version.

I found very hard that a DT-overlay made for the TI amplifier of the amp2 will work on the INFINEON amplifier of the amp3, they need a totally different driver

would be good to have support amp3 too, may somebody can add the necessary drivers? As there is already a lot of Hardware supported I is maybe not such a big problem for the team?

In that case, will the Merus amp selection not work?

the MA12070P amplifier used on Merus HAT and Hifiberry AMP3 requires two pins to be set, on top of the I2S and I2C connections (!ENABLE and !MUTE). If those two pins are mapped to the same RPi GPIOs, the Merus AMP selection might work. If they are mapped to different GPIOs, it won’t.

Unfortunately I don’t have an AMP3 to check, best thing to do is just try

1 Like

… and, did it work?

No. I’m also unfortunately not an IT expert to do Darmur’s workaround.

Maybe someone else can be found.

no need to be an expert to perform the test I suggested, just select MERUS-AMP, reboot and see if it works

1 Like

Hi, i will test it maybe today or next days and give you feedback. thx for try to help

I tried with the Merus setting, I had no success with that either.

My trick works. You need Volumio2 !!!

I tested it with Volumio2 at the weekend. On the Internet I found the following version for download. 2.9.17-2021-10-6. After installation I found no Volumio wifi to set up via several ways.

@Wallgarden, what version are you using and can you possibly send me a link to your version?

// https://updates.volumio.org/pi/volumio/2.917/volumio-2.917-2021-10-06-pi.img.zip

Thanks, but this is the version I tried.