Volumio x86 on Intel NUC


this is my first post here but I’ve been testing Volumio x86 images for some weeks now. On my old system I could easily boot via M.2 SSD after writing the x86 image to the SSD via dd. Now after getting an Intel NUC for the exact same purpose I can’t boot after writing the image to the SSD.

Platform: Intel NUC5PPYH
BIOS: latest
Image: volumio-2.201-2017-06-14-x86.img
Drive: Samsung EVO 840 1TB

I tried both just dd’ing from a running system to the blank SSD as well as booting the NUC from USB with the very same Volumio image and dd’ing the unpacked image to the SSD as suggested in the guides section here. In both cases I can’t see the SSD in the NUC’s BIOS after writing the image.

Re-inserting the SSD into another machine I see three partitions intact but gparted offers to fix the GPT - which does not help though the SSD will again be visible in the NUC’s BIOS.

Any advice maybe?

Thanks in advance!

Seems to work now - but I can reproduce the error every time I write the image to the SSD.


  1. Boot Linux (e.g. Volumio image from USB install, Ubuntu live CD,…) or use another PC
  2. Write image to SSD using dd (same process as for USB installation)
  3. Start gparted to auto-fix GPT partition table
  4. Enable UEFI boot in BIOS (needed for GPT support, drive will show up and boot in legacy anyway?!)
  5. Restart

If UEFI boot remains disabled, starting Volumio is still possible through the F10 boot menu. However, it seems there’s no way to automatically boot on device power on if it’s not enabled.

Doing gparted should not be necessary as I coded that in initramfs and gets executed on first boot.
This moves the GPT backup partition table to the end of the disk before doing anything else like factory copy, resizing etc.
Can you try without?

I tried it several times yesterday. After writing the image to the SSD with dd (including sync and whatnot) I cannot even see the SSD as a device in BIOS - neither in the UEFI nor in the legacy section.

Probably best I test my NUC with the latest release, who knows…
Mine is an older type though: D34010WYK

Well, mine died yesterday so you might want to wait until I try with a replacement unit before you do excessive testing.

Worked with the replacement unit on my first try. Same USB drives, same SSD, same NUC model, same procedure… guess I’m lucky the device actually died :laughing:

Case closed. Thanks for reading.

nanana, you’re not getting away that easy :smiley:
Are you using the LAN port or wireless, which LAN hardware does it have?
Wireless is listed in the specs, LAN isn’t.

–Gé –

fair eough. I was using LAN for the first tests but failed getting wifi to work. Planned to use hotspot for remote control but activating either wifi feature will make networking stop completely. Found out why, i think… driver seems to be missing.


Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)


Network controller: Intel Corporation Device 3165 (rev 81)

So, any chance to get this integrated in the standard x86 kernel maybe? I’d be willing to beta-test of course.

//EDIT: On the “network stops working” issue: let me know if you need details. I can reproduce the error via the Network Settings any time.