Volumio SD card not detected by Rasberry PI4

Strange issue. I have flashed Volumio 3.179 via both Rasberry Pi Imager and BalenaEtcher. I successfully installed 3.179 on a new RPI4 4Gb to work with a HifiBerry DAC2 HD but wanted that 4Gb RPI for programming so i bought a 2Gb RPI4.

No matter what source of OS flash (Etcher or Rasberry), the 2Gb RPI4 will not recognise the flash. The same SD card flash of Vol3 is instantly recognised on the 4Gb PI.

The 2Gb RPI4 will happily load the normal Rasberry OS and other programmes. I have even done a EEPROM restore but still no luck in getting Vol 3 to run. Have tried 16Gb and 32GB SD cards and same result.

Both RPI4’s are using Arm64 OS. Any suggestions. Must be something fundamental I am doing wrong because the SD card works on the 4Gb and yet the 2Gb PI will accept both 32-bit and 64bit OS flashes? This request was posted via the 2Gb RPI4 so it works!!

Do you see any flashing of the onboard leds?
Are you able to attach a screen to see if there are any messages displayed?

Hi Wheaten - when nothing was happening in the headerless config I hooked up the HDMI display to see what was happening. On the 4G RPI4 I will see the Volumio banner followed by the password request. On the 2Gb you get the Rasberry Pi Log and barcode and a list of config checks. It looks to be recognising the SD card but there is a comment that says the software is outdate and I should go to the Rasberry.org website for the latest software

I should say I am using the 2GB RPI4 to write these replies

Are you able to reach a prompt. As I think your board is a V1.5 you need a different image.


Here is the corresponding topic:

Very much appreciated. Will give it a go

just checked the error message and it says the same thing start4.elf: is not compatible. Will flash the update and see what happens. Very much appreciate the support. Dave

The update worked. Cannot understand why the 2Gb board would have an issue and the 4Gb not. Many many thanks


There is no issue, the new board has different HW.

To check: Active SSH on both and type

I expect the 4GB shows < V1.5 and the new 2GB shows V1.5


will take a look,. Thxs

Please report back, it will help other folks.

Not sure if you tried this once flashed the put into your raspberry pi 4 2gb first
Go on your PC mac linux look in your dropdown list of wifi to see if volumio is showing up
Make you have turn off all you other raspi volumio machine. If come up your know it’s working give it 5mis to 10mins to come up just user name volumio password volumio
Have browser open it should open if it’s no working try again a complete new card not use so you no it should. Sorry I haven’t had this problem and only raspberry pi 4 8gb 4 4gb and raspi zero w all work. If anyone else with a rasp 4 2gb has had the same problem please comment.
Hope this this helpful .

Hi Jimbo The upgrade suggested by Wheaten to 3.194 worked fine. Did not release the 3.179 worked only with the 4GB RPI. All good now.

i’ve a 2GB Pi4 and neither of the current nor 194 image are working. I get some brief code on the screen that i think mentions timeout but then it goes blank and does nothing

Is there any pattern with the RED and Green LED’s on the rPi?
Like described here?

Green is flashing constantly but I’ve nothing on the attached screen via hdmi. I’ve no issues with any other cards in this pi so it has to be this install, just no idea where to look

Please try to reflash with either Win32DiskImager or Raspberry Pi Imager. Seems something went wrong during the writing of the SD card

i’ve used balena etcher and the RPI imager, neither have resulted in anything different. it appears to have card activity for about 5/10 mins then just stops. i’m trying a different card currently but both are brand new…

i’ve tried a different distro (retropie) on the same card and its fine, so i currently suspect the video out is not within a range the HDMI / TV is liking. Is there any way to amend that manually?

UPDATE: (hit the topic limit)
got connected via the hotspot and configured things but still have no HDMI output. Touch Display is installed but has made no difference :S

HDMI is only default available for the x86 version of Volumio. For rPi you need to install the plugin “touch display”