Volumio not working on Raspberry Pi 4 rev 1.5 board - start4.elf not compatible


I just received a Raspberry Pi 4 Model B - 2GB and tried to install volumio, but it is failing to boot. The error is: -

start4.elf: is not compatible
This board requires newer software
Get the latest software from https://www.raspberrypi.org/downloads/

I re-flashed the SD with latest raspbian and it boots up fine.

In /proc/cpuinfo the board info is: -

Hardware: BCM2711
Revision: b03115
Model: Rapsberry Pi 4 Model B Rev 1.5

I setup a player two weeks ago with Rapberry Pi 4 Model B - 4GB with no problems. Checking /proc/cpuinfo on that board: -

Hardware: BCM2711
Revision: c03114
Model: Raspberry Pi 4 Model B Rev 1.4

Does anyone know if there is a workaround, or is a known issue?


Very odd. My newest Pi4 is the Rev 1.4, so I can’t replicate. Did you flash using Raspberry Pi Imager? That is more reliable with Volumio than Etcher.

1 Like

Hi Simon, thanks for responding.

I tried again today and with the RPI Imager I get a different error - Firmware not found. Maybe I am doing something wrong? I did try twice and safe eject sd card.
I went back and did flash of volumio using balenoEtcher and got back to the start4.elf error. So consistently getting the two different errors with the two different methods.
I also flashed latest raspbian os onto same sd card using RPI Imager and it booted with no issues.
I tried copying the start4*.elf files from latest raspbian sd onto volumio sd (something suggested on internet when looking up start4.elf errors) but that didn’t work either - stack trace and an error re. memory deadlock.
It does look like there is an issue with volumio os and latest revision of rpi boards.
I’m guessing as more rev 1.5 boards get out into the wild, this will become more of an issue, so hopefully a fix will be forthcoming.



Did you say you have other Pis running Volumio? What happens if you try swapping the sd cards? Can’t think of anything else to check, other than the things you’ve already tried. Hopefully someone else with a 1.5 board out there reads this.

I do have one running fine on Pi 4B rev 1.4 - haven’t tried swapping out the SD from that yet. Will give it a go, thanks.

make a backup first, of the working one. :slight_smile:

wise words :slight_smile:

let’s hope it’s not related to V1.5, as it is very hard to get an rPi nowadays due to component shortage.

I doubt it will work. I read that the newer rpi 4s need newer firmware that probably did not come with Volumio 3.

It didn’t work, unfortunately. Same start4.elf error.

seems @volumio Dev’s need to recompile the kernel for the new rPi V1.5. The delivery time for a rPi is long nowadays…

1 Like

thepihut.com have them in stock at the moment - I’d been checking their site daily and they came into stock on Friday. Only the 2GB model and one per customer. That’s UK-based though.

Saws them, but paying 60 euro for a rPi4-2G…

I have it working now. I had a look at the raspberry pi firmware git repo and saw a commit 11 days ago that affected 16 files including start4.elf. I copied just those 16 files (fixup*.dat and start*.elf) over from latest raspbian onto volumio and it booted fine. Music playing, so all sorted.

Thanks for all your responses!


I’m currently going through the same issue, however have been unsuccessful finding the same git repo you located. Do you still have the issue link to be shared?

This is the link to the git repo, but I just used this for reference - to identify which files had changed in that commit.

What I did to resolve the issue was flash volumio 3.179 onto one SD card (using balenoEtcher), flash the latest raspbian onto another SD card (using RPI Imager) and then copy those 16 files from the boot partition on the raspbian card over to the boot partition on the volumio card. You can do it without using 2 cards - just flash raspbian onto SD first, copy those 16 files onto host computer, then flash volumio onto SD and finally copy files from host computer onto volumio SD.

1 Like

Thanks for the heads up guys.

We made a test image with the latest PI kernel, which should be compatible with 1.5

Please be aware that:

  • This image might not work
  • We ask if you can test with your 1.5 PI and let us know if that works
  • Don’t manually change the elf files or download anything else.

If you like to test, please report to us if:

  • PI 1.5 works
  • You have any kind of issue



1 Like

Sure, no problem. I’ll test it out and let you know.

Please move this to the top of this topic…

1 Like

I tested this out and it works fine. Raspberry PI booted fine, went through 1st time setup wizard, tested playing my local library and also Spotify plugin. All working as expected, thanks.