Volumio playback issues

Hello, I’m using Volumio 3.301 on my RPi3 with Hifiberry DAC 2 HD and Official Touchscreen. Sometimes I’ve got such issues:

  1. playback stuck - time ticking - no sound,
  2. wrong track showing on web and touchscreen,
  3. playback stops… then continues after sometimes without any actions from my side, in such situations I’ve tried to control Volumio via Web or/and Touchscreen - but can’t do it.
    I’m using NAS (smb source) as Music Library source. Volumio connected to the same network switch with cable.
    Maybe someone can suggest me how to resolve this issues.
    PS Generally I’m satisfied with Volumio, thanks for your work
1 Like

You’re experiencing buffering and stuttering, most likely a network issue - either your Volumio system’s network connection, or the connection to/from your NAS. Or both.
If you’re using wifi, try repositioning. If you connect (as a test) via an ethernet cable, does the problem go away? Sometimes the Pi case, especially metal ones, can reduce your signal.

Edit. Just re-read your post and you are not using wifi. Maybe the network switch?

1 Like

I wrote “Volumio connected to the same network switch with cable” and I don’t think it’s network issue

Yes, sorry, replying on the move and didn’t read your post properly.

Same problems if you play from a source other than the NAS?

Yep, tried connect USB-disk

Sorry, more questions. Did it work ok before? Did you change anything in the system? Do you have another PSU you could try?
Maybe try a basic config without NAS and touchscreen and see if the problem is still there.
Run df -T -h from a command prompt. Is there free space in the overlay?

So, I’m back after several days of testing… I’ve used USB-disk as storage, situation (3) when Playback stops almost gone, but still persists (rarely).

Sometimes after booting I can see such message when try to start playing something:
Reboot helps me, sometimes 1 reboot, sometimes 2…

Problems (1) and (2) still persists…

login as: volumio
volumio@’s password:
/_ \ __
__ __ //\ \ __ __ ___ ___ /_\ ___
/\ /\ \ / __\\ \ \ /\ \/\ \ /' __ __\/\ \ / __
\ \ _/ |/\ \L\ \
\ _\ \ _\ /\ /\ /\ \ \ /\ \L\
\ _
/ \ _//_\ _/\ _\ _\ _\ _\ _/
// // // // /////////___/

         Free Audiophile Linux Music Player - Version 3.0

      © 2015-2021 Michelangelo Guarise - Volumio Team - Volumio.org

Volumio Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Welcome to Volumio for Raspberry Pi (5.10.92-v7+ armv7l)
volumio@volumio:~$ df -T -h
Filesystem Type Size Used Avail Use% Mounted on
/dev/mmcblk0p2 ext4 2.5G 424M 1.9G 19% /imgpart
/dev/loop0 squashfs 363M 363M 0 100% /static
overlay overlay 27G 1.1G 24G 5% /
devtmpfs devtmpfs 445M 0 445M 0% /dev
tmpfs tmpfs 484M 177M 307M 37% /dev/shm
tmpfs tmpfs 484M 9.0M 475M 2% /run
tmpfs tmpfs 5.0M 4.0K 5.0M 1% /run/lock
tmpfs tmpfs 484M 0 484M 0% /sys/fs/cgroup
tmpfs tmpfs 484M 0 484M 0% /var/spool/cups
tmpfs tmpfs 484M 3.1M 481M 1% /tmp
tmpfs tmpfs 20M 52K 20M 1% /var/log
tmpfs tmpfs 484M 0 484M 0% /var/spool/cups/tmp
/dev/mmcblk0p1 vfat 92M 55M 37M 60% /boot
// cifs 56G 19G 37G 34% /mnt/NAS/t1nk3r
/dev/sda1 fuseblk 239G 133G 107G 56% /media/exSSD
tmpfs tmpfs 97M 0 97M 0% /run/user/1000


We are aware of this issue and we are currenty investigating. It impacts qobuz and tidal, when a specific track is selected from an album. When there is news about the ETA of a fix we will let you know.

In the mean time, as a workaround please click on the Play button next to an album to play the whole album, or the big play button on the top of the album. You can navigate to your favorite track using the transport controls.


Apologies for the inconvenience

1 Like

The issue is related to our hosting infrastructure. It seems some update happened there which causes this issue. We have contacted their support and we hope for a swift solution. :pray:

Is there any way to check SoundCard? As I said, periodically I can see message with error accessing ALSA Device…

I’m having this same issue with Tidal and it also happens when clicking on a big button to play an entire album.

So, in my case problem was related to Power. I’ve connected Display and Board+DAC with 2 separate PSUs and everything started work well.