Volumio on Mac Mini

Not sure if this counts as DIY but couldn’t think of a better forum location; please move if this isn’t the right spot.

Was a happy but occasionally frustrated Raspberry PI 3B Volumio user for the last 9 or so months. I was astonished at what this software could accomplish, setting a web server and easily accessible over AirPlay for this iPhone and Mac user. WOW.

But I had enough performance/lockup/crashing issues (not a complaint!!) on the Pi that i thought about moving to a another small format CPU with more resources. I picked up a 2010 Mac Mini (the last year before they went to the CD-less format) for about the cost of a pair of paper clips and thought that this might do the trick.

The Mac has 4GB RAM as opposed to the RPi 1G with a 2.66GHz Core 2 duo CPU as opposed to the RPi ARM processor, so why not?

Loading the software as the running OS was a little bit trickier than I thought; I thought I could boot it off of a USB flash drive but what came up was not workable. Finally flashed the PC Volumio OS to a micro SD and then booted the Mac off of that (via a USB --> SD adapter). Volumio has the great “Install To Disk” feature that worked perfectly.

The OS boots on the Mini smoothly, and displays to a monitor with keyboard and mouse control by default. The logitech mouse via the Logitech receiver did NOT work well, but an old school wired USB mouse (always keep one handy!) did the trick.

Some learning experiences:

  • Volumio doesn’t have drivers for the Mini WiFi functionality, but it works with the Ethernet interface smoothly. I recall from running Linux on Mac earlier that a Broadcom driver is needed for the WiFi; gonna poke around to see what I can do about that.
  • The default volumio.local address works smoothly when wired to the house router. The web interface is just plain old snappy and faster than on the RPi. The phone web browser interface is still a little slow but better than through the RPi.
  • Rescanning the external drive files and building the database was quick; that’s meaningful with 21,000 songs.
  • I got some sound output issues early on as I was playing via the Mini’s headphone jack, with very very low volumes. A system Factory Reset did the trick and it’s been stable with no lockup or performance issues since then.
  • The unit supports AirPlay perfectly, which is great for playing problematic sound files straight from the laptop instead, such as…
  • …this setup can NOT play hi-res files, such as the 24/96 files I have. Attempts to do so result in very little more than stuttering.
  • Not all of the Plugins I saw on the RPi version are accessible; in particular the Equalizer plugin doesn’t show up.
  • Sound Quality out of the Mini is better than I expected; kudos to what I understand to be Volumio’s bit perfect capabilities. I’ve been using it to drive the Amp Camp 1.6 that I just completed in an ad hoc living room setup with an old pair of Heresys and it all sounds great. I know with the Mini that I lose the simplicity of the on-board RPi DACs that are out there, but I’m in the market for an inexpensive USB/optical DAC anyways.

Very happy with all of the above. As I’m limited to Ethernet connections only, gonna try and see if it works smoothly in other areas of the house via a WiFi repeater. Meanwhile I’ll poke around the site further and see what’s up with system-level mods and driver installs.

Anyone else with Volumio on a related unit? Would like to see what else is out there.

1 Like

You may want to try a dev version from this page
There are quite a few improvements regarding drivers, with a bit of luck your built-in wifi will work too, it is stable and has been tested by quite a few members.
And in case you’re really adventurous, watch the forum because a beta Volumio version, based on Debian stretch, with all current drivers and firmware will be released soon.

1 Like


I loaded volumio-2.416-2018-07-08-x86 several days ago through the method I referenced earlier. Some notes:* There’s still no WiFi access; I can turn “Wireless Networkin” on but the setting does not persist. Ethernet is still solid though!

  • 24/96 files now play perfectly! yay!
  • USB output is still incomplete. I use an NAD DAC-1 device to send music to the bedroom from the Volumio device in the living room; it consists of a sender connected to the Volumio device via USB, and a wireless receiver/DAC. The sound continues be just a stutter. Otherwise the system seems to respond about the same; I think it’s a little quicker on the mobile phone browser than it used to be, which is a good thing. It’s still snappy on the laptop browsers.
  • Half of the radio stations that I choose do not play and eventually the system responds with a timeout error. KEXP, KMHD, Ambient For Sleep and Radio Paradise come through great, but the Linn and Naim stations do not.
    I much appreciate the news of updates and look forward to trying later devs when ready. Should I also post in the “Compatible x86 machines” forum?

Thanks again

Could you do an “lspci” in a terminal session? This would help determining what wfi module is in your mac mini

Does this work on any other device (PC?) without stuttering?

Difficult to do proper support for a Mac Mini when you not have one :unamused:
Anyway, it would be better to continue in the “Next-X86” thread I pointed you to.
That is where I will continue with x86 (but this can take a while).


I’d like to create a similar configuration with my old 2006 Mac Mini, but I could not resolve my main problem: configure the boot sequence in order to run Volumio by pressing the power on button.

How did you do?
Did you start directly in Volumio or you have to do some tricks to run it?



it should work with a more recent kernel, as it was running on mac’s with previous experimental versions (which we abandoned in favor of Debian stretch/ buster porting versions) . I do not promise anything, but send me a mail at volumio(at)bluewin.ch and I’ll organize 2 test versions for you, curious how that works out…

A very late response. But I also have an old mac mini that I want to put volumio on.
I flashed the latest X86 version on a USB stick.
However when I want to boot from the USB stick it gets stuck on the next screen. Any idea what I can do about this?

1 Like

Please explain what “latest” version means, the official download?
Mini macs are being used by several members, not having one makes it difficult to help.
You may want to try our early pre-beta volumiobuster-2.857-2020-12-11
Though we are much further meanwhile (V3.0xx), we’re having hiccups with the latest beta, which makes it of no use for you atm.
The advised version is just top check whether you can boot properly, we’ll take from there.

I now had version: volumio-2.873-2021-02-19-x86.
Good to hear that there are several mac mini users on which volumio works. That inspires confidence.
I will immediately test it with your version. I’ll keep you informed.

10 points! The version you sent works. Thanks for that.
However, I am unable to mount to my NAS.
On my raspberry with volumio, this works. But on the mac I don’t get the NAS added.
This should normally be possible?

And if I were to purchase a separate USB DAC, can volumio handle that too?

For NAS issues, please do a fresh boot, try adding the NAS share and then submit a log.
Post the link here.
Howto: Send a log

USB DACs will work with Volumio, Linux has a standard USB Audio driver which covers most of these on the market. Refer to the compatibility thread in this forum, when it says a particular USB DAC works, then it does not matter whether that was said for PI or X86, with the latest kernels and Volumio versions, PI and X86 support the same devices.

Unfortunately, I am unable to add to the NAS. I have done the exact same settings as on my PI.
Below the log file.

Furthermore, a few things that I do not fully understand yet.
I wanted to install volumio on the hard disk. This took a long time (almost 4 hours) and at the last minute I get this message:

Then I clicked this way. And I shut down the system.
For the test, I took out the boot USB and restarted the Mac. Still, Volumio starts up and I can just listen to my internet stations. Isn’t this weird? Is volumio installed correctly now?
Furthermore, I don’t see any plugins when I open them.
This is the case with my PI variant.
And is it also possible to use the mac’s CD drive to play CDs?

don’t worry too much about the errors you get, this one was to try getting the mac mini to boot remember?
Zie in je log niet waarom het niet werkt…

My advice, try again with the later versions, you could use this one, should cover it little more, perhaps even analog sound or spdif.
Boot, run through the wizard but do not add an nfs share yet (we have an issue here). Reboot and then try adding a share.

Note, we are not aiming at supporting mini macs, but do our best to integrate them as well as we can.
Installing to local disk should now be less than a minute.

Unfortunately I get the following message while booting this version. So this is not going well.
Where can I find previous versions of volumio?

1 Like

Now I also get the error message with the NAS on my Pi variant. This has worked well until yesterday.
Foutmelding Volumio

1 Like

Please, please do not start putting RPi problems in an x86 thread, otherwise we are going to have a mess soon!

There is something very wrong with the device you were booting from, I do not see whatelse could cause these kind of errors.

Okay, you’re right. I will move this to another topic.

Okay, what to do: I download the .img zip file. I unpack these.
Then I write the .img file to the USB stick with Rufus.
This should normally be okay, right?
And if I then want to write a new .img to this USB stick, can I do it in exactly the same way? Or should this USB stick be completely erased first?

What also strikes me is that the topic starter says that it was not possible to boot from USB stick. But from SD card. Is there a logical explanation for this?


There could be an issue with reflashing an already flashed usb stick/disk with x86, you’re not the first.
Better erase and retry.

1 Like