Volumio on Mac Mini

It would be more the other way around: there are only a very few x86 boards which are capable to boot from an SD card.
You already booted an earlier version from USB, so you should be OK.

Unfortunately. Just erased the entire stick and put the .img file on the stick again with Rufus. Unfortunately the same result and get the same notification as in post 13.
To be clear, this applies to version Volumiobuster-3.058-2021-04-10x83_amd64.zip

For the test I also tried volumio-2.873-2021-02-19-x86 on another stick.
I do get to see the Volumio screen (that was also the case with this version), however, after a while 2 pink bars appear at the top right of the screen. And nothing more happens from this moment on.
I don’t understand anything at all anymore …

1 Like

I honestly don’t know what is wrong.
Mac Minis are not officially supported but we are interested getting these working as well, albeit with a less higher priority.
I would like to continue this after the Volumio 3 beta phase is finished, hope you understand.

1 Like

Okay, I understand that. But can I find older X86 versions somewhere to test with? Since one of the previous versions you shared on this forum works, but unfortunately I still have problems with the plugins. Perhaps it can be solved for the time being with an older version from 2020.

that is not of much help, I built so many :slight_smile:
Was it an early Volumio Buster beta version (volumio2)?
Then try the Development section, Volumio 3 Beta testing, 3.066 is fairly stable,

Sorry, I mean this version you shared: http://updates.volumio.org/x86/volumiobuster/2.857/volumiobuster-2.857-2020-12-11-x86.img.zip

Then try Volumiobuster-3.066-2021-04-15-x86_amd64
Report any issues in the appropriate beta thread in the Development Section

This one seems to be working completely fine. Even NAS is recognized.
However, the Plugins do not work. Is it true that this is “normal” with Buster versions?
Is there a way to add Spotify on this system?

1 Like

plugins for buster are work-in-progress, currently you are not allowed to install plugins on beta versions as they often install additional software libraries or replace them with versions which the base system cannot handle.
The limitation helps us when there are issues without the risk of stumbling over unexpected additional software.
This also means we ignore support questions about plugins until we release them.

Okay clear. Version: 2.873 is the only official X86 release in which plugins work? And I can no longer download an older version than this for the test? Since this version don’t boot on my mac. (Incidentally, with the same USB stick with which Volumiobuster-3.066-2021-04-15-x86_amd64 works)

Volumio 2 and Volumio 3 beta are using completely different kernel( OS) versions.
Volumio 3 is up-to-date with drivers and firmware, that is the reason why it works and Volumio 2 does not.
We can only ask for patience, there is no way to get plugins working otherwise (in your case).

Okay. Thank you for the explanation

Also have old Mac mini (2009). Installed the above version and as stated it works. I have also installed other versions that works, however they all give me the same results, the sound emits from the inbuilt speaker rather than the optical sound port. Any ways around this? Else I’m done with Volumio after spending countless of hours searching info on this issue … :slight_smile: Thanks in advance.

Best regards,

1 Like

Succeded to solve it by using alsamixer to activate the spdif. Will it stay activated now or will i have to activate everytime I restart the application? /Cheers /Martin

it should stay activated.
Better would be if you could give us the result of

aplay -l

With the information, we can add a sound card profile and unmute spdif at boot time.

I don’t understand what I’m doing wrong anymore. If I read here, others succeed in getting Volumio running on the mac mini.
But I currently have another mac mini in my possession. With my previous mac mini (late 2009 model) it also failed to install properly on volumio.
I now have another mac mini, mid 2011 model, i5 processor and 8GB memory. Should be enough anyway.
However, I get the same boot problems as last time. During boot I choose the USB stick that has Volumio on it. Then the next screen appears, which then jumps to black and nothing else happens.
Anyone any idea.
I have now tried this version; version: 3.175

Does your BIOS support UEFI and can you activate it and retry a boot?
There was never a guarantee that it would work on a mac mini, not even that it works on all thousands of x86 configurations out here. If the x86 works for some mac mini users, good. But I’m sorry when it does not for others, there is nothing I can do.

Don’t own a mac mini and I do not plan to buy one for support.

1 Like

Oh, this is a UEFI boot already, did not realize that when looking at the image the first time.
Makes it more difficult, any linux command line skills? We’ll need some :grinning:

Okay, I’m a little further now. Now what is the problem, the mac does not output the GUI via HDMI. That’s why I didn’t see anything on my screen.
However, this “black” image seems to be outputting as the display continues to see input and does not turn off.
But somehow I don’t get to see volumio on the screen.
Via the ip address volumio can be reached via my smartphone.
A few things that don’t work or don’t work right now:
-GUI over HDMI does not work
-no Spotify plugin?!
-output I have to set to analog output every time I reboot, otherwise I get an error message and I can’t play audio files. See message below

Ok, let us take this to PM’s so we can investigate interactively.
Of course the result will be placed here.