Volumio often disconnected from wifi

I’m using a Raspberry Pi 3 running Volumio 2.141 with a DigiBerry hat connected to a Denon DAC. Files are served via Synology NAS over WiFi.

Very frequently I will come to use Volumio only to find it is not connected to my network. The Pi then needs to be restarted before it is accessible. The lights on the Pi indicate that it is still powered up and not crashed (I think). Connection is always persistent when actively using Volumio, this only happens if I leave it inactive for some hours (overnight usually).

This has happened to me on versions 2.041 and now 2.141, as well as on a Pi 2 and 3.

I feel like it’s losing the wifi connection somehow and then failing to reconnect - does this sound like a known problem at all?

My other theory was something to do with the DAC’s auto shutdown sending some sort of power down signal, but is this even possible over an optical connection?

Thanks for any help and thanks for all the hard work that’s gone into the latest version of Volumio - really enjoying 2.1 over 2.0.

I was thinking of opening a new thread on this, but since you already started one, I will add on to this. The exact same problem has been happening to me sporadically. In my case, the first sign of problem is, volumio airplay device disappears from my iPad, and volumio.local does not work in the web browser. However, I can still access the web UI using the explicit ip address. Sometimes, if I leave it for many hours (like overnight), even the explicit ip doesn’t work and ping doesn’t work either. So I rebooted after such a freeze and noted down the error messages from the dmesg command. The lines relevant to wireless are the following. Not sure what that means.

[ 18.162002] brcmfmac: brcmf_add_if: ERROR: netdev:wlan0 already exists
[ 18.162088] brcmfmac: brcmf_add_if: ignore IF event
[ 23.687937] brcmfmac: brcmf_add_if: ERROR: netdev:wlan0 already exists
[ 23.688014] brcmfmac: brcmf_add_if: ignore IF event

A google search revealed, brcmfmac is the driver for Broadcom wifi chip.

Can you set Hotspot to OFF and save; then check if you experience same issue.

Do you have any USB dongle attached?
I think I understand what is causing such message, but I do not think it is responsible for reported issue.
When problem occurs, can you type and report (with console or SSH): ifconfig sudo iwconfig

I don’t have a USB wifi adapter. I am using the onboard wifi of RPi 3. The USB devices that are connected are a USB hard drive and a DAC connected via Audioquest Jitterbug. I will try the commands that you suggested tonight and report back.

Many thanks.

Here are the results from

  1. ifconfig
    eth0 Link encap:Ethernet HWaddr b8:27:eb:73:e9:a2
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

lo Link encap:Local Loopback
inet addr: Mask:
RX packets:287 errors:0 dropped:0 overruns:0 frame:0
TX packets:287 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1
RX bytes:28364 (27.6 KiB) TX bytes:28364 (27.6 KiB)

wlan0 Link encap:Ethernet HWaddr b8:27:eb:26:bc:f7
inet addr: Bcast: Mask:
RX packets:476 errors:0 dropped:310 overruns:0 frame:0
TX packets:197 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:80105 (78.2 KiB) TX bytes:39861 (38.9 KiB)

  1. sudo iwconfig
    wlan0 IEEE 802.11bgn ESSID:“Sup_Home_2.4”
    Mode:Managed Frequency:2.437 GHz Access Point: 34:68:95:F8:8F:DB
    Bit Rate=72.2 Mb/s Tx-Power=31 dBm
    Retry short limit:7 RTS thr:off Fragment thr:off
    Encryption key:off
    Power Management:off
    Link Quality=58/70 Signal level=-52 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0

lo no wireless extensions.

eth0 no wireless extensions.

Was it when your “wifi problem” showed-up?
It seems correct: your network is on 192.168.0.x, right?

About Your USB devices: do they have external power sources, or are they powered by Pi USB?
Please check if your Pi power supply can deliver enough power: could be that intermittent problems arise when HD is pumping significant current out of Pi USB for instance… Do you still have similar problems without USB HD for instance?

Yes, thats correct.
This is after I restarted after the freeze. During the crash, I couldn’t ssh at all. Next time it happens, I will try to connect to a monitor and test.

yes info under console during issue would be more helpful.
Pls check my updated post too (my edits & your post crossed…).

Among the USB devices, the portable hard drive is USB powered, the DAC is externally powered. The power supply is the CanaKit 2.5A USB Power Supply with Micro USB Cable and Noise Filter. I am not sure if the freeze is power related because it never freezes when active, only sometimes when left inactive.

I had a freeze just now, so I connected a hdmi cable to a monitor, but didn’t see any prompt. The monitor didn’t detect any signal coming from the RPi.

I checked for old log files that the system may have written from the previous session, but couldn’t find any in /var/log. If it was possible to enable log files to be written, I could check for error messages from the time the freeze happened. In mac, there is a nice log file with messages written along with the times of the events.

Have a look at ‘sudo journalctl.’ This will give you all the system logs. If you use the ‘-b’ option, it restricts logs to since the last boot, or ‘-b -1’ from the previous boot etc.

Eg. sudo journalctl -b -1

Apologies for starting this thread then going quiet, it’s been a busy month or so and I’ve been away.

Things seem to have really got worse for my Volumio setup as of tonight. Currently it will lose its connection, then after a restart it will appear on my router’s connection list for maybe a minute or so (the GUI isn’t accessible during this time) and then it loses the connection again.

I’ve plugged a monitor in and it gives a display (proving that it’s just the wifi going down, not a complete crash). A terminal is shown with the first lines being:

volumio login:[ 23.160733] brcmfmac: power management disabled [21991736] cfg80211 Regulartory domain changed to country: GB

and then final line

[49.260751] brcmfmac: power management disabled

This has been such a consistent problem involving multiple Pis (2+3s) and SD cards. I moved to a USB-less setup thinking that might be the problem with no success. I’ve even tried multiple power supplies thinking that might be it. Is it possible that my router is the problem? I don’t have trouble with any other devices and the signal is strong, but I’m running out of ideas here.

Any help would really be appreciated

PS - Thanks for the suggestion of disabling the hotspot feature, but that didn’t solve the problem.

Just couldn’t get this working on a Pi 3 so I downgraded to a Pi 2 with a usb wifi dongle.

It’s certainly better though still not perfect. Makes me think it was something to do with the built in wifi chip. Would be interesting to hear if anyone else has had this problem.

strange i have Pi3 with the official power supply and allo boss dac. my volumio 2.201 install has been on for over 10 days on wifi only and it has not dropped even once .

Why downgrade? If you plug a USB dongle to the PI3, it will use the USB dongle for wifi instead of the integrated one

I didn’t realise that was the case - I thought there would be a process for disabling the integrated wifi. I had a Pi 2 lying around anyway and there doesn’t appear to be much of a performance difference…

I’m hopefully going to find a way to run an ethernet cable between floors to solve this problem for good. I’ve had nothing but trouble with powerline adapters before, but given that I don’t really need a fast connection to the Volumio GUI (just one that’s reliably always on) that could be an option (but I remain wary).

Is there any reason to think that using non-Pi hardware would provide a more reliable connection? I had Volumio installed on an intel NUC for a while and it was great but it was a bit of waste of a solid PC and the fan noise got annoying too. Don’t know much about Odroid, Cubox, Udoo etc but would be interested in giving them a go if it solves my problems.

I have the same issue here with. When the Raspberry loosing the connection to the AP for some reason (e.g just a reboot of the AP) it is not able to reconnect, I had this with a standard APs and now with a Mesh wlan (Netgear Orbi) as well. It seems that the Raspberry is still alive, because sometimes the wlan LED are still blinking. But there is no chance to connect either no ping, ssh, or webui. I also tried to connect the Raspberry via HDMI to a screen, but there was also signal or prompt.
Regards, Caunus

Same issue here with RPi losing connection. RPi3, Schiit Bifrost DAC, Seagate Backup Plus 4 TB USB drive, and iFi iPower 2.5A power supply. System works well on start, but after a long period of idle I can no longer access by SSH, MPDroid, or web brower. The static IP no longer shows as connected on my router. The RPi3 and USB drive show they are powered. After manual power off and reboot, everything reconnects and works well.

Presume this is a RPi software power management issue, but iwconfig shows wireless power management off. Not sure where to go next.

This issue has been marginally better since upgrading to 2.201 last week - only one or two manual restarts needed.

I’ve also switched my Denon DAC for the built in one on my new amp (Yamaha a-s801) in that time, but I don’t think the old DAC could have been the source of the trouble (or could it?)

I don’t want to jinx it but since upgrading to 2.224 connectivity has been perfect. When my router/ network has gone down Volumio has reconnected so anyone getting similar issues should upgrade.

Volumio is one step closer to perfection. Thanks to all involved.