Volumio often disconnected from wifi

Looks like I jinxed it after all.

After several days of perfect connection Volumio now malfunctions every couple of hours. So frustrating how this software is 90% of the way to being the ideal music player but just has one or two fatal flaws that make it unusable in the medium/long term.

What have I got to get this working perfectly? Change my router? Change my ISP? Switch to the Mini x86 system? Switch to some other software?

I know it’s frustrating, and sadly the issue remains even in the latest version. For me, it happens consistently every 24-48 hours. It seems to be the wifi driver. To diagnose the issue, I set up the RPI with a static Ethernet ip. When the problem happened, I connected through Ethernet and reset the wifi from the volumio web interface. Everything was up and running instantly. To bypass this issue, I installed a plugin in volumio that’s supposed to check at regular intervals if wifi is down and reset it. Unfortunately, that didn’t solve the problem at all, and volumio still goes down systematically in spite of the plugin.

So, here we are! I am at present out of options.

@sup27606 can you, by chance, replicate the issue with a USB wifi-dongle instead of onboard wifi?
There is indeed a know issue in onboard wifi driver/firmware that is being tracked by Cypress: this is independent of Volumio.
Once resolved a kernel/firmware update will fix it in Volumio.
If your problem happens with external USB wifi dongle, then it might be different issue, and may be Volumio related.

Thanks. Good thought. I don’t have a USB wifi dongle at the moment, but I also suspect its a bug with the RPI wifi driver, not volumio. Anyway, I found a workaround using the wifireconnect plugin which I managed to fix. It seems, the ping command was broken due to a bug with the Raspbian distro. Issuing the command “sudo chmod u+s /bin/ping” fixed the ping issue. So now, the wifireconnect is working and seems to restart the wifi driver as soon as it fails to connect to the internet.

Hum…not really recommended to alter access/execution rights for such purpose. You may rather want to check alternate ways than ping as proposed here for instance.

Yes, I know it is risky to modify files in system directories, but the ping issue seems to be an access/ownership bug in the RPI distro, as discussed here: raspberrypi.org/forums/view … 7&p=875833. That was one of the recommended fixes. I am not touching any other system files though.

I am not sure how to modify plugin files. If the plugin creator updates the wifireconnect plugin by solving the ping issue and implement wget, I will be happy to update it in my system.

I try to modify tonight… I’ll keep you in touch. :wink:

Done here using wget instead of ping, but not tested… so let me know : github.com/balbuze/volumio-plug … onnect.zip

edit : successfully tested on a pine64 :wink:

Not sure whether to start a new thread, or resurrect a this old one.

Recently, I upgraded my wireless router from a TP-Link Archer C7 to a Netgear Orbi mesh router. This causes Volumio 2.575 to crash after some random interval of time (anywhere from 5 minutes to several hours).

  • I’ve tried this both with a Raspberry Pi 3B and a 3B+.
  • I’ve tried this with both the existing SD card and flashing a new copy of Volumio on a brand-new SD card.
  • When it crashes, the RPi does not respond to pings over either the wireless or the wired interface.
  • This was never an issue with the old wireless router.

Running the following script (as root)

#!/bin/bash while [ true ] do sleep 10 ping -c4 > /dev/null if [ $? != 0 ] then systemctl restart wireless sleep 60 fi done

( is the IP address of the router) seems to lengthen the time interval before a crash, but does not prevent it. (This may be placebo – as I said, the interval between crashes seems to be random.)

The only thing I have tried that solves the problem is to turn off the wireless interface entirely, and run the RPi with the wired interface. Over the wired interface, it runs rock-solid stable.

Note: I have not tried an external USB Wifi dongle.

I think I have a similar problem, but not on WiFi. I have pi3 connected to wired network and WiFi is turned off. If I don’t use it for a long time (>1 day) it disappear from network. Can’t ping it, can’t see it in “Fing” network tool, can’t see the fallback AP of the pi (it’s configured to make it if connection lost)
I have USB DAC in my active speaker (Edifier S880-DB). If I turn the speaker off it turn off the DAC, and I see a message in volumio that “USB DAC disconnected, output changed to audio jack”. When I turn the speaker ON in a short time (<1 day), volumio switch back output automatically to USB DAC and works.
Now I stopped playback on volumio (.flac from my NAS), then turned off the speaker. No message about DAC disconnected, but volumio crashed. I turned the speaker on, still can’t connect to volumio, can’t ping it. After hard reset it works.