Volumio Multiroom: some questions

Volumio Information

Volumio Version: V2.917
Hardware: Raspberry Pi3


I have a question: I wanted to create a multiroom system using Volumio and Snapcast Plugin.

I thought I was doing something like this:

  • 1 raspberry 3 as a server and place it on the data rack (connected to Lan) and connected to the NAS to read the Playlists
  • 3 raspberry zero W with DAC on the various rooms
  • possibility to listen to everything even from the PC

I Have 3 questions:

  • on Raspberry Zero W do I have to install VOlumio and activate SnapCast Client?
  • how do i listen to music and web radio from my desktop pc? I tried to connect to the volumio-server but I don’t hear anything
  • the raspberry “volumio server” must have the DAC? I do not think since the transmission of the songs is via LAN

Volumio 3 (currently in RC1 testing) should allow you to do (most of) this OTB with minimal fuss :slight_smile:

Ok, but:

  • the raspberry server must have a dac?
  • ok but the multiroom with volumio 2?

I know I’m not being particularly helpful, but you can do it either way:

  • Either run snapserver as only a server, doesn’t do any local playback and sits on your rack
  • Look up the volumio-snapcast-plugin

For streaming from your PC - use UPnP/DLNA to send audio to the client on the server.

I’ve been running owntone on a Pi 4 as the server with a few Pi3 + DAC Volumio setups around the house.

On the Volumio “clients,” I just make sure that ‘Shairport-Sync’ is active (Settings > Sources > Functionalities Control) & the server sees them as available speakers (in addition to everything else configured for Airplay around the house, like our Roku, Kodi, etc.). As in your system, the server machine doesn’t output anything directly.

It works really well. Some caveats:

  • The apps for controlling owntone can be a bit laggy (particularly in selecting speakers), but the web interface is pretty zippy.
  • Occasionally the Volumio speakers disappear; the server sees them again if I toggle the “Shairport-Sync” setting off and back on. I need to just write a script for that, but I’ve been lazy.

Having said all that, I definitely am looking forward to trying out the syncing on Volumio3.

1 Like

Thank you

Reading the tutorial on this forum we talk about editing mpd.conf by adding

type “alsa”

name “Output”

device “hw:0,0”

dop “no”


audio_output {
type “fifo”
name “my pipe”
path “/tmp/snapfifo”
format “44100:16:2”
mixer_type “software”
} [/code]

It must be done?

Hey @Ma_junior , I don’t know If you got answers to your questions and solved your problem but if not, I’ll try to help.

You don’t need a DAC for the volumio server or any of the Pis to test the sound output.

This is my Setup:

RPI3 (with volumio 2.915) in Server room (connected by headphone jack to stereo amp)
RPI3 (with volumio 2.915) in Office (connected by headphone jack to a DTA30HP Mini Amp)
RPI 1 (with volumio 2.915) in Bedroom (connected by headphone jack to stereo amp)

I installed the volumio-snapcast-plugin that @ashthespy mentioned on every pi

I do have SnapServer and SnapClient enabled on all 3 RPIs so that I can, at times, switch between Servers and clients depending which Pi I want the source to be (not necessary for you).

I don’t use desktop pc for the sound output in office because I want to be able to listen to music even if the pc is off or needs a reboot. I only use pc to access web GUI and control Volumio.

I haven’t had to make edits to any conf files. Once the SnapCast plugin was installed, I just use the setting from the GUI.

If needed, you can follow this video for instructions on installing and setting up snapcast plugin. It worked well for me. (https://www.youtube.com/watch?v=oA0L4tSvPKk)

See attached screenshots of my snapcast setting for each Pi

Let me know if you need any more help.

1 Like

thanks, you have been very kind
I try… :slight_smile:

Thank you
everything works