Volumio multiroom only works with one device

Volumio Information

Volumio Version: 2.907
Hardware: RPI 3 and Zero
DAC: Hifiberry

Debug Log

Steps to Reproduce
I have two raspberry pis with volumio in my network. I can individually access them by using their hostnames or ip-addresses.
Click on the icon for the multiroom view.
In the list of devices I see the name of the other pi but the picture is of the album that I am playing is the one on this device. Depending on which device I clicked first, only one volumio pi is playing music. I access the devices individually by their hostname and try to play on them but only one is playing. It is not possible to select the other one again from none of the frontends. Only the divice whose name does not appear in the list is playing.
What can I do?

You are misunderstanding what “multiroom” is in Volumio. It allows you to access all of your device from one IP address. This is not the same as “synchronised multiroom playback”, which is what I think you were expecting.

You can get synced playback by using the ‘Snapcast’ plugin:

or waiting for it’s inclusion in MyVolumio in Volumio 3 (currently in beta).

1 Like

Its actually bugged also in the sense what the topic title is.

  • Device A can see device B
  • Device B cant see device A

So i can access both from address of device A, but not from address of B. since it only sees itself.

I do understand what multiroom is and it is not working. With two devices in my network I would expect to see two devices in the “Zones” tab. As described I see only one. What Joni_Salminen describes seems to be what I am experiencing. After some clicking on devices in the “Zones” tab only one device is reacting to my commands even though I connect to the two devides individually via their ip addresses.

Synced playback is also what I am looking for and I have already tried the snapcat plugin with the result that I do not get any playback at all. I could probably fix it but then I don’t know what would happen with the next update. As a general rule I want to spend more time listening to music than fixing technical issues.

@marjaco are you using on both fresh installs or a copy of the other?

Both were fresh installs when I installed them. It has never worked from the beginning. I wanted to wait for a few updates but they haven’t resolved the issue.

I don’t think that this happened. How would I look up or change the UUID?

I can ssh onto volumio. Where is the uuid stored?

what version are you running i’m running 3.074


2.907. That is the latest that the update system gave me.
The uuid’s are different, so that is not the problem.
Thank you for your help.

if they are diffrerent it should show up. in the 3.xx versions it does… 3.xx is beta your on lastest release.
i had problems with 2.xx versions it crashed my whole network that’s why i run 3.xx

I could try it but where do I get this version from? It doesn’t show up in the downloads.

what is your connection wifi or cable? the are still some bugs with wifi on those so switching the zero could be a pain in the butt

OK, I let it be. I only have wifi.

@dvo – Sorry but you are not looking at the UUID, also please don’t confuse your issues with what others are facing…
@marjaco if you flashed two new images, then all this is moot, the uuid is created on first boot.

oke i removed it from here … he didn’t see his zones … btw