Volumio doesn't always boot.

I am experiencing the following issue, I have imaged he SD with etcher on my Microsoft Surface Book. I have a raspberry Pi 3 B+, with a Geekworm Raspberry Pi 3 B+ DAC Amplifier HIFI AMP TAS5713 Expansion Board Audio Module. Symptoms are as follows with a 5 inch touch screen , When it boots it works fantastic, but whenever I shut it down there is less than a 50/50 chance it will reboot. If I select restart from the menu it has about a 30/70 chance of working. I am modifying a boombox for my son for his birthday and I know he will frequently shut this down and restart it. I am happy to provide logs and more details. Things I have tried. I usually have to try removing the power a few times to get it to go.

  1. Removing the touch screen. Not seeing really any change from this.
  2. I have some music on a USB, I removed that to see… not much difference (it’s hard to tell since it is so intermittent)
  3. Tried just using the power on the Raspberry pi board… no go.
  4. replaced the SD card.
  5. replaced the Pi
  6. Removed the DAC (just using the speaker jack) … no dice.
  7. Replaced the raspberry Pi (bought a new b+ from amazon)

I reviewed the logs for Volumio.log and boot.log… I can’t really see anything here but then I am not used to lookig at them. Any help would be greatly appreciated. Been working on this for several days now. BTW I do love this software, I am excited to get it working.
There are no NAS mounts, I feel like the USB is a mount in terms of a /dev/sda or /dev/sdb device. but there are no NAS or other mounts than that.

Here is the boot.log

here is the volumio.log


“When it boots it works fantastic” sounds a little like a power issue to me, boot time is where the psu has to handle peaks, it might not be able to do this in a stable fashion.
You wrote you have a touch screen and a DAC connected, have you tried it without both, just the PI?

Edit: which power supply are you using?

Yes I broke it down to just the raspberry pi and the speaker jack using a portable speaker I had lying around. Still failed. When running just the PI I used a adafruit 2.4 adapter. when using the DAC I am using a 12v adapter (that came with it) . I just tried something new that I am testing. I think it might have been the USB mount , I set it up during the initial setup and I think it might be causing the problem. More to come. Thanks for your reply.


Shared pain, mine (RPi3 / HiFiBerryDAC+ / RPi touchscreen) has the same problem. Sometimes it starts, let’s say 30% of the time. I’ve checked the board power and even increased it to 5.2 volt measured on the PCB, but that makes no difference. I have tried with it my bench power supply but it looks the powering is not the problem. The SD card I use is a high speed Sandisk 16gb, these cards work perfect with all my other RPi projects and with my other Volumio players without a touch screen. In my opinion the problem is caused by using the RPi touchscreen with Volumio and I’m looking forward reading any solution.

Regards, Hans.

Hello everyone,
I have the same problem.
I have a big problem booting the RPi 3B with PiFi Digit DAC and the original 7" touch display.
The Pi boots without a 7" display. When I now connect the 7" display, it sometimes offered immediately or only on the third or fourth attempt.
I used a 5.2 volt power supply with 3000 mA to switch off all power supply problems, then I used a longitudinally regulated laboratory power supply with 10A to determine whether it could be due to the power supply, I have the voltage of 4.9 to 5.3 volts on the RPi, unfortunately without significant change. Then I used a second RPi 3B which behaves exactly like the first one, then an RPi2 which boots correctly more often than the two RPi3B but still stops again and again. The green LED flashes 3 times and the system stops.
After that I installed RUNE AUDIO, the version always boots no matter how often I turn it off. There seems to be a problem initializing the 7" display.
Anybody have any idea what could be causing this?

The display of Volumio makes only a brief striped image after the Sart.
Rune Audio displays a multi-colour image.
It really looks like this is an initialization problem of the 7" display. Can I change anything in the installation files of the 7" touch plugin?

Sorry, i forgot, i am using version 2.444

I had the same problem with version 2.444 is now solved (also 7 inch touchscreen)

I did this: I flashed a new image and then went through the entire set-up and then, as a volumio asks for a reboot, I did not reboot.
instead, I activated the dev version (test mode) and updated it to the dev version, then rebooted and then started it without problems.

I also left the language on English.

enable test mode (Beta Releases) at the bottom of the page of the link.

volumio.github.io/docs/User_Man … em_updates

the new myvolumio image also works well.


It seems to be working, thank you for pointing that out.

nice :smiley: , but keep in mind that you are now running a beta version, in the future it may go wrong once you update.

Tried the beta as suggested by michel8166 but this made no difference with my hardware. As mentioned I had to re-install Volumio to get the usual version back but prefered to spend that time installing Moode Audio which works now without any touchscreen issues. I consider to switch to Moode Audio or wait until the next Volumio update hoping the issue is solved.

it still works well for me, I have to tell you that I have fed everything 3x 5 volt power supply and maybe it has to do with little or that the voltage goes down during start-up.

picoreplayer / moodeaudio / runeaudio also works without problems.
I would still think that something has changed in the last 2,444 volumio version.

or look here: can-start-volumio-rapsberry-t10466.html

another reported that he had solved the problem with a new SD card, the old one was bad, according to him, look here: rpi3b-doesn-survive-reboot-with-444-t10474.html

You have already tried the new myvolumio image.


Hi Michel,

The powering is also one of my concerns. Do you mean you have powered the setup with three power supplies? Or did you power each board (RPi/DAC/Touchscreen) with separate cables to the same power supply? Untill now I use a 5A bench power but still connected via the mini-USB connector on the RPi board which has about 5.1 volt (measured on the HiFiBerry PCB) when playing. I did not measure large powerdrops when booting, at the other hand the compete setup consumes about 900 mA during startup. Possibly to much when powered via USB.

Hope to hear from you,

best regards, Hans.

I use three separate 5 volt power supplies, one for the raspberry pi and one for the kali reclocker/allo isolator and one for the touchscreen, they all have 3 ampere.

So I feed the touchscreen separately from the raspberry pi.

I also did not see a big power drop during start-up, but in one way or another I do not suffer from it as soon as I use the beta or the new myvolumio image.

Thanks for the info Michel! But, to be honest, if I need to power a project with 3 separate power supplies I give up…

For now I have changed powering by connecting Vcc and GND directly to the GPIO-pins. To exclude startup disturbtions caused by my 5A switching power supply, short after connecting to the 230 volt main, I have installed a delay board with a 555 delay chip. About 3 seconds after powering the switching power a relay on that board switches and sends the 5 volt to the RPi. After spending to much time to do this it turned out the issue still excists…

After some more testings and many reboots it looks the boot process is mostly succesfull after cooling down for some minutes or an overnight. Inspite the heatsinks the hardware becomes pretty warm and the airflow is blocked by the GPIO-connector on the topside of the boards when using the display in the default (out-of-the-box) orientation. So I’ve changed the orientation by selecting “lcd_rotate=2” in /boot/config.txt. Now I have to take the time to test and boot several times after cooling down.

Regards, Hans.

Okay, I understand your problem but what I mean is that it worked for me to go to the beta version or the new myvolumio image and that it might have to do with a lowering of volts during startup.

I have everything I built in and by means of one switch I start all three power supplies at once so for me it is not such a problem.

Maybe it is a software problem because more users have this problem and what I understand are the developers now on vacation and have to wait until they are back.

edit: turning 180 degrees of the touch screen is not an option for me, see screenshot :wink:

this is an old photo (picoreplayer) forgive me volumio but he really plays on volumio software :laughing:


It looks like the temperature of the boards is causing the problem. If I boot while the temperature has dropped, it goes well in 99% of all times. I have ordered a fan to cool everything, hopefully the problem will be solved then. I share your opinion the issue may be related to the software, can’t wait read the opinion of the developers.

You built your system in a sturdy cabinet! What is your experience with Picoreplayer in combination with the touchscreen? Do you also have boot problems with that software?

Regards, Hans,

I do not have a single start problem with picoreplayer.
picoreplayer works very well with the touch screen also the use with LMS (logitech media server) works fine and picoreplayer has many more options for operating the touchscreen.
there is another advantage with picoreplayer that you can turn off the raspberry pi without corrupting the micro sd card.

maybe a raspberry pi heatsink helps the heat problem, if the heat problem is the cause.

setup touchscreen picoreplayer.


moodeaudio works fine too just the setup of the sd card is a hassle if you never did this and takes at least one hour


set-up moodeaudio.


Thanks Michel. For now it looks RuneAudio is the best choice for me but I really hope to switch back to Volumio if the issues mentioned are solved.

Regards, Hans.

I also hope that it will be solved quickly because I think volumio sounds better in my current stereo system.

Can you guys please try this release and report back ?

updates.volumio.org/pi/volumio/2 … pi.img.zip

PS: You can also use the OTA Updater, by enabling test mode.

Let me know, in case it does not work also the exact configuration of sw\hardware you’re running