Volumio 3 USB DAC works on RPI3 but not on RPI4, all else the same

Hi all,

I running a BSS BLU-USB DAC on Volumio rev 3.546. Clean install. No HDMI audio option comes up at start in the RPI4 but that seem to be related to the 7" touch screen. Screen is RPI standard connected by ribbon cable and 4 separate power cables as by the instructions.
The RPI3 works just fine with headphones out, an internal ALLO HAT and my external USB DAC. Only difference is that is that the RPI3 does not have the touch screen. The RPI4 (8GB) has a new clean card (32GB) install. Both run fixed IP and updated DNS (Google). From clean install in the RPI4 the headphones alternative works fine. When connecting the USB DAC it does come up as a choice and works for about 30 seconds and then stops. I have tried with or without driver for the screen. With or without ALSA HW/SW/none volume. Regardless of what I do it shuts down output and cannot be started without a restart. At restart it automatically install ALSA HW volume control, which I don’t want/need. I have checked all settings and they are the same between them albeit the RPI3 works the RPI4 does not. No difference if using USB2 or 3 on the RPI4 either. Both are wire Ethernet connection to the same switch. Power supply is RPI 3A to RPI4 and a 2,5A to RPI3.
What can be he difference between RPI3 & RPI4 in Volumio?
Any input much appreciated.

That would be guess work, to get more information, start with a clean install, no additions.
Boot, then connect the DAC and wait until it shuts down output. At this point create a log and post the URL here.
How to create a log

Sorry for late reply. I have tested 2 diffrent Pi4 with the same result and two Pi3 that run just fine. Same power unit, same cables and same USB DAC.

Dump done.

All help much appreciated

You say PI3 works fine, but this is a log from a pi3 and I see no USB DAC at all!

I expected a log from the PI4 which gives you problems.

Sorry for that. Must have logged into the wrong one as I have several. New log uploaded.


This time System info clearly says Pi4.

Thank you

New test. Clean install. Runs for a little more than a minute and the dies (same as before). Cannot be retarted. Same with both RPi4 where the RPi3’s is fine. Using USB2 connector for the DAC. This time no Screen SW installed.


Dump taken direct after failure. I don’t want the volume control as I have that in HW later in the chain but having that set to 100% or setting “none” gives the same result.

Kind regards

perhaps you should have another look at this
How to create a log
You forgot to supply the URL.


Sorry for that. Here is a new try. Clean start and runs for 20 seconds this time. All else same as before.



Kind regards

Your log shows

Nov 06 18:02:37 4367m kernel: usb 1-1: clear tt 1 (0020) error -71
Nov 06 18:02:38 4367m kernel: usb 1-1.3: USB disconnect, device number 3

This means the usb device disappears.
Bad cable? Power issues, tried with a powered hub? Tried a different port?

what power supply are you using?

gkkpch, thank you for checking the logg.

That may well be but it does not happen on the Pi3. I have also used this specific SUB-DAC with a windows computer without problems. So the problem is really why the Pi4 loses the DAC but the Pi3 with the same version of Volumio does not. I have tried at least 2 pcs of hardware of each the Pi3 and the Pi4 with the same result. I have a bunch of them. Pi3 works fine Pi4 does not. Everything else is the same, cables, connectors, lan, power supply aso. Just swapping the main unit. The USD-DAC has its own 12v power source.

I do have two identical pcs of the USD-DAC (BSS BLU-USB) and the result is the same for both. Hence I don’t think it is a HW issue.

It did work with a previous version of Volumio. I have recorded earlier usage where it worked fine so something has changed. It should have been early February this year. I built the streamer with an attached DSP that is feed trough the “DAC”. And it worked in this configuration back then. I don’t recall what version it was but not “3”. I can check if I have that version stored and try that again later in the week.

A bit of a backdrop
I built a streamer early this year based on the Pi4. It is hard line Ethernet and my plan is to use the USB-DAC mentioned. The USB-DAC is not really a DAC it is a 3 channel class 2 soundcard that outputs a digital signal direct into mu DSP where the XO and volume control is. From there I feed two power amps and them my 4367 speakers. I built the streamer in February but as the speakers were no ready it was put on the shelf until 2 weeks ago. When restarting and updating it did not work.

I am absolutely sure it worked earlier as it would have have to worked to run signal into the DSP to run all the measurements on the speakers. I believe this is a Volumio “3” issue.

All my other Pi3 & Pi4 with Volumio works just fine using ALLO hat DAC and Topping D10 USB DAC’s

Darmur, the PS is a Pi4 3A wall wart from OKdo. I can try with a bigger unit later in the week but the same PS works fine with the Pi3’s.

Any ideas? Any other log or so I can take out?

Kind regards

the Pi3 is way less power-hungry than the Pi4, this could well be the reason of the problems on the Pi4 and not on the Pi3

Please try with a very good power supply, truly able to deliver 5.1V/3A

Hi again,

Swapped in a high power PS and no change. It runs for about 40 seconds and then stops. Message on screen is that USB unit not available. I have updated to the latest SW 3.569.

Any ideas?

Frustrating. It definitely sounds like hardware. Power supply you already tried, so the USB cable, the Pi4 USB bus or the SD are top suspects in that order. Or it was the power supply and the different power supply you tried isn’t compatible.

Hi Simon,
The PS is OKdo Raspberry Pi4 original (3A) and the one I tried now was for a computer 60W. No luck.

I have 2 Pi4’s and it is the same thing on both. I have several Pi3 and they run just fine. Hence, I don’t think it is HW.

I’m now flashing an older Volumio to see if that will work.


Ok, I give up for today.

Pi3 on 3.546 works just fine. Pi4 does not. Everything else exactly the same equipment.

Tried removing the flat cable to the screen with no luck. Tried to downgrade to 3.396 with no luck.

Will try 2.917 tomorrow as I know I have had it running before.

Update. I guess my memory is playing tricks with me as I can’t get the RPi4 to work on the old Volumio version either.

I have tried a second RPi4 again and its the same story. I plays for about 20-50 seconds and stops and it says that it lost the USB connection to the DAC. If I just shift to the next song, nothing else, it starts just fine and plays for 20 to 50 seconds and stops. Same pattern every time I forward to the next song. Odd.

Does shift to the next song reset the interface?

Are there any time outs that may differ from RPi3 to RPi4 as the RPi3 works just fine.

I did try both the USB2 and USB3 connectors.

All input much appreciated

To me it looks like a power issue: PI4 is more power hungry than PI3, and it might fail to deliver adequate power to your DAC.
As first thing I would try a different PSU (more powerful) or power the DAC via a powered USB hub

Hi Volumio,

Thank you for the post.

As can be seen above I did try a 68W LapTop PSU USB-C with no change. Tried on both my Pi4’s. That should provide more than enough power.

Pi3’s runs just fine on 2A original OKdo PSU.

The DAC has its own 12V PSU so it is not USB powered and I have tried both USB2 and USB3 ports on the Pi4. One of my P4’s has a touch screen the other does not. The one with the touch screen does not show the HDMI output as an option the other does. Both cuts out after 15-60 secs. Forward to next song starts the same cycle again.

Since the Pi3 runs fine on the latest Volumio release but the Pi4 does not (have tried two of each with same outcome) it may be a timing issue on the Pi4 USB ports since it has a dedicated bus on the Pi4.

The Pi4’s runs for 15-60 seconds and then drops the connection to the DAC and stops. It cannot be be restarted from that point but if I change to the next the song it restarts just fine and stops again after 15-60 secs. Really odd.

Continuous playing is enabled but it does not forward to the next song by it selves when it stops. But there is no problem doing it manually.

I would very much like to use the Pi4’s as they are much more responsive due to more CPU power.

All ideas welcome.

There are many thousands of Volumio users with a Pi4 - there is no compatibility issue. I would recommend using the official Raspberry psu.