Volumio 3 Spotify Connect not working

We have 5 Volumio players in our house. I have uppgraded one of them to Volumio 3 and it sounds great, but I can´t get Spotify Connect to work.
The normal Spotify plugin is working fine, but Volumio 3 does not show up as a device in the Spotify app on my phone. I made a new installation of Volumio 3, but with the same result.
The HW in this player is RPi3+ and HIFIBerry DAC+ Pro.

Is Spotify Connect working on Volumio 3?
I have to know if the problem is my installation…

For me it works just fine.

Perhaps share logs and someone can take look, if something obvious is wrong in here.

It is, been using it during the beta phase a lot and now on the release version, on RPi occasionally and x86 very often.
Lots of others are using it as well.

Thank You for the information.
I will see if I can find the problem.

Create a log when you’re getting stuck. That might help

I am unable to connect to Spotify Connect on Volumio 3.
Here is my log file:

This was my sequence before sending the log file:

  1. Verified Connect2 plugin is installed and enabled
  2. Reboot Volumio
  3. The Spotify app cannot find the Volumio device as a Connect endpoint
  4. In Volumio Installed Plugins tab, disable and re-enable the Connect2 plugin
  5. Now the Spotify app shows the Volumio device as an endpoint
  6. On Spotify, select the Volumio device
  7. The device icon blinks for a few seconds but connection is not achieved
  8. Repeat a few times but it never connects

If I switch back to Volumio 2, Spotify Connect works again. However on Volumio 2 I also frequently had the issue where Spotify couldn’t find my Volumio device but it will find it after I disable/re-enable the Connect2 plugin.

*** Edit ***
I think I found the problem. Looking at the logs, it was showing an error with a missing mixer. I looked around Volumio settings and in Volume Options, the Mixer Type was set to “undefined”. I changed it to “None” and now Spotify Connect is working. I had never touched Mixer Type and I feel this is a Volumio setup problem that isn’t setting mixer to a proper default value.

1 Like

Nice find!!

Thank You metro for the tip, but it did not work out. So I did it all over again used another sd-card, but with the same result. Everything works exept Spotify Connect. Then I tried another power supply, but it did not make any differens.
I use Linux Mint on my office computer with Raspberry Pi Imager v1.6.2 making the card. So I tried Balena Etcher instead on the same computer and that solved my problem.
After that I have written it two more times with the same result on two different sd-cards.
The reason I tried this is that I have had some spoky problems with the usb-imager that comes with Linux Mint but balena Etcher has worked ok.
I tested the failing card in another RPi with the same result. No Spotify Connect

Itś even more spoky because the first test with Volumio 3 I did was an upgrade trough UI from 2.917.
No image writer involved.