Volumio 3 RC1 Beta Testing - Odroid images

The copy is taken from the latest image for Volumio N2+, I haven’t altered it.
It’s identical to the original config.ini from Odriod.

For the DAC’s I2C1 is used.

; Device Tree Overlay
overlays=“spi0 i2c0 i2c1 uart0”

overlays=“i2c0 i2c1”



Also check odroid-n2:application_note:gpio:i2c [ODROID Wiki]
I think you may not need ic2-0 and i2c-1 overlays, as their aliases are enabled already. Check the gpio pins and the location of i2c-0 and i2c-1, see N2 pinout.
Again, I have not used it, so need to check next week in case you haven’t found out yet.

tried that already, but commands are failing.
fdtget /media/boot/meson64_odroidc4.dtb /soc/cbus@ffd00000/i2c@1c000

already adapted the path to /boot/amlogic/meson64_odroidc4.dtb, but not able to find /soc/cbusxxxxxxx

Will try to find a solution, sofar no luck, teh OLED is located at address 3c, but not visible on i2c1. On the original Odroid image its located at i2c0

Ordoid C2
Installed 3.136, but system wouldn’t recognize my WiFi USB module (accessory:connectivity:wifi:wifimodules [ODROID Wiki]).
I had to install the firmware for it: firmware-ralink and now the module is recognized and works!

thanks for letting me know, I’ll add with the next version. I think there will be more missing.

1 Like

Could you create a log with the dongle connected please.
Just to make sure I can test the right device, thanks.
Howto: Send a log

I was premature when I said it works. The wireless hotspot does not seem to work, but the wifi module connects to my router and I can use the web UI from a browser.

Here’s the log immediately after restart: http://logs.volumio.org/volumiobuster/zuo570W.html

And this worked with the latest Volumio 2 version on C2?

1 Like

yes, I finally did today and found the issue.
There is some confusion with the kernel versions, from 4.9.241, Hardkernel has changed the SPDIF signal to J7.2 (that’s Pin 2 of the audio header).
This is a bit annoying as most users won’t solder a header for using SPDIF when you can have Pin 7 (GPIOA_13) without extra work.
The configuration was tested today, which allows most users to continue to use Pin 7.
This will be the default.
Users of audio header J7.2 will have a configuration option in the user.config.ini, which will survive updates. Instructions will follow when I release the next N2/N2+ version.

1 Like

Yes, it did.

1 Like