Volumio 3 RC1 Beta Testing - Odroid images

Unfortunately not, for a number of technical reasons.
Re-flashing is the only option.
Try with an extra SD in case you want to test.
Edit: that being said, in case you had an earlier volumio 3 version, OTA would work with dev mode set.

Ok it upgraded to 3094 and not 3136. Is there something else I need to do?

No, I need to check why it did not OTA to 3.136
For now, flashing is your only option.

1 Like

Looks like it’s trying to update to v3.076 from 3.066.

Guess it’s time for a re-flash.


There is no sound on Odroid N2 when using spdif output. (Pin 7) I am able to get the sound through spdif only on version volumio-2.857-2020-12-11-odroidn2. Tried every build after this one without success. Are there special settings for alsamixer or built in digital out is disabled/muted by default?

hmm, have not tried this lately. To rule out any kernel updates, could you tell me what kernel version 2.857 has? (I don’t have a record of that, would have to flash one).

Thanks gkkpch for prompt reply :). 2.857 has 4.9.230+. I use coaxial connection from gpio to my amp and 2.857 works well, however sometimes it is losing network connection, so I have to plug/unplug network cable from Odroid device to get it working again. Starting from version 2.877 and higher I have no sound on coaxial and recent build of Vol3 (3.136) has the same. I did not check 3.039, 3063 and 3066.

I need to have a closer look at this, currently I’m not using spdif on my test install. Will let you know (may take a little as we are building for volumio3 release). Just poke me if nothing happens.

Any ETA on the later versions for Odroid.


Odroids got a round of updates only 17 days ago.
There are other community boards which did not have a beta yet at all, they are also entitled to get one.
Giving an ETA makes no sense, because that would be a promise I would often not be able to keep.

1 Like

Have you had a chance to verify spdif problem? Just poking :slight_smile:

1 Like

No, didn’t have time to create a test setup with the N2 yet.
Same story for the next 2 weeks, sorry.

I am reminding about the spdif problem on odroid n2 :slight_smile: Any chances to look into it soon?

No, and at least not for the coming week either. I have a long backlog since I concentrated on volumio 3 for x86.
Community portings are 2nd priority at the moment as this is voluntary work, not a fulltime job

1 Like

I tried Volumiobuster-3.136-2021-11-05-odroidxu on my XU4 with 8GB emmc. However, I could not get it booted up.

The problem has been located, fix will come in the next version (no eta!).

Thank you very much for doing this even though there are not many XU4 users. I really appreciate it!!!

Hi Ge,

Playing around with with the Odroid N2+ images, but it seems that for all images both V2.x as V3.x i2c0 is disabled. (needed to add the OLED screen) Even though the overlays seems to be set in the /boot/config.ini.
overlays=“spi0 i2c0 i2c1 uart0”
overlays=“i2c0 i2c1”

Even with the devicetree it’s not activated. I know it’s related to the image as the official Odriod image has both busses enabled. Any suggestion?

I need to have a look first, never used any of the i2c gpios on any of the Odroids.
I’m not sure here, do we use i2c0 for the Shield2 DAC?
Can you test with i2cdetect -y 0 and also on the other bus 1 and 2?
I won’t be working on community portings for v3 until early next week, so not of much help just now.
I use the same devicetree as HK.

Guess you checked the hardkernel forum?
I remember there is something unusual with i2c aliases

These go under overlays only, custom is meant for your own ones (in case you had any)