Volumio 3 and Hifiberry Digi+ no sound

Hi all,

I have upgraded to the Volumio 3 on a RPi3B+ with a HifiBerry Digi+ board. Volumio is connected with a digital coax to the Yamaha RX-A1010.

Upgrade went smoothly, including configuration. Result: No Sound. I tested different config settings but no sound.

I’m lost. This combination has worked very well with Volumio 2.

Thanks for the tips and tricks.

I hlave The same problem, after the upgrade to Volumio 3. Using hifiberry digi + connected via optical to Denon amp. Volumio v2 worked fine.


Please send me a link to version2 download. Thanks!

1 Like

Click on hints at: Volumio 3 does not work for me yet, some things I need are still missing.

1 Like

I tried it but but the version 3.173 doesn’t work for me. I have hifiberry digi+



1 Like

I saw this page, but can’t find any topic that is related to the HifiBerry Digi+.

I went back to the latest version of volumio 2. And it works fine.

Well, if it works, it works. I know it goes EOL. But better a version that is EOL and works than a version that is not working.

1 Like

Was hoping I could run a test but only have a HifiBerry DAC+ ADC Pro Audio Board lingering . Can’t test this.

I have the same setup as Lubo (my specs: running Raspberry Pi 4, 4GB memory and the digi + HAT DAC). V2 works perfectly, but no sound is sent via optical to my Denon amp with V3. This happens on both the V2 upgrade and installing V3 from scratch via the .img file.

1 Like

I wonder if someone from Volumio can comment on the progress/priority of the HiFiBerry Digi + “no sound” fix.

A small data point - I reinstalled v3.175 from scratch and chose the “headphone” output (bypassing the DAC) and Volumio works just fine and outputs analog sound.

Had simular issues with the Hifiberry DAC+ ADC Pro, when doing a fresh install. I’ve added the dtoverlay manually to the /boot/userconfig.txt. After that the hifiberry appeared as selectable output device.
Can you try this with by adding " dtoverlay=hifiberry-digi" to the /boot/userconfig.txt file.

The problem is not the selection of the HiFiBerry Digi + during install. It shows up in the drop down menu and when selected, writes the “dtoverlay=hifiberry-digi” to the /boot/config.txt file. The real problem is after selecting this I2S Dac during install, Volumio works fine as a player but no sound is sent from the digital output of the HiFiBerry Digi +.

Wheaten - are you suggesting that adding “dtoverlay=hifiberry-digi” to the /boot/userconfig.txt in addition to it being in the /boot/config.txt file will fix the sound output problem?

Hmmm, i have Hifiberry Digi+ Pro which seem to work sometimes, for example now i reattached it after seeing this post and got it working, last time i tried after the first official V3 release, there was no way to get it working.

Now it seems to work after multiple reboots without any workarounds needed, which is very odd.(i always liked the sound better this way, than with usb out)

Now that its running flawless is there anything i could do to provide information? which could be compared to setup where its not working.

perhaps @volumio, @mervinio to the rescue? @gloyboy had valuable input for a problem concerning a number of installations.

I can actually confirm the behaviour @gloyboy sees here, if i select my digi + pro during initial setup it does not output any audio even thought the playback seems to advance based on the web ui, same what happened with initial V3 for me i assume.

now if i select my usb dac, it starts playback instantly as i suppose it should do, now the “magic trick”, reboot my device with the usb dac selected, go to playback options and select digi + pro from the i2c dropdown menu, it does work flawless from now on.

So whats the difference in selecting it as first output device during first setup compared to selecting it after usb dac is configured?

No I just told my experience when trying to get the Hifiberry working. Selecting it from the i2c menu kept generating errors. It didn’t update the mixer settings, so it was still set to hardware even though my berry only has SW control.
When adding the overlay to the userconfig.txt (the place where it should be, to survive during updates), the berry was available and it worked.

Joni - absolutely brilliant! First, I never thought of using an external DAC I had on another computer. So I followed your recipe and took a fresh image of 3.175, plugged in the external DAC, and after walking through the startup sequence I had music playing from the external DAC. And then the “magic trick” - I rebooted and changed playback options to i2c and the digi + pro dropdown and to my astonishment, I had music playing via optical to my Denon amp from the HiFiBerry. I finished up all the other configuration and now I have a fully functional v3 running on my Raspberry Pi 4. Nice!

I would probably suggest to @volumio, @mervinio that something wasn’t getting initialized the first time through the setup, and for some reason attaching the external DAC, rebooting, then selecting the HiFiBerry made it come alive. BTW, Kudos on the V3 version which seems to be a lot snappier. And having the Virtuoso plan paid off handsomely when all my webradios, playlists and songs on my external USB drive came up without any painstaking recreation. Well done!


For Digi2 Pro I found the following instructions to get sound out:

Settings/General Playback Options/Audio Output → Enable “I2S DAC” and select DAC Model “HifiBerry Digi+ Pro”. → reboot Volumio

I suspect that the problem is in file “…/app/plugins/system_controller/i2s_dacs/dacs.json” where needsreboot attribute is to false for hifiberry-digi-pro card. @volumio Volumio team, can you check this.

Hi all,

I bought a new micro SD card and created a new fresh image of Volumio. After the configuration it stil doesn’t work. But there was a new appearing on the screen. It was very short in red, but it seems it looks like an error message.

So I changed the playback option to another Hifiberry, I don’t have. Reboot the system. Then change the playback to the Hifiberry Digi save the setting and reboot the system.

And now I have sound. Don’t ask me why, but it works now.