[Volumio 3.601] Upgrade from previous version to 3.601, rescan needed :-/

I have updated from the previous version to V3.601 on 2 different installations (details see below). Unfortunately somehow my music library got lost on both systems, so I need to rescan my SSD :-/ Not a big issue, but anoying and time consuming (it takes hours and I need to do it one after the other because I use the same drive for both).

Correction (29-Jan-2024): The rescan on the device which contains the SSD took only about 20 minutes (for ~50k titles). Only for the other device which is connected via a slow powerline it took about 5 hours.

My library is on a SSD connected via USB expansion (similar like this here ) on one of the 2 devices, but I use it for both.

In addition I’m using a NAS, but haven’t switched it after the update so I’m not sure whether there it’s the same. I will add a comment once I have checked it with the NAS.

System 1:

System Information

OS info
Version of Volumio: 3.601
Hostname: volumio-3k
Kernel: 6.1.70-v7+
Governor: performance
Uptime: 0 days, 0 Hrs, 53 Minutes, 25 Seconds

Audio info
Hw audio configured: Allo BOSS
Mixer type: Hardware
Number of channels:
Supported sample rate:

Board info
Manufacturer: Raspberry Pi Foundation
Model: Raspberry Pi 3 Model B Rev 1.2
Version: a02082
Firmware Version: Oct 17 2023 15:42:39 - 30f0c5e4d076da3ab4f341d88e7d505760b93ad7

CPU info
Brand: BCM2837
Speed: 1.2Ghz
Number of cores: 4
Physical cores: 4
Average load: 4%
Temperature: 48°C

Memory info
Memory: 944476 Ko
Free: 88592 Ko
Used: 855884 Ko

Storage info
INTERNAL storage - Size: 4636Mo
Used: 176Mo
Available for storage: 4217Mo (91%)

Log file: http://logs.volumio.org/volumio/b1otmKf.html

System 2:

OS info
Version of Volumio: 3.601
Hostname: volumio-5
Kernel: 6.1.70-v8+
Governor: conservative
Uptime: 0 days, 0 Hrs, 25 Minutes, 53 Seconds

Audio info
Hw audio configured: Allo Piano 2.1
Mixer type: Hardware
Number of channels: 16
Supported sample rate: 44100 48000 88200 96000 176400 192000

Board info
Version: c04170
Firmware Version: 2023/10/30 16:45:10 Copyright (c) - (embedded)

CPU info
Brand: undefined
Speed: 2.4Ghz
Number of cores: 4
Physical cores: 4
Average load: 47%
Temperature: 63°C

Memory info
Memory: 4089064 Ko
Free: 39000 Ko
Used: 4050064 Ko

Storage info
INTERNAL storage - Size: 26908Mo
Used: 258Mo
Available for storage: 25258Mo (94%)

Log file: http://logs.volumio.org/volumio/DNRmhKR.html

Same issue here, my NAS contains only one folder after the update while it should be 12 folders.

I have a copy from the tag_cache,
Tried to copy it to /var/lib/mpd/ but this doent help.
Even after mpd reboot.
This worked in previous versions.

My NAS is quite big and this will take hours/days :melting_face:
And way too many Pis with volumio on.

We had this issue during QA but we fixed it… Or at least we thought we did…

Can you explain in more details how many drives or Nas shares did you have configured?

Annoying to have a rescan start automatically after the update, As another user mentioned in another post - the size of the NAS is just showing “NaN MB” - this was working in the previous version. The whole update process is not straightforward for a novice user …

Only one NAS attached to all of my players.
All flac, about 12TB of music, one HDD of 18TB connected to usb port of a small HP desktop.
Nas is running on Ubuntu server with smb share.
And is showing in volumio as NaN MB

Same problem here. Local music on a Synology NAS. Size: NaN MB

Update after I have switched on my NAS drive:

Unfortunately it’s the same, i.e. also for this drive I have to rescan it :-/

Apart from an SSD connected via USB I do have only one NAS and for both it is (was) that I had to carry out a rescan. Also for me it’s that the size is displayed as “NaN MB”

I had the same problem on an x86 installation with the music database on a locally attached USB-drive - no NAS. Mind you, the re-scan completed very quickly.

One of the major changes in this current release is a newer MPD version.

This version, upon starting, checks if the db has been generated with a previous mpd version, if that’s the case, it checks if all files are there and if not, removes them.

We had a race condition where MPD was starting before we mounted all medias (USB and NAS) but we fixed it (at least in our systems). This looks like it’s not the case in your systems. Hence the issue.

From now on, this issue should not show again, but we would like to fix it anyway.

To understand at which point your files are mounted, please provide some logs and paste the links here.


Which means I can copy the tag_cache again to my other players if the scan is completed ?
I think I’m currently on roughly 90% since last Friday for one player :skull: damn slow wifi

Player 1 = X86

Player 2 = Rpi4

1 Like

@MikhailK you get the NaN MB indication only on PI, right?

For everyone else, please send logs where you explain your setup. This is really important for us to replicate (on both my NAS it works just fine, this is probably a clash of SMB dialects)

Same here with NaN MB.

My setup:
Pi4B rev 1.2, Volumio 3.601, NAS on a Pi5 using Samba

And on my second system. Same config as the one above. Logs

we found out the root-cause of the problem, it was a regression introduced in the kernel 6.1.70

we have a new test image with the previous version of the kernel (6.1.69), that should not have this bug in place

you can try to update enabling test mode, and verify if the issue is still there?
otherwise, you can flash the test-image on a spare SD-card, if you prefer

1 Like

@Darmur Yes that fixed it. I did the update in test mode.

1 Like


Same problem after update 3.611
Rpi 4, NAS using samba

There seem to be samba issues with the RPi kernel.
Could you please also create a log, just to verify it is the same issue as above?
How to send a log

for me after the update to V3.611 this issue is solved.

Here is my debug log.


I created this log after updating music library finished. Check following process

  1. Add network drive
  2. Starting music library update
  3. I can see music list during updating
  4. When I see the final music list and reload the page or reboot then the music library disappear.

Rpi 4.0, Volumio 3.611

Thanks for your reponse.