VOLUMIO 1.5 for Cubox-i, UDOO and others feedback thread

Dear guys, big release day.
Please post here the bug you can spot. Try to give as much informations as possible, like:

  • Device (UDOO, cubox-i etc.)
  • System description (which USB DAC, which NAS etc)
  • When the strange behaviour occurs
  • Is it a fresh image or did you change something
  • Add anything you think is useful

Thank you and enjoy!

I’ve downloaded the 1.5 image and tested it, here’s my setup:
Device: Hummingboard-i1 (i.MX6 Solo, 512MB RAM, RTL8192CU-based USB wifi adapter, using built-in SPDIF output)
Image: Cubox-i v1.5, fresh install

Here’s my findings:


  • Missing packages - Samba, cron
  • Player name setting is applied literally as hostname (in /etc/hostname and /etc/hosts) - this could be a problem with spaces. Should be transformed into, .e.g dashes. I want my player name as something descriptive like ‘Kitchen speakers’, but as a hostname this could be ‘kitchen-speakers’.
  • Services started on boot (but instead should be started manually by Volumio?):
    [*] mpd
  • upmpdcli (causes a problem because when started as a service takes UPnP name from config file, not player name as when started by player_wrk.php)
  • smbd (nmbd seemed to have been disabled already)
  • samba-ad-dc (not needed?)
  • nginx (tho if disabled as a service Volumio doesn’t start it - incidentally, why is the design like this, that services are disabled and Volumio controls them manually? Why doesn’t Volumio just use service start/stop? Anyway, seems nginx must be started by system)

Not bugs, per se, but problems or things that ‘just aren’t right’:

  • Ramdisk (/run/shm) is 512 MB (tho smb.conf description says 265mb) - Cubox/Hummingboard-i1 devices only have 512 MB RAM total, would be better to set this more dynamically? (in fact, why is Ramdisk in /etc/fstab? tmpfs already exists on /run/shm, so mount shows it twice?)
  • /home/volumio owned by root:root (should be volumio:volumio)

Suggestions, recommendations & feature requests:

  • UpMpdCli version is old (0.63) - update to 0.90 (why not use the provided apt repository?). Also set openhome=1 in config file (for playlist control via, e.g. Bubble DS/UPnP)
  • Consider including sc2mpd with upmpdcli (unfortunately have to build it (and ohNet, ugh…), no pre-built package available) to enable Songcast streaming (OpenHome ‘Receiver’)
  • First boot should expand SD card filesystem (perhaps see how Igor Pečovnik’s Debian image/build scripts do this as an example for Cubox-i)
  • Local storage (on SD card) exposed as a Samba share and indexed as MPD folder would be useful (more useful to me than Ramdisk, but I appreciate others may use that)
  • Lower timeout and other options for DHCP on eth0 so that wifi-only systems boot faster (see, e.g. https://calomel.org/dhclient.html) - sorry, looks like it’s already done!
  • Mount /tmp as tmpfs (RAM)?
  • Use noop scheduler for SD card?
  • mpd zeroconf name is ‘volumio’ - does this cause problems if multiple Volumio players are on the same network? Should MPD take up the player name as its zeroconf name too?
  • Should alsa-utils service be enabled to store/restore volume on boot/shutdown?
  • Set HDMI video output to lower resolution & bit-depth as it’s not really needed? (also set GPU mem options to as small as possible? appreciate some people might use this, and probably can’t disable HDMI as it would get rid of HDMI audio? but my case is headless)
  • Is the serial port TTY really needed?
  • Publish automated build scripts (also see, e.g. Igor Pečovnik’s Debian image/build scripts do this as an example for Cubox-i)

Issues I am experiencing that may be bugs or specific to my setup:

  • AirPlay output is distorted (had this on my previous Debian image too, but tested with ethernet and sc2mpd gives clear audio so don’t think it’s a network bandwidth thing. I’m using Airfoil from a Windows 8 PC, must try with iPhone/iOS too)
  • Network connection seems unstable - goes offline (wlan0 and eth0) but comes back after a few minutes, not rebooted, can’t tell what caused it (no /var/log/messages?), must test without USB wifi adapter

Hi Michelangelo and Volumio team!

I downloaded and installed volumio 1.5 on my cubox-i2Ultra yesterday, and I am very, very happy with the result!
All the issues i had with previous volumio version (i.e. kernel panic during MPD update) are simply gone!!!
This is the very first time I have volumio up and running and it is GOOD!

More detailed feedback:
1- My system:

  • Music (mainly ALAC and MP3) on Synology NAS
  • Cubox mounting the NAS share via NFS
  • Audiolab MDAC hooked up to the cubox via USB (got a hub in between - … the solution I found to prevent pops and clicks when using Archphile)

2- Functioning:

  • NAS mount and MPD DB update work fine!
  • Both Ethernet and Wifi do function great!
  • Mpod client on iOS: connection OK.
  • Shairport working great from both mac and iOS.
    Basically, all I tried is working good!

3- Modifications to the image:

  • Installed lighttpd to serve the album covers for Mpod: works great, no interference with WebUI, and no impact on CPU load, as far as I can say!

4- Bug(?)/Problems/Questions:

  • Volumio and playlists
    From WebUI, it seems feasible to save a playlist.
    I tried, but could not retrieve the playlist(s) I created from webUI, nor from Mpod.
    From Mpod, I cannot save a playlist, which I was able to do when using Archphile.
    Could you please confirm it is possible to save playlists in WebUI and retrieve them on both WebUI and Mpod/other clients?

  • Volumio not playing/no sound
    After discovering volumio and listening to some music yesterday, I switched off the amp and DAC but left the cubox on overnight (Wifi).
    This morning, I switch on the DAC and the amp, connect with Mpod and play a webradio: no sound.
    On Mpod, all looks normal, but it never starts playing. At some point I can read “Paused” on the top of the screen
    On WebUI, the webradio was indicated as being played but…time was not moving.
    From trying other distributions, I know this happens to be a connection issue between the DAC and the Cubox.

I tried to:

  • power cycle the DAC: no sound, same symptoms as described above.
  • switch off DAC, reboot cubox with DAC off: no sound, same symptoms as described above.
  • reboot cubox with DAC on: Voila! There was sound finally.

I will have a look at the logs and give more details about this point when I m home tonight.
In the meantime, any idea, suggestion?

  • Access to volumio via finder (mac OS)
    Even though my previous tries at volumio were not successful, I remember I was able to see and access some folders of the the Volumio machine on my network, directly from the finder.
    This is not the case any longer, as reported there: volumio-cubox-connection-from-outside-possible-t2161.html

5- Tips:
Easy adding Webradios:

  • webradio source: vtuner.com/setupapp/guide/asp/Br … rtpage.asp
  • Include in volumio: download the .m3u file and move it to the webradio folder (/var/lib/mpd/music/WEBRADIO)
  • Update DB and you can find the .m3u file(s) in the webradio folder.

Getting webradios as playlist in Mpod (My cheap workaround to the playlist issue I report above)

  • webradio source: see above
  • Include in playlists: download the .m3u file and move it to the playlists folder (/var/lib/mpd/playlists)
  • go to the browse tab in WebUI and refresh the view. The playlist(s) appear at the same level as the shares (e.g. NAS, WEBRADIO, USB…), and can be retrieved in Mpod under saved playlists.

6- To do:
short term:
Try streaming to volumio with airfoil
Out of curiosity, try to remove the USB hub between the cubox and the DAC and confirm about pops and clicks.
Investigate the no sound issue reported above (point 4, second bullet)
Investigate the playlist issue (any help welcome)
further away:
get volumio to auto-backup (cron to reboot from USB, clone the SD card to NAS, reboot from SD) and keep different versions!

7- Conclusion
Volumio 1.5 is working very good, with only few issues to be worked out (especially the no sound one).
Volumio is a great piece of soft!

Thank you all for your dedication and hard work!


PS: to be added to the to do list, short term: find and press the “donate” button! :slight_smile:

I realise my post might look a bit negative now! Have to say that what I did try with Volumio works pretty well, generally very pleased with performance, and of course, much better than v1.4 image which didn’t boot at all on my Hummingboard-i1.

I think this issue might be related to Samba not being installed. Certainly I can see my Volumio and shares on the network, now that I have installed it via SSH: apt-get install samba

@ImG, no I do really appreciate your detailed and costructive report! You were not negative, instead this helped me a lot. To quote:

  • Need to install Samba, got rid of it for compatibility issues but now I solved the problem.

mpd is started by worker
upmpdcli is started by worker, with all the required parameters also the open home settings

As for the other suggestions, they completely make sense. I’ll refine the code and post the result. Again many thanks.


Volumio detects sound hardware at boot. That is why if you plug a USB dac after boot (or you turn it off) the device is not recognized. I may implement an hotplug function in next releases to solve this issue… But this is something quite complicated as lot of services need to be restarted as well…

Hi , I tried upgrade my Cubietruck to Ver 1.5 , everything is fine but Library can’t find my SATA Harddrive , even I change the folder . I am sure the haddrive is mounted … :confused:

Hi Michelangelo!

Same problem with my SSD and cubietruck. No SATA recognition. Would it work with the recommended workaround of V 1.4?

One more thing: External USB drive doesn’t power down after shutdown (Same as with V 1.4)

Everything else seems to work fine for my needs.

Greetingz, Robert

the cron deamon is missing / disabled by design it can easily be installed if needed, but volumio it self doesn’t need it. maybe in the future if / when volumio turns in an alarm clock schedule-play-list-t564.html

@ flahutbux
You should be able to find the playlists in the Browse tab


@ Michelangelo
Thank you for your answer about the “no sound issue when starting the DAC with Volumio up and running”.
I clearly understand now the reason why, and confirm the hotplug function in future releases would be appreciated.

When I create a playlist and save it with the webUI or Mpod, I cannot retrieve it.
It does not appear in the browse tab, nor in Mpod.
I checked the playlist folder (/var/lib/mpd/playlists) and it remains empty, as if no playlist was created.
However, when I manually place some .m3u files (webradios) into the playlists directory, then they appear in the browse tab.

Anyway, still very happy with Volumio 1.5!

Had about no time to continue exploring Volumio further but I can confirm that:

  • Streaming with airfoil to Volumio (shairport) works well
  • I have pops and clicks if I remove the USB hub between the cubox and the DAC.


@chevelle and metalrob

You should use the same fix used on 1.4 . So, assuming the hard drive is mounted on /mnt/

To see it we create a symlink

cd /var/lib/mpd/music ln -s /mnt/

Let me know how it goes

Yes this is a current bug. Thanks for reporting. The fix should be this (cannot check now)

Add this to /etc/mpd.conf

playlist_directory    "/var/lib/mpd/playlists"

Then give appropriate permissions:

sudo chown mpd /var/lib/mpd/playlists sudo chmod 777 /var/lib/mpd/playlists

(we could also apply more restrictive permissions, but let’s check with this)

And for your DAC, guess this is a power issue. Is your hub powered (I think yes)

Let me know

Hi , I tried to do the fix , but when I refresh the library , it still have WEBRADIO , NAS , USB and RAMPLAY . I did’t see the harddrive I’ve mount :cry:

Udoo +volumio 1.5 : the library tab doesn’t work better than before with big collections (appears empty).
(it seems to be the same as described in this thread : library-empty-after-scanning-18232-m4a-files-t1385-20.html)

Hi Michelangelo

Thanx for the playlist fix! Works good now!
FYI, the playlist directory is listed correctly in /etc/mpd.conf. It is just a matter of permission.
Installed samba as well, and now I can see and access volumio from the finder!
All good now!

Regarding my pops/clicks issue, I confirm the USB hub between the cubox and the DAC is a powered-type USB 2 hub.
However, i realized by accident/luck that I do not need to have it plugged to the power line for it to work and to remove the sound issues.
I m still puzzled about it, but it works!


Michelangelo, could you point me to the code/system which Volumio uses to detect sound hardware while booting? I’m playing around with UDEV and it would be nice to see how Volumio detects sound hardware at cold boot :slight_smile:


As it turns out, the user rights and the access mode of the device nodes of the USB DAC are not correct after hot plugging:

  • After a cold boot, in /dev/snd/ you get:

crw-rw---T 1 root audio 116, 0 Jan 1 1970 controlC0 crw-rw---T 1 root audio 116, 16 Jan 1 1970 pcmC0D0p

  • After hot plugging, in /dev/snd you get:

crw------- 1 root root 116, 0 Jan 23 18:09 controlC0 crw------- 1 root root 116, 16 Jan 23 18:09 pcmC0D0p
Volumio does see the USB DAC in that situation, but music won’t play. After issuing:

chmod +grw /dev/snd/controlC0 chmod +grw /dev/snd/pcmC0D0p chown :audio /dev/snd/controlC0 chown :audio /dev/snd/pcmC0D0p
you get:

crw-rw---- 1 root audio 116, 0 Jan 23 18:19 controlC0 crw-rw---- 1 root audio 116, 16 Jan 23 18:19 pcmC0D0p
this is enough to make the DAC play music as it should :sunglasses:

The next step is to make this automatic. I guess this will be a case for UDEV.


I think the last post confirms my experience. I have a hard time getting my USB-DAC to be found.
With the USB-DAC powered and starting up my CuBox-i2 it is in some cases found. If not, after reboot
it is almost always found. My biggest problem is that i lose the connection when playing music as well !?
The music goes silent but the WEB UI continues playing. When looking under Player settings, the D20 option
is lost.

Is there a quick fix to make this more stable. I will just use my USB-DAC. I am not programmer .o)

The playlist is hardly working for me at all. It behaves strangely. Adding items sometimes add something, sometimes not.
Sometimes it starts playing songs (when double clicking in library), sometimes it just ads it to the list, sometimes the whole
playlist gets erased. Will try the Playlist rights fix suggested earlier. (Indexing the library worked fine).

I am also missing the RAM Play options. Don’t see them on my Win7 computer anymore.

In general this release is a really big step forward (I had almost given up hope). The Spotify extension worked straight away,
WiFi worked straight away etc.

Really good work so far. Thank you ! Donation on its way !!

(( Phi

Missed this thread and opened a new bug report, but here it comes. CuBox i-2 with wi-fi,

This issue that I found is that the CuBox must be connected to my router via a network cable for Volmio to work.

When Volmio is connected and booted via a wire to my router, I can configure both the wire and wireless connections. I may disconnect the cable, and the wi-fi works fine.

However if I will reboot the CuBox and it is not connected via a wire to my Router, than after the boot volymio will not start any network connections.
Even if I will connect the cable at this stage, Volumio networking will still fail. No data on the cable.

Bottom lne - Must have the network cable connected for Volumio to boot and be on the network.

Thanks in advance !!


Device (UDOO, cubox-i etc.) - Beagleboad Black

System description (which USB DAC, which NAS etc)

  • Devialet D200 DAC/AMP (USB)
  • Readynas PRO4

When the strange behaviour occurs

  • During startup. Sometimes you get sound, sometimes you don’t
  • Or when you turn off the DAC, leaving the Volumio turned on. Next day, you cannot proceed to playback.
  • Sometimes no sound at all, even though I saw USB is connected at both ends.
  • Playback of DSD (with DSD option turned off in Volumio) resulted in “stuttering” playback. I can hear the music, but between pauses and playback.

Is it a fresh image or did you change something
Fresh image.

Add anything you think is useful

  • Usually nearly every single time, I need to ensure that DAC is turned on properly and set to USB as input, and reboot Volumio to start playback.
  • Any way of breaking this chain will disrupt all playback. Nothing works until I reboot everything.
  • For DSD, it appears to be working, but stuttering playback. Devialet does not have native DSD decode, but Volumio does DSD through PCM. That should work. However, playback issue. Not enough CPU power?

@madsumm: have you read this thread: https://volumio.org/forum/usb-dac-hotplug-t2515.html?

Maybe it will solve your problem :slight_smile:


Anything on the wi-fi problem ?
Is wi-fo working OK on devices other than CuBox ?

Thanks again,