V1.4 Library is empty after scanning 18232 m4a files

I have a NAS mount with 18232 m4a files, have scanned it, they show in “Browse” Page but “Library” page shows Loading for a long time and then all lists are empty.
I tried a smaller folder with 6844 m4a files. Now i can see filled lists in the “Library” page, but scrolling is nearly impossible with Safari 7.0.4, extremely slow.
With Chrome on Windows, i can scroll the lists, but i´m missing the play/add buttons in the Albums list.

Are you using Raspberry PI? Try to use ctrl + f5 to update your browser

Rapberry Pi, 1.4, 8Gb Class 10 SDHC card.
Firefox accesing from both Linux computer and Android Tablet

I must report a similar issue. I have not had time to investigate a bit more till last night.
My music shows and works perfectly in the Browse tab but Library fails.

I tested by successively adding samba mounted sub directories. My music is 100% flac varying bitrate, properly tagged
and organized in /TopLevel (1-5)/Artist/Album/(Optional CDxx)/Titles.flac structure.

Adding directory one, 6715 songs (66 genres, 207 artists, 543 Albums) works fine.
Adding directory two 1324 songs (totalling 8039 songs) works fine
But adding third directory 2222 songs (totaling +10.000 titles) and library tab fails - no songs listed.
Browse tab still works fine.

If I remove the third directory content and update the Library Tab is still empty.
And now the two first NAS directories are missing from the browse tab also.

I had to remove all mounts and re-add for the Browse (and Library tab) to work again.

Last item adding the first 2 directories and then a third with 1829 songs in totalling at 9868 song and Library Tab works.
That is keeping number of titles below 10.000 and it seems to work.

Please advice if I can help with further information.

For me the Library tab is a dream come through, if it had worked.
A otherwise very pleased and grateful Volumio user


Good work Palle, so now we know that the library backend cannot handle 10k+ files… Going to have a look to this

Need a fix too :slight_smile:

I have the same problem with a library accessed via SMB. Can browse via the “Browse” tab, but nothing shows up in library. I have about 50 000 flac-files, so way over the probable limit of 10 000. I work around this problem by using BubbleUPnP-remote on Android with my HomeServer as library and Volumio as renderer and then everything works like a charm. It’s not possible for me to set Volumio as library in BubbleUPnP-remote, then nothing shows up - so it only works as a renderer.

I run a Raspberry Pi with 256 Mb om RAM, 8 Gb SD-card Class 10.

Unfortunately I’m seeing the same issue: I just set up volumio today on a 512MB RasPi, connecting to a SMB share on a Mac with ~37k m4a and mp3 files in the directory structure.

I’m experiencing exactly the same behaviour: database updates slowly and shows genres, artists, albums and tracks on the Library display as it does so, but once complete the library appears to be empty.

Hoping a fix comes along for those of us with more music than sense

This may be a step in the right direction:

It seems that, by default, mpd has a 10000 track limit on playlists.

I’ve tried adding the following to my /etc/mpd.conf:

…then restarting the system but not seen any change :confused:

Update: I tried running this up on a BBB today to see if the extra grunt helped out at all, no luck.

Volumio quite happily scans my entire library over SMB and it can be browsed from the “Browse” tab, but clicking “Library” give me the “LOADING…” page for just over 30s then shows a blank library. That time of 30s is consistent every time I try to refresh the library window. As a consequence I’m thinking this is a timeout issue. htop shows the “php-fpm: pool db” process using up all available CPU for that 30s period then returning to idle once the blank library is displayed.

It looks likes the issue may lie with php-fpm’s “max_execution_time” setting. I’ll tinker and let you know how I get on…

I´m having the same problems - too many Files and a blank Screen…are there any news about this problem or how to fix this? :frowning:

I’ve got the same issue popping up for me. I can browse the nas share, but the library just spins and then comes up empty.

Bump - I have this problem too!

From the excellent beet’s stats, you can see my library size is very large:
Tracks: 35381
Total time: 15.6 weeks (9445345.40 seconds)
Total size: 280.0 GB
Artists: 4892
Albums: 2943

I’d be happy to help test a fix, but don’t know how to solve this myself.

Bump again. Lots of Flac, and a blank library… Any updates or ideas for a solution greatly appreciated :wink: o

I am experiencing the same problem. Any news on a fix or work around? All of my music is in the root directory of the USB drives that I tried with the same result.


Unfortunately I cannot remember exactly where I read it but…
In a comment about 1.4.1 michelangelo wrote that they have temporarily disabled the Library tab since it was not working properly.
They plan to re-introduce it when problem fixed. However they are currently prioritizing other issues that is asked for by more users.

Let’s hope that is soon.



So rpi loses the webui for the library? I investigated a little more: no errors in mpd.log, and scan/updates occur successfully. ‘Cantata’ mpd client connects and sees the whole library, so the problem must be in the webui, maybe memory problem or such like on the poor little rpi. Cantata etc is a good solution on a pc, but the webui was really cool on a phone/tablet - I really hope someone can fix it!

Any one who experienced this issue who has some skill in debugging. Please check this thread…



Not sure it is only PHP/webUI issue.

I am facing the same issue on raspberry Pi and Volumio 1.41:

  • First I have plug a little 32Gb USB stick full of MP3/FLAC music. The update library succesfully done and I can play all my music;
  • Then I reboot with a 500Gb external hard drive full of MP3/FLAC/DSD music. During the browse of the drive I can see and play found music but at the end of the scan all scanned music are disappear and the old music database (the one of my first USB stick) is displayed.

I have check the mpd.log and I have ton of
“Note: Trying to resync…
Note: Hit end of (available) data during resync.
Oct 19 20:30 : mpg123: mpg123_getformat() failed: Message: I am done with this track.
Oct 19 20:30 : ffmpeg/mp3: Header missing
Oct 19 20:30 : ffmpeg/mp3: Could not find codec parameters (Audio: mp3, 0 channels, s16)
Oct 19 20:30 : ffmpeg/mp3: Estimating duration from bitrate, this may be inaccurate
Note: Illegal Audio-MPEG-Header 0x00000000 at offset 4092.”

That suggest me that there is issue with large database and this version of mpd.
Maybe try to update mpd following tutorial-update-mpd-version-t642.html

same issue with mpd 0.18.9 but it crash with error:
“*** Error in `/usr/bin/mpd’: munmap_chunk(): invalid pointer: 0xb1828ce8 ***”