UTF-8 support [Solved]


First, I would like to thank you for your great work. I follow you since a long time now, and it’s a pleasure to see that things are constantly moving in the right direction.

A short description of my system :
I installed Volumio on a raspberry pi. My music is stored in a HDD, connected with USB to the Raspberry.
For digital to analog, I used a small board based on PCM2704, which make the conversion from USB (on the raspberry) to SPDIF. SPDIF is then converted by a Musical fidelity M1DAC.

As I don’t want to move my USB HDD each time I want to add music on it, I use Samba, and from my computer (on Linux Mint) I have access to the USB HDD connected to the pi.
The problem is that accentuated characters don’t appears well. For example, Björk appears as B0A235~X, Noir Désir appears as NEBBU7~Y…
Moreover, it prevent me to copy files which names have accent.

I tried to modify /etc/samba/smb.conf by adding :
dos charset = CP850
unix charset = UTF-8
unix extensions = no
display charset = UTF-8
at the end of the file (I have previously commented dedicated lines on /var/www/_OS_SETTINGS/etc/samba/smb.conf)
But it doesn’t work.

Previously, when I used Raspify RC2, both smb.conf and /etc/fstab have been modified and it worked
(in /etc/fstab, i mounted my USB HDD with this line : /dev/sda1 /media/music auto iocharset=utf8,gid=pi,uid=pi,noatime 0 0)

Now in Volumio, in fstab, I don’t see any reference to the USB HDD.
What should be modified to solve this problem of accent ?

Thanks for your help.

Volumio uses usbmount

so you should have your config files in /etc/usbmount/usbmount.conf

(I may not remember correctly, but you should be able to see them…)

Let me know!

Thaks for reply.

I then modified /etc/usbmount/usbmount.conf
and uncomment the line :


then add iocharset=utf8 :


I now see my files with accent (Björk is Björk !) ans am able to copy files from my PC to the USB HDD.

but it seems to raise problems with mpd as it want not play music any more…
Many thanks

Did you try to update the db again?


problem will be in “dmask=0777,fmask=0777” you should have it as FS_MOUNTOPTIONS="-fstype=vfat,iocharset=utf8,gid=root,dmask=0002,fmask=0002", because with 0777 you will get rights d--------- and mpd doesnt have rights to read it :slight_smile:

It works !
Thank you very much !!

Hi! Happy New Year!

I have the same problem with albums with Greek characters, but I know very very little about linux, so my question is how to call the /etc/usbmount/usbmount.conf from ssh, so to edit it? How to see and edit this confguration (and other configuration) files in volumio?


easiest can be use software called WinSCP.

Hostname: volumio.local (or IP of your volumio)
user: root
password: volumio

but be aware what are you doing :slight_smile: (you can edit files by clicking right -> Edit)

PS: Do not edit files in Notepad (use PSPad or something like that if you download the file locally, editor in WinSCP is OK)