Accented characters in Folders and file names displayed incorrectly on USB Pendrive and messing up Music Library and SMB Network Share view

Hello, I have just updated from 2.917 to the newest 3.233 on Rpi 3B+, and suddenly discovered these anomalies with accented characters (Hungarian in my case) with folder and audio file names:

This is how they shown in the Music Library after I’ve browsed them from my USB Pendrive (connected directly to the Pi Box):

See that there are “?” characters where should be the normal accented characters, like á,é,ő etc…

And that’s what I have found when i tried to access the Volumio’s Network SMB Share->USB drive through Windows (with Total Commander):

Edit. (correction): You can see on the left side how the folders and the file names should be displayed normally, and on the right side, how the Volumio device shows them from the network share of the USB Prendrive that contains the files on it (the ones that have accented characters in their name are now totally scrambled, random character-lines).

When I unplug the USB Pendrive from the Volumio device and plug it in to my Windows PC all the folder and file names show correctly on the drive.

So it’s rather a totally mess up right now. And there was no problem at all with these characters on the 2.917 version. Please suggest a solution to resolve this, or if it’s general (what I think it is), then please fix it!

Thank you!

Edit.: I have edited Playlist to Music Library both in title and the description, as I have realized that the bug is rather particularly presented there…

Would it be possible for you to send some of the affected files via mail to Michelangelo at volumio dot org?

I could and will if it goes no other way, but the most simple way to test it is i guess is to take these example folder names and file names with copy->paste from here to an USB Pendrive while making this new directory and within you can use and copy any other mp3 audio files to rename them to these names, than plug the Pendrive into the Volumio device.

Jó Slágerek

Files within folder:
Sárga kikötő.mp3
Piroska és a kabátja.mp3

My presumption is than in case of the folder and the first two files (that have accented letters) will show the same result as on the picture with ? characters in their names in the Music Library and totally random characters from the Network view. The third file is a “control file”, that has no accented letters in it’s name, so it should be displayed properly. Please feedback if it’s or isn’t a viable solution for testing and how it went for you.

Thank you!

Edit!: It seems that in the case of Volumio’s Music Library, only files without mp3Tag track name info are affected. Couse in this cases Volumio displays rather the file name as on the USB media (with .mp3 extension at the end), and thus the ? character issue occurs. But not in the case, when the m3Tag track name info can be read out by Volumio in the Music Library, because that is still displayed correctly even with accented letters. So please try to do the upper suggested “test trick” with mp3 files that have the track name info removed from the mp3Tag. But still regardless: even this issue wasn’t present in v. and from the network share view the folder and the file names are messed up in these cases (of course because mp3Tags doesn’t affect these).

I have found a very similar issue to me mine in this thread: Link

Tho’ it’s juts a “hacking” solution, but no better given (that I could know at the moment), I would try the trick mentioned there to modify the usbmount.conf file, but in my case there’s no usbmount.conf file at all on the Volumio’s SD card anywhere (tho’ it is likely supposed to be in the etc/usbmount folder, that is also missing in my case). I have searched through the whole file system with WinSPC from Windows through SCP connection for both the folder and the file, but ended up with no results. (Maybe it’s because the new version of Volumio uses a different config file logic, but at this point I’m helpless here on my own). Any tips you have that what could be the catch here and what else I could to try in my case?

Thanks guys for reporting and for the hints.

It has been fixed:

We will release a new update this week.

Thank you for the fix, will be waiting for the update!

Hello, so when we can really anticipate this update? (Newest version still on 3.233).

Well, no replies here since, but the update has finally arrived yesterday and it really did fix the this issue… Tho’ thus I have to delete and remake all of my Playlists to make them work again, because of the character differences in the file names Volumio won’t even start to play them. Have to wait for it more than anticipated, but finally, things get work as they used to, so thanks for the fix!