USB storages not recognized by Volumio

I am struggling to get music with my ALLO USBridge signature + Shanti with the latest Volumio version. For some reason Volumio doesn’t recognize the USB hard disks connected, I have tried with a lot of them: a 1TB self powered lacie fat32, a 1 TB self powered Packard Bell exfat, a 500 gb not powered Toshiba fat32, with some of these the music library icon shows an acquisition process in progress but even waiting for a lot of hours the files never become available and the music library remains empty. The only device that is fully recognized is only a 1 gb pendrive …
many thanks to you for any support

Have you tried support at Allo?

yes but after some days they have not solved the problem yet

You could have a look at the system logs and see if the USB drives are actually being mounted (and if not there might be more info given).

Unfortunately I have limited computer skills… how can I do it? a command through SSH?

/dev/sda2       932G  615G  317G  67% /media/UNTITLED

So, you can see that you have a device mounted as sda2 of size 932GB with 67% space used.

/dev/sda2 on /media/UNTITLED type vfat (rw,nosuid,nodev,noatime,uid=1000,gid=1000,fmask=0000,dmask=0000,allow_utime=0022,codepage=437,iocharset=ascii,shortname=mixed,showexec,utf8,errors=remount-ro,uhelper=udisks)

It is formatted with vfat, and mounted with the usual Volumio mount options.

Then there is a long list of items being removed from and added to the library … presumably you changed the storage device? There are also warning by the system that devices are not being properly unmounted … personally I wouldn’t plug/unplug usb sticks while the device is running in case of file corruption.

Rest of the boot seems to go ok up to:

Mar 11 06:46:52 volumio volumio[1032]: info: Exploding uri music-library/USB/MY PASSPORT/Enrico Pieranunzi & Bert Joris - Afterglow (2021) FLAC/00 Afterglow.m3u in service mpd
Mar 11 06:46:52 volumio volumio[1032]: scanFolder - failure to stat '/mnt/USB/MY PASSPORT/Enrico Pieranunzi & Bert Joris - Afterglow (2021) FLAC/00 Afterglow.m3u'

being shown repeatedly. Presumably you were trying to play this track, but it can’t be found in the library. Can you see anything in the library?

First of all thank you very much for your interest! only a small part of the hard disk “USB my passport” remained visible in the library for a while while the rest was never loaded (while the part was visible I tried to play a couple of files without success) moreover after all activity had ceased I tried to safely remove the disc and an yellow error window appeared that sounds something like this: impossible to umnount the disk since there is not a mount point.
I made another attempt with another HD (the fourth) a 500g HD iformatted EXFAT filling it only for 30G. This seems the only to work regularly…later I will try to add more files

i added other files to the new HD until 50 gb and they are available on volumio library: that’s the good news but…even the this HD cannnot be regularly umounted, the system screams …mount point not found!
I cheked again this disk through the disk utility of my macbook pro and it does not find any file system defects so the bug must be inside Volumio

Hello fastfish.I have the same problem with the USBridge Sig. I bought 10 days ago.Things went OK at firs moment, and I was able to change USB drives,and Volumio instantly recognized USB storages.Just had to wait for the library update and everything was OK.
Things went wrong two days after the purchase, just right after I updated Volumio to the latest version.
I don’t know since when you have the USBridge,so ,¿have you experienced this issue always or only just after the Volumio update?

Hello Jupiter no I did the reverse: I started with the last Volumio version, after the onset of the problems with the usb disks I also tried a previous version but it still didn’t work…I can only think that volumio is very picky towards USB disks and doesn’t love old and more times formatted disks

I don’t know what’s going on.I have two plus devices running Volumio;a Pi4B and a Digione Player with a Pi3B+ and using the same USB storage devices (both a pendrive or a HDD) work perfectly fine.I mean Volumio itself is not the problem.I guess Volumio integration with USBridge Sig USB ports could be the reason.
In my case, I’ve been able to load USB storages a few times, but they misteriously disappear after a
re-boot…really weird.I’ ve tried with Moode OS with similar results…

If you have the problem with Moode too for sure the problem is not only inside Volumio. It may be in the integration between USB sig. and Volumio as you assume. Anyway today I installed a brand new hard drive and thank God it works! This confirms my guess that the USBridge struggles to read disks written and formatted many times (even with high-level formattation)

it even could be the passport i had one that booted after the system boots and that could be the anwser why it’s not seen in the system in the beginning.

I’ll follow this as well since I’m having the same problem in 2.874

I spoke too soon, today I added another 300gb folder to my brand new WD red hard disk in a Loetad case and after booting Volumio doesn’t recognize the new folder … what the hell will be the problem? Could it be only that my computer is a mac?

Do you have access to a RPi? It would be interesting to swap out the USbridge, and see what happens :grinning:

You are right, I will try to find a RPI for testing

After some tests…the problem with the USB disks also manifested itself with a friend’s Allo digione, instead with Moode the same hard disks were recognized without problem. At the end I think the only problem is that Volumio is not that good at indexing large hard drives with AAC encoded files