update issue

2.444 to 2.449 update doesn’t work for me.
It tells me…
“System Software Integrity check failed, manually edited files were detected. System Software Update is not possible under those circumstances. Please execute a Factory Reset or Delete User Data, then retry.”

1 Like

have you changed something in the system using ssh?

Nope. And same issue with two different setups configured identically.
I could perform a factory reset and re-establish my configuration without too much problem, but was hoping not to do that.

don’t forget, you are trying to update to a dev version… :wink:

It’s not a show-stopper. I’ll just leave it as 2.444 for now.
Thanks much.

I see an official update v2.449

I have the same problem and I indeed changed files such as /etc/fstab. Would a factory reset help at all to solve this? Or do I have to take back my changes manually? How’s the system integrity check done, based on checksums?

We added this check because many people that edited their volumio installs manually reported bad behaviours of the system.
So if you edited your files, volumio won’t update (unless you clear user data or do a factory reset).

I thought the error message was self-explanatory, but given your questions, it’s not. How would you change that to be more clear?

In any case, doing a factory reset or deleting user data will do the trick

I edited no files manually on my setups. Still unable to upgrade to 2.452 without incurring this message.

FYI, two of my units are configured identically with Allo Boss DAC’s on top. Neither updates correctly.
A third unit has a PiDigi+ on top, and that unit does successfully update.

A factory reset does indeed work, but that is a tedious solution.


I’m having a problem with 2.452 (the version with August 27 release date).

In my plugin, I load the mpd plugin like so:

self.mpdPlugin = this.commandRouter.pluginManager.getPlugin('music_service', 'mpd');

It does not want to load anymore. I got this error when my plugin tried to stop playback during the uninstall:

TypeError: Cannot read property 'sendMpdCommand' of null

This is affecting the RadioParadise plugin as well. I can’t seem to load the mpd plugin at the moment and things were working right up until I upgraded this morning.

Is there an easy way to get back to 2.444? I am thinking I’ll have to reflash.


error: !!!! WARNING !!!! error: The plugin music_service/mpd failed to load, setting it to stopped. Error: Error: Cannot find module 'musicmetadata' error: Stack trace: Error: Cannot find module 'musicmetadata' at Function.Module._resolveFilename (module.js:547:15) at Function.Module._load (module.js:474:25) at Module.require (module.js:596:17) at require (internal/module.js:11:18) at Object.<anonymous> (/volumio/app/plugins/music_service/mpd/index.js:13:10) at Module._compile (module.js:652:30) at Object.Module._extensions..js (module.js:663:10) at Module.load (module.js:565:32) at tryModuleLoad (module.js:505:12) at Function.Module._load (module.js:497:3) error: !!!! WARNING !!!!
I think I found it. in /volumio/node_modules/ there is music-metadata, not musicmetadata. I changed that in /volumio/app/plugins/music_service/mpd/index.js (at the very top of that file for anyone watching).

Certainly do not change this unless mpd is not working for you. I have not changed anything in my installation except my plugin to my knowledge, but your mileage may vary, as they say.

same problem and did’t edit anything.

@trucker you did indeed change some files, if not you would not have this error. Indeed also using volumio pull triggers the condition when the player will not update.

@jonas can you please tell me from which version you started (the very first one version flashed to your pi) and which plugins you have installed?

@michelangelo Yes, I remember, I did touch a file and put it back the way it was. It was probably that same mpd index.js file I mentioned.

Would it be best to just start over or is there another way to sync my volumio system back to normal?

My Volumio is running on Pi2+Allo Boss Dac 1.2+Allo Isolator. I have just updated to the lastest version of 2.452 (the version with August 27 release date).

My problem is Volumio can play/run DSD files but no sound. All other files are playing normally.



Okay, I checked with git status, and that file was marked as altered, so I checked out the file, discarding my changes.

Sorry for the noise. Turns out it was my fault.

Well, that sucks.

So what is the difference between “Clear User Data” and “Factory Reset”?

I ask, because — if I’m going to have to go through the trouble of reinstating all of my customizations after the upgrade – I’d like to minimize the hassle involved.

Nevermind. I figured it out (always pays to read the source code).

I’m getting the same error. Is there a way to scan the system or read a log file to learn what file(s) the integrity check believes I edited?

I’ve not changed any files only set up through GUI but I get this unfortunate upgrade message anyway!
Not the end of the world but a nuisance to have to set everything up from scratch.

Sent from my iPhone using Tapatalk