Unable to mount Synology network drive

I have a Synology NAS DS214 se with a shared folder. I get the following error:


I’ve enabled NFS v4 on the NAS and believe I’ve set all the necessary permissions.

Thanks in advance

Disable NFS 4.1 in the Synology File Services > NFS menu

Synology Shared Folder > NFS Permissions tab > Create
Hostname or IP : *
Priviledge : Read Only
Squash : No mapping
Security : sys
Enable Asynchronous : Yes

In Volumio > Sources > Add New Drive,
Make sure you click Show Advanced Options and enter the username and password for the Synology NAS.

You may need to delete the existing mount from Volumio and add it again after checking/changing the NFS share settings on the Synology.

Some of the path slashes look to be the wrong way round. Should be \ not /

The path is fine. The slashes look odd but that’s how Volumio displays an NFS mount. I checked earlier.

Personally I share my music folders using SMB/CIFS from my Synology NAS. I have NFS set up for a different application and Volumio connected to it just fine.

Thanks I will try that.

I don’t see how I can configure Volumio to share a folder using SMB. I don’t see that option in the network drive settings.

This worked!!
Thanks so much!

I have another issue. The network drive is successfully mounted but I can’t see any music files that are in the shared folder on the NAS:

If the scan did not start automatically, press:

I already did a Rescan but it doesn’t find any files.

Are you sure that the path /volume1/Media is correct?
Normally the volume is not part of a shared folder.

The ‘volume1’ is completely normal for an NFS export from a Synology NAS.

NFS export names follow the *Nix convention, host:/file/system/path. With softlinks and hardlinks used to obscure the path when required.

Synology DSM automatically creates the ‘volume1’ directory in the root of the file system when the first logical volume is created. The ‘volume1’ directory is hidden from the DSM GUI but visible in a console over SSH.

For whatever reason Volumio displays NFS mounts as a poorly formed UNC (IBM Lan Manager) as used by Windows Networking (SMB/CIFS).

/network geek

Running a QNAP.
I can connect in both ways, either by share <ip>/Music_LL
or full path.
According the GUI the path would be <ip>/DataVol2/Music_LL But this is not accepted. If I would go for the full path I need to enter <ip>/share/CACHEDEV2_DATA/Music_LL

Hence my question if the path is ok.

I think the path is valid otherwise the mount would fail.
Otherwise what do you suggest?
This is my NAS Media folder.

I’m at a loss here. Could it be a permissions issue? I gave R/W permissions to all users.

The Synology NAS is configured to share the folder. Look in DSM > Control Panel > File Services and check the SMB service is enabled. The default settings should be fine.

Volumio connects as an smb/cifs client to the shared folder. In Volumio, Sources > Add New Drive > Show Advanced Options
File Share Type : cifs
Enter the IP and the name of the shared folder and your Synology NAS username and password.

SMB and CIFS have a long and complicated history that predates widescale adoption of the Internet and the ubiquity of TCP/IP. For most all intents and purposes you can treat SMB and CIFS as being the same thing.

I would expect that <ip>/Media should do the trick.
Strange part here is that the connection seems successful but nothing is found.
Which to me indicates there is no music in this folder.
Can you post a log after you have clicked update or rescan.

What is the output of ls -als /mnt/NAS/Synology

I tried this and gety an error saying no such file or directory. I guess I need to use a different path?

Thanks. Will send info later.

or try as path NAS_Home/Media