Unable to mount Synology network drive

I get an access denied error when trying to mount.

Attached log after Rescan.
log.txt (1.1 MB)

sudo ls -als /mnt/NAS/Synology displays the list media files . Note that I have to execute this command as sudo.

should be accessible as non sudo.
please remove all shares from Volumio, reboot and map again.

And please post the link to the log, to keep it readable.

May 12 10:08:32 volumio sudo[5192]:  volumio : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/bin/mount -t nfs -o ro,soft,noauto /mnt/NAS/Synology
May 12 10:08:32 volumio sudo[5192]: pam_unix(sudo:session): session opened for user root by (uid=0)
May 12 10:08:32 volumio sudo[5192]: pam_unix(sudo:session): session closed for user root
May 12 10:08:32 volumio volumio[688]: info: An error occurred mounting the new share. Rolling back configuration

Delete ‘volume1’ from the path so it is changed to just

SMB/CIFS uses the UNC convention

NFS uses the *Nix convention

As I mentioned before, Volumio messes up the NFS locater by trying to make it look like a UNC.

Yes it is a permissions error. Or rather an incompatibility between the Synology NFS export options and the Volumio mount options. (I had forgotten how old NFS is.)

If you really want to use NFS, from the Synology Control Panel > Shared Folder > NFS Permissions > Edit
Squash : Map all users to guest

Then check the guest account is enabled and has read access in your Media shared folder. If you Synology is accessible from the internet, you might think carefully before giving the guest account access to the file system.

Personally I would persevere and get smb/cifs working.

I think I will take your advice. Will also try what Wheaten is suggesting.

To use cifs you only need to delete ‘volume1’ from your path

Volumio > Sources > Add New Drive
Alias: Synology
NAS IP Address:
Path: Media
File Share Type: cifs
Username: HomeAdmin
Password: ********

Check HomeAdmin has read permissions in the shared folder.

I can’t see which version of SMB/CIFS is supported by your NAS, if V3 then it should connect without issues. If lower you need to add vers=1.0 or vers=2.0 in the option field of Volumio, depending on the supported version.

Screenshot taken from a QNAP NAS:

Provided the Synology is on default settings it will support V3

If not, Control Panel > File Services > SMB > Advanced Settings
Maximum SMB Protocol : SMB3

I used these settings and it works!!!
Thanks a lot.

One thing I don’t understand is, In the Synology Permissions dialogue for the Media folder it shows full read and write permissions but if I open a terminal window and display the permissions for Media, I see:
schedule_ 013
You can see that HomeAdmin does not show read/write permissions for Media but I see a + at the end which I believe means it uses extended permissions.
Is this the reason?
Sorry but I only have basic knowledge of Linux


I am not really sure why and where this is documented but i experienced Volumio is doing a read only mount by default.

Set RW in the options field to avoid that

The other question is - why would you like to write to the sources - ripping discs ?


I’m only writing to the Media folder from a PC to copy meda files to the NAS.

Yes the Synology controls file permissions by managing extended permissions, Linux ACLs (access control lists), indicated by the + char at the end of the permissions mask.

ls -hlad /volume1/music?
drwxrwxrwx+  1 root                root                 122 May  7 14:47 /volume1/music

ACLs can be manipulated from an SSH terminal using the command

My advice is, don’t. ACLs are are very easy to mess up and difficult to put right. Incorrect ACLs often cause problems, such as broken software updates, further down the line. If you need to change an ACL on a Synology box it is safer to use DSM or Windows File Explorer.

No need to apologise for that. I’ve been Linux-ing 15 years and still learning new stuff every day.

No, I wasn’t intending to mess around with the ACLs. I just like to understand so thankyou for your help and clear explanations.

1 Like

You may want to try placing the following in the options box “vers=1.0”. That worked for me with Synology but I’m not sure if that NFS option or CIFS.

Been using it that way for years.
Good luck

Maybe you don’t want to do that. CIFS / SMB v1 is littered with well known exploits and is a magnet for ransomware attacks :thinking:

Microsoft have been trying to kill off CIFS v1 since Wannacry took down large sections of public infrastructure around the World. The protocol was deprecated in 2012 and is forcefully removed from Windows 10 and 11 by default.

You are talking about CIFS / SMB. NFS v1 was never released outside of Sun Microsystems internal network.

Synology DSM 6 and 7 are shipped with CIFS / SMB v2, v2.1 and v3 enabled by default. The only reason anyone might need CIFS / SMB v1 is connecting to a very old Windows or MSDOS box - Windows XP, Windows Server 2003, or earlier.

Said every customer who asks me to clean malware off their network :wink:

This works! Thanks

1 Like

I am trying to get Volumio (running on Primo) to connect to my Synology NAS via nfs or cifs but can’t seem to get it to work. Which (nfs or gifs) is better to use? Do I need to create a user on Synology specifically for Volumio or can I use “guest”? Does anyone have a step by step to get this to work?

1 Like