Tidal Connect Failures

Mine is fking up all the time, was thinking it is the hardware if there isn’t a known issue. I Can see on the touch display that raspberry pi 4 is still playing. However nothing on the DAC or no sound. Gets annoying after while wouldn’t get a job as a DJ.

If it’s any help seems to shit itself if you start changing from the native app and tidal app, but is unrecoverable.

Updated to 3.634 this morning and have just spent a pleasant 90 or so minutes listening to music with NO failures. OMG, could it be fixed!?

edit: dammit I spoke too soon. Not long after I posted the above comment it died again. A lot better than yesterday though. New log:

http://logs.volumio.org/volumio/dvazy2h.html

1 Like

not sure what’s going on - i think 2 or 3 version ago was great, nice if could roll back.
some things aren’t worth tinkering with if the reliability no good. Love it in general though.

Updating mine now too.

Broken

Is there any news on a fix for this issue?

I’m hoping a fix is in the pipeline too.

Updated to 3.635 and it froze the first time I tried to skip to the next track.

For last few days it’s working without any hiccups - v3.634. I’ve noticed that MacOS Tidal app works good all time with Tidal Connect from Volumio… I’ve also tried to reinstall Tidal on my Iphone and it helped for now…

Still very broken on 6.636 for me. Working great on my new WiiM mini though.

I’m also having the same problem. PI3+ w/ ALLO DigiOne hat.

Same. Reliability is pretty bad these days, RPi4. Seems to struggle after not long (using the tidal app on pc. Closing and opening doesn’t help, the volumio device needs rebooting fairly often).

http://logs.volumio.org/volumio/Yk8mwXB.html

Thanks

I’ve had to pause my subscription as the only thing I need from it is Tidal playback so can’t test. It’s a shame but hopefully it will be working again soon. I miss it!

1 Like

Same problem here. Literally unusable with Tidal connect.
Just purchased premium and rebuilt half of my setup to now use Volumio as the streamer instead of buying one.
Playing internet radio for hours or even using the integrated Tidal app works without problems for hours, but not Tidal connect.

It seems to be a bigger problem as also the logs seem to crash somehow. I do not get any live logs in the dev console when the issue happens and minutes after. Only when I start to stream from a different service, I get the alsa error and have to reselect the USB output device…

After not even 24hours I really start to regret that I paid money for this. I mean this bug is known for nearly 3 months now…

@sladflob @G-rig @adam_bernatek

Came here to say me too. Even reported this to Support between November and December '23.

It’s fully replicable in different systems/dac combinations, either I2S or USB. It happens when changing tracks - particularly when doing so quickly, one after the other, as if the sequence of commands were somehow saturating, timing out, or blocking a resource and we get the silence + failed to open ALSA device error.

Hopefully it gets fixed soon @Darmur @volumio !