Testing Needed for I2S DACs

Ok, guys. Since there are some issues with current kernel, I will update asap with a new one. Before doing that I want to ensure that it works ok with all the I2S DACs combinations, I simply cannot test them all by myself. This is where I need your help.

So, from your Volumio install (better if fresh), connect via SSH

sudo apt-get update sudo apt-get install binutils sudo rpi-update e38850519c56b835dbd1c81e04d9307e154c36ed sudo reboot

This will install kernel 3.12.26 (a slightly diffrent one than 1.41 tough).
Then please report :

1- Your model (B or B+)
2- Your i2s DAC model
3- At which bitdepths and bitres it works or not

As soon as I have more info, I can release an update, and everyone will be happy ! :smiley:

I just uploaded an updated and fixed image of Volumio @ sourceforge.net/projects/volumio … p/download

Unfortunately I don’t have so much time to test it (leaving for the weekend). Please try and let me know if everything works!
Thank you guys, I am really appreciating your involvement!

Hi Michelangelo,
Not so good…
With model b+ and iqaudio:
Flac 16/44.1 sounds good.
Flac 24/96 no sound.
Flac 32/96 no sound.
Flac 24/192 no sound.
I know it’s not so confortable but that’s what happened to me…!

First – Big thanks for all your hard work Michelangelo!

I installed your updates with the 3.12.26 kernel described above and had much success.

1 - My model is: RPI B
2 - My I2s DAC is: Pi-DAC from IQaudIO.com
3 - I tested & verified: 24bit flac files at 48 kHx, 88.2kHz, 96 kHz, 176.4 kHz, 192 kHz

Before this kernel update I was having problems with Hi resolution files (using Volumio 1.5). With the 3.12.26 kernel all the tested files sounded good.

With the update applied?

Yes sir!
Before the update 32/96 and 24/96 were played too fast, now no sound is played!

After a reboot 32/96 are ok!!!
24/96 and 24/192 still nothing…

May it doesn’t like word at 24 bit…?

I update my Raspberry as you wrote and I did the following test with flac files :
16bits 44khz - ok
24bits 88khz - ok
24its 96khz - ok
24bits 192khz - ok

raspberry B
dac audiophonics ess 9023 i2s -
driver Hifiberry
Software mixer
But but : I can hear as soon as the play start a sort of crakling noise and it stop a the end of play. It is very more important at 16bits 44khz and diseappears with 24bits 44 or 88khz. I first thought of ground loop or something like that, even if I never heard it before.
I 've got from a test disc a “sound of silence” (no music) : the cracling noise appears clearly as there is no other noise.
So I reflash Volumio 1.4 : no crackling noise. So I think it 's a driver bug. Dont you think ?

That works just great, thanks - 16/44.1; 24/96 & 24/192 all play fine…

Raspberry B+, Audiophonics ES9023 I2S, with Hifiberry driver. :mrgreen:

Thank you very much for all your work - this is just great!

I just tested the “downgraded kernel version” and it works :mrgreen:

1 model is B+
2 i2s DAC model is hifiberry dac +
3 perfectly: 24/96, 24/176, 24/192, 16/48. Other formats not tested

Many thanks, michelangelo for the new release and the work for volumio!

I’m sorry, I forgot to mention: 16/44,1 worked always. Only the higher resolution formats didn’t work before the fix

Volumio v1.5 and new kernel 3.12.26 installed on my RPi B+ with iQAudio Pi-DAC+.

24-96 and 24-192 both working perfectly, along with regular 16-44.1. Very happy.

High-res weren’t working before, with the ‘stock’ 1.5 image and kernel.

Many thanks for all your hard work on this. It is excellent. Setup of the Pi-DAC+ with Hardware volume control, via the web interface was easy and trouble-free. I had my install working in about 5 minutes, and I could have sworn that the sound quality is better than in Volumio 1.4 :slight_smile:

Tested on RPi B+ with Curryman Dac Es9023 and Hifiberry driver and everything is ok after update. Thanks a lot for your hard work.

New halloween update:
Everything’s fine!
I changed the driver from iquadio to hifiberry, rebooted, turned back to iquadio driver and rebooted again.
Now all files are played correctly!
The only bug I experienced is that with 24/192 files the time shifting doesn’t appear or it’s wrong, but at this point I’m so happy! :slight_smile:
Thank you for everything Michelangelo!

I have B+ and IQuadio Dac+ (for B+)
I ran a clean image of 1.5
Ran the update commands you mention in this thread
(no sound)
Set appropriate iqaudio driver in system options
(rebooted again in order to get wireless networking working)
Now I can play songs but it sounds horrible - only seems to come out of one speaker with popping and

Edit 1-
Removing my wired ethernet connection resolved the issue of one channel

Stereo - 16 bit - 44.1 kHz seems play fine
Stereo - 24 bit - 44.1 kHz seems play fine (some distortion but probably my own files)

Edit 2 -

24 bit 96 hz IS DISTORTED - too fast/ buggy

Edit 3 -

Volume is not controllable via web UI ; system setting for volume is set to mixer type: “hardware”
Audio Output: “sndrpiiqaudioda”

Edit 4 - I’m an idiot. Somehow I missed the command to actually revert the core version… After doing so and rebooting I can no longer play 24 bit audio (at all). 16 bit 44 plays back fine (and sounds so bad lol).

Clicking “apply” underneath the hardware volume selection in playback options allows Web UI volume control

Edit 5 - Web Radio says it is playing Stereo - 24 bit - 44.1 kHz - and it works. Don’t know why my .flac files with that bit rate are silent.

… and after retrying Stereo - 24 bit - 96 kHz it plays once again. Maybe the hardware mixer “apply” fixed it?

K last update - here’s your thread back.

Model B+

After changes as per Michelangelo post works well on all bitrates. :smiley:


hifiberry DAC+

flac 16/44.1 ok
flac 24/96 no sound
flac 24/192 no sound

With kernel update applied?

Yes kernel updated per your instructions.

Raspberry PI & HifiBerry:

situation before the upgrade

16-44 ok
24-96 too fast reproduction
24-192 no sound

situation after the upgrade
16-44 ok
24-96 nothing happens
24-192 nothing happens

“nothing happens” means that the song doesn’t start and the progress indicator in the playback tab remains 00:00


Everything working with the update! Previously the 24bit caused noisy playing.

hifiberry DAC

flac 16/44.1 ok
flac 24/96 OK
flac 24/192 ok BUT some slightly beeps and cracks.

B+ with Hifiberry+

Applied updates per Michelangelo’s instructions.

Previously, 16/44.1 played fine, 24/88.2 and 24/96 played sped up.

Now, 16/44.1 plays fine, 24/88.2 and 24/96 files don’t start (as described by ggfum).

Additionally, I tried choosing None under I2S driver, rebooted, then chose the Hifiberry+ driver, and rebooted. Situation remains the same.


P.S. I’m new here, and VERY grateful and excited to see (and hear!) what’s happening. Happy to help in this round of bug fixing! :slight_smile:

Yes same here with my B+ and hifiberry +.
I said no sound above, but it doesn’t even start on the 24 bit stuf.

and yes think we’re all excited to get a good working ver and happy to participate! thks all!!