Testing Needed for I2S DACs

Hello, my SD card just broke and after the update and the driver change nothing happened. I tried three times switching between hifiberry+ and iqaudio driver and the 4th time was the right one.
Just insist on two or three times, and maybe it works too!

I performed the update as described and successfully played:

16 bit - 44.1 kHz
24 bit - 88.2 kHz
24 bit - 96 kHz

Pi B+

yesss! it works!

1 model is B+
2 i2s DAC is HiFiBerry Digi+
3 all perfect!

thank you very much for the hard work you all put into this, you are awesome!

I’ve noticed today that some files are skipped in the playlist instead of played. I’m fairly certain at least one of the files worked before the patch. Has anyone else seen this? I’ve seen skipping of both 16bit and 24bit flac files.

Model B
Hifiberry Digi
(Optical to Marantz 7701 pre amp)

1.5 image:

  • 16/44 plays well
  • 24/88 is garbled and slower
  • 24/96 plays faster and choppy
  • 24/192 no sound (buit play indicator ticks seconds)

Applying update from initial post

  • All above plays fine.



@michelangeo: since the “problem” with playing hi-resolution files is linked to a kernel/firmware, I’m wondering if the “update” you’re preparing will be applicable with the new update button or we’ll have to re-flash again ?


after first flashing a fresh volumio 1.5 image i had one of the issues described here by many testers:

  • first file plays back normally
  • stop, load something else, press play and nothing happens (playback indicators stays at 0 seconds, no sound)
  • after some clicking around playback works again (even for the same file that didn’t play at the previous step)

could it be, that this is a separate issue with 1.5? i noticed it before applying the kernel downgrade and after, too.
re-reading this thread it looks like some of the issues reported are similar to the one I experienced and thus maybe not related to the kernel “fix”.
the testing pattern of the kernel fix could easily trigger this “other” bug (start playback, stop, start another file, etc.).

Just my 2-cent.


Hello Volumiosos

Nooby here.

Recently connected Sellarz DAC 24192-ABR to Raspberry Pi B+.
(Wired connection since Sellarz DAC is intended for RPi B not B+)
Helpful Sellarz from Korea provided GPIO connections for B+.
Immediate music heaven.
(Michelangelo: Remember Sellarz?)

Updated to Volumio 1.5:
16 bit music OK
24 bit music fast garbled: bad sound

Installed Putty and , for the first time ever, logged into my Raspberry
(First command line typing since MSDOS days).
Executed the command lines in this thread: Heaven again: 24/192 works!

Thanks you guys!


fresh install of 1.5:

16bits 44.1khz OK
24bits 44.1khz OK
24bits 88.2khz NOT Working
24bits 96khz NOT Working

after modification of the kernel:

16bits 44.1khz OK
24bits 44.1Khz OK
24bits 88.2Khz OK
24bits 96Khz OK

Pi model B
Hifiberry Digi+ connected to DAC
Cannot test 24bits 192khz because not supported from my DAC


Raspberry Pi B
Hifiberry Digi (spdif coaxial output)
Benchmark DAC1 HDR

fresh install of 1.5:
16bits 44.1khz OK
24bits 44.1khz NOT Working
24bits 96khz NOT Working

after modification of the kernel:
16bits 44.1khz OK
24bits 44.1khz NOT Working
24bits 96khz NOT Working

It seem that once it is 24 bit, the decoding fail to work.
but if I use the built-in resampling algorithm every thing work
16bits 44.1khz OK
16bits 96khz OK
24bits 44.1khz OK
24bits 96khz OK
32bits 192khz OK
32bits 384khz glitchy (hifidigi don’t support the format / or cpu workload overloading)

I really don’t want to use the software resampling for music…

After I disabled the resampling all the format works now!!
16bits 44.1khz OK
24bits 44.1khz OK
24bits 96khz OK

weird…but my music is back!!

1- B+
2- Hifiberry DAC+
3- Tested up to 24bits 96Khz and work perfectly!

I used a fresh Volumio 1.5 and ran the updates suggested in this post.


That’s great ! An update is landing soon!

I just uploaded an updated and fixed image of Volumio @ sourceforge.net/projects/volumio … p/download

Unfortunately I don’t have so much time to test it (leaving for the weekend). Please try and let me know if everything works!
Thank you guys, I am really appreciating your involvement!

Hello Michelangelo

First off all, many thanks for making this great software!
Before the update all my high resolution files (all higher than 24 /192) where unable to play.
But now my raspberry B+ with the Hifiberry + plays all my files flawless .
Even 32 bit 192 files.
Volumio rocks!


Tested with the new 1.51
1- Raspberry B
2- HIFIMEDIY ES9023 I2S DAC FOR RASPBERRY PI MOD B 192KHZ/24BIT (using Hifiberry settings)
3- Tested up to 24bits 192Khz and works nice!

Pib+ hifiberry dac+
only get “ALSA” in drop down for audio output.
so not able to select my hifiberry…

sorry didn’t load the i2s driver…urgg

Pi B+ and Hifiberry Dac+
working with all flac resolutions!!! awesome! thks guys


PiB with the new 1.51 & Hifiberry -> 24 bit - 192 kHz works fine!

Now I can hear Helge Lien Trio “Badgers And Other Beings” in HighRes again. A great “thank you”. :smiley:

LG Gerry

Thanks! Works here as well with Digiberry+ and 32/176.4, 32/192 files.
What I do see however are errors on the SD card:
[ 302.698796] EXT4-fs (mmcblk0p3): error count since last fsck: 3
[ 302.711242] EXT4-fs (mmcblk0p3): initial error at time 1396987247: mb_free_blocks:1426: block 309248
[ 302.726951] EXT4-fs (mmcblk0p3): last error at time 1396987322: ext4_remount:4680

It’s a B+ Raspberry with a stable power supply (12 Watts), so I should not see SD card corruption.
Also, the errors are triggered mainly when playing hi res audio. I have seen errors also when playing 16/44.1 files, though.
Is my SD card shaky, or do others see a similar corruption?

My experience with volumio 1.51 on raspberry pi B+, + Pi DAC +
downloaded 1.51

flashed SD card
used webui to change system driver to IQaudio under i2s drivers
and under playback I specified hardware mixer and saved the setting

  • heard the startup sound via the headphone jack :slight_smile:

Test of streaming all listening via PiDac+ headphone output

  • web radio streams worked
  • airplay worked from ipad and iphone

Files on local usb stick—found after doing a “Library Update”

  • mp3 files played
  • ogg files played
  • flac files at 44 kHz 16 bits played reliably (these were created from CDs
  • flac files from 192kHz/24 bits played one track, but then hung and wouldn’t play anything else