Spotify Plugin not working/ Playing Music

Hello everybody,

I have just installed volumio on my raspberry pi 3b+.
The first thing I did was activate the Spotify Connect plugin. It works fine.

Then I installed and configured the normal spotify plugin, which can be used to display the spotify playlists via Volumio.
I registered with my premium account and then authorized the connection. I can search for songs / playlists and see my own playlists, but I cannot play any songs. The popup appears that the song is now being played, but nothing happens.
I use the Aux output from the Raspberry and i use WIFI.
Spotify Connect works perfect but the normal spotify plugin to control songs via the Webgui from Volumio has problems with the playback…

I hope someone can help me :slight_smile:

This is in the log after i want to play a song from spotify through the webgui connected to my spotify account

info: CoreStateMachine::play index undefined
info: CoreStateMachine::setConsumeUpdateService undefined
info: CorePlayQueue::getTrack 0
info: CoreStateMachine::startPlaybackTimer
info: CorePlayQueue::getTrack 0
info: [1624462214444] ControllerSpop::clearAddPlayTrack
info: {“uri”:“spotify:track:53bryiwW9cKTw6K8phb9y8”,“service”:“spop”,“name”:“Dance Like Rihanna - Mixed”,“artist”:“Jerome”,“album”:“Kontor Top of the Clubs - 2021.02 Mix”,“type”:“song”,“duration”:125,“tracknumber”:1,“albumart”:“",“samplerate”:“320Kbps”,“bitdepth”:"16 bit”,“trackType”:“spotify”}
info: [1624462214444] ControllerSpop::sendSpopCommand
error: SPOP command error: Error: This socket has been ended by the other party

I have absolutely the same problem, since the afternoon. The Spotify stop working on all my installations.
At some moments, temporarily, Spotify start working and than nothing again.

I have 4 installations and Spotify is not working on any of them within Volumio. It works using connect, which shows that my account is active and working.

Same here, live log ends in →
error: SPOP command error: Error: This socket has been ended by the other party

Same than you guys, same logs.

Same here. I logged in via ssh to poke around and found the following:

Starting it by hand with spopd -c /etc/spopd.conf fails because it can’t find running ldconfig by hand and then starting spopd by hand again works, but it dies when trying to play.

Adding /sbin/ldconfig seems to make it start on boot, but still no playback. spopd dies again.

running spopd -d -c /etc/spopd.conf I see this:

2021-06-24 03:23:51 [INFO] Running in debug mode
2021-06-24 03:23:51 [DBG ] Creating session…
2021-06-24 03:23:51 [DBG ] Setting preferred bitrate to high.
2021-06-24 03:23:51 [DBG ] Setting preferred offline bitrate to high.
2021-06-24 03:23:51 [DBG ] Setting cache size to 0.
2021-06-24 03:23:51 [DBG ] Session created.
2021-06-24 03:23:51 [DBG ] Logging in…
2021-06-24 03:23:51 [SPTF] 03:23:51.327 I [offline_authorizer.cpp:297] Unable to login offline: no such user
2021-06-24 03:23:51 [DBG ] Will listen on…
2021-06-24 03:23:51 [INFO] Listening on 6602
2021-06-24 03:23:51 [SPTF] 03:23:51.336 I [ap:1752] Connecting to AP
2021-06-24 03:23:56 [SPTF] 03:23:56.338 E [ap:1694] AP Socket Error: Timeout reached (20000)
2021-06-24 03:23:56 [SPTF] 03:23:56.339 E [ap:3953] Connection error: 117
2021-06-24 03:23:56 [SPTF] 03:23:56.339 I [ap:1752] Connecting to AP
2021-06-24 03:24:01 [SPTF] 03:24:01.343 E [ap:1694] AP Socket Error: Timeout reached (20000)
2021-06-24 03:24:01 [SPTF] 03:24:01.343 E [ap:3953] Connection error: 117
2021-06-24 03:24:01 [SPTF] 03:24:01.344 I [ap:1752] Connecting to AP
2021-06-24 03:24:02 [SPTF] 03:24:02.493 I [ap:1226] Connected to AP:
2021-06-24 03:24:02 [INFO] Logged in.
2021-06-24 03:24:02 [SPTF] 03:24:02.819 I [offline-mgr:2082] Storage has been cleaned
2021-06-24 03:24:03 [SPTF] 03:24:03.814 I [offline-mgr:2030] 0 files are locked. 0 images are locked
2021-06-24 03:24:03 [SPTF] 03:24:03.815 I [offline-mgr:2056] 0 files unlocked. 0 images unlocked

That debug output never moves, and in the debug console I wind up back with:

info: [162450391149] ControllerSpop::sendSpopCommand
info: ADDING DEFER FOR COMMAND uplay error: SPOP command
error: Error: This socket has been ended by the other party

1 Like

I am wondering if something changed on the spotify end of things:

1 Like

2 other points on this issue:

  1. I installed my two pi’s last night and they were working. I did not reboot them so did not uncover the LD_LIBRARY_PATH issue then. Things just worked.
  2. That could just be a coincidence or something with my installation, but since others are seeing the same and it all started around the same time, that points to an issue on spotify’s end. I am going to install an older version of volumio and try again with that.

I installed Volumio from scratch on my testing Pi 4B, last night, it worked for a while, the same I experienced on my “production” pi’s, there were some moments it worked, but rare, the situation happened on 3 devices that I have not been manipulating with before the current failure of playback.
Teorethically the problem could be: a/ Volumio gets hidden patches b/ there is an entity in between Volumio end device and Spotify service failing c/ Spotify has changed “protocol”.

1 Like

Elaborating continue:

I played also with spopd, and found that inability of playback definitely depends on spopd weird behaviour. I exported path from console export LD_LIBRARY_PATH=/usr/local/lib/ spopd and than start daemon spopd -c /etc/spopd.conf, than Spotify disappeared from GUI, and I had to bring it active with new login. Than it started work, even after reboot it worked, but I was not able to reproduce it again. It looks like after issuing the command for playback the daemon starts working for a second till it is shut down by ?? There is a very short blink || on the GUI.There is symptomatic that more people experienced the same problem at the same time. Will be trying on.

1 Like

At least good to know that some have the same problem.
Unfortunately, I am not that into IT.
It would be nice if someone has / knows a solution to provide a user-friendly guide :smiley:

Thanks to invisible fairy, Spotify works again!

1 Like

If someone is still having the issue, logging out and logging back in(don’t forget to authorize aswell), did seem to work for me today.

So what is the solution for the problem?
Could somebody explain it to me?
Thanks :slight_smile:

1 Like

I do not know what is the real solution, can only guess, but do not believe on accidents. Only happy its working.

Okay what did you do that its working now?

The error 117 Spotify means that a connection problem exists and the Software cannot connect to the Server.

I think that it is up and running without any connection to my elaborating, at one device I had to login to Spotify again. I guess It must have been some operational problem.

Unacceptable! Based on the number of posts here and on the help forum there is clearly a problem. This is not freeware, I just paid the yearly fee and now I have nothing.

We deserve a response form Volumio on what they are doing to fix this.