[SOLVED] Failed mounting FRITZ.NAS volumes

I went through all the documentation but did not found the answer. I am using one of those very popular german Fritz-Box as my router with an USB-HDD attached as a NAS containing all the music files. While it is no problem handling this volume from the PC, I was not able to register it under Volumio. When I click under MyMusic / Rescan it only shows up the computer itself, not the NAS drives.

I tried a lot, registering like “” and other and similar but it always gives an error msg… anyone here using the fritz-box as well???

The problem that I have seen with people using USB ports on routers for a NAS is getting the correct name and path of the share (presumably samba/cifs??), because it is not always obvious.

Can you try the following command from an ssh session:

smbclient -L

assuming that your router address is

Well, I am not familiar with linux, ssh, etc., when I recently installed Neutron Player on my android phone I got guided through all the procedure, first clicked the network, then immediately appeared the drives, then the volumes and finally the folder where the music is stored and I saved the process. I thought this could have been similar here… how or where could I see the details you need?

On the IE the mapped drive looks like this: \WD-Elements10A8-01 (\fritz.nas\Fritz.nas) and on the Web-UI from the fritz.nas it says: / fritz.nas / WD-Elements10A8-01 / sofort / musik_alle. I tried all these and other possibilities but had no success…

What I do with my fritz-box and works like a charm (using advanced settings!):

NAS IP Address:
Path: FRITZ.NAS///
File Share Type: cifs

for you I suggest to try:
NAS IP Address:
Path: FRITZ.NAS/WD-Elements10A8-01/sofort/musik_alle/

1 Like

My god, thank you so much, it works perfect, all the music on the lib!!!

I guess I tried this before as well but always with the double back slash before the data!!!

Just one further question: When I click “Music Lib” I see three options. First is the USB inserted in the rpi, second is called “INTERNAL” and third is the NAS (fritz-box).

What means here “INTERNAL”, is it the sdcard? How do I get music on this space? … Is it even advisable?

Depends on the size of your SD card. Someone’s entire music might fit on a 128/256GB card, so why not?

Also the structure is the same in Volumio’s x86 version which you might want to install on a regular SSD or HDD in a computer of your choice.

Internal is the free space of your SD card. You should see it from your computer and able to copy files on it.

Yes, you are right, I tried again and could transfer files and play them with no probs. Thanks again!

Hi all together,

my name is Tom. I’m new to Volumio - thanks to Michelangelo for his great job!
I’m very experienced with Microsoft world but not with Linux. The Raspi with Volumio was prepared by my son.

So - my configuration is similar to Berry’s: FritzBox 7490 with USB-HDD for Music + Raspi + Volumio.

With Kodi on a PC under Win 10 the configuration works fine.

With Volumio I first tried by myself - I love learning by doing without reading advice first :mrgreen: . ==> Connection Volumio to Fritz did not work - of course!

Then I started reading and found this thread and followed shaDNfro:

==> Error message (displayed so shortly that I could not read it)

  • with and without sec=ntlmv2
  • with another (simpler) folder on the FritzBox: fritz.nas/Musik

What seems to me strange is the “:” in the path: … (see screenshot)

In the second trial I followed [Guide] SMB/CIFS shares in Volumio 1.5 https://volumio.org/forum/smb-cifs-shares-volumio-t1461-10.html being aware that it is for Volumio 1.5 while I’m using 2.x.

With this settings I got no error message - the “waiting curl” appeared for some minutes.
After coming back to the user interface nothing was done: No music files even the new share was has not been stored.

Can somebody help me?

Thanks and so long, Tom

well since volumio 2 I do not use the sec=ntlmv2 Flag (Option) any more.

I am not sure if the fritz.nas (in the Path) is case sensitive… I allways use it in Capital Letters (FRITZ.NAS).
You might also add an / in the end of the Path.

Your screenshot shows a “not mounted” red X instead of an green checkbutton… seems the mount did not work at all.

Did you check the ip of the fritz.box (as standard setting is:

Did you set the right user access rights for the folders in the fritz.box settings (I guess you did, if it works with Kodi…)

Bye the way, mounting hughe shares takes its time… Whenever I read in the NAS I’ll wait 24 h until I am sure all my files a recognized and the “search”-wheel vanishes

Hi shaDNfro, thanks.

I checked and tried your hints, but no success:

after pushing “save” I get this error message:

I also tried in shh:

smbclient -L


FritzBox says that login to SMB was successful:

05.08.17 10:46:50 Anmeldung des Benutzers volumio am FRITZ!Box SMB-Dienst von IP-Adresse [2 Meldungen seit 05.08.17 10:46:50]

I had a look to the log file. The part dealing with the FrizBox is this:

Aug 05 13:36:16 volumio volumio[1148]: info: CoreCommandRouter::executeOnPlugin: networkfs , addShare Aug 05 13:36:16 volumio volumio[1148]: info: Adding a new share Aug 05 13:36:16 volumio volumio[1148]: info: No correspondence found in configuration for share Fritz on IP Aug 05 13:36:16 volumio sudo[21978]: volumio : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/bin/mount -t cifs -o username=volumio,password=volumio,ro,dir_mode=0777,file_mode=0666,iocharset=utf8,noauto // /mnt/NAS/Fritz Aug 05 13:36:16 volumio sudo[21978]: pam_unix(sudo:session): session opened for user root by (uid=0) Aug 05 13:36:16 volumio kernel: FS-Cache: Netfs 'cifs' registered for caching Aug 05 13:36:16 volumio kernel: Key type cifs.spnego registered Aug 05 13:36:16 volumio kernel: Key type cifs.idmap registered Aug 05 13:36:16 volumio volumio[1283]: Invalid card number. Aug 05 13:36:17 volumio kernel: CIFS VFS: cifs_mount failed w/return code = -6 Aug 05 13:36:17 volumio sudo[21978]: pam_unix(sudo:session): session closed for user root Aug 05 13:36:17 volumio kernel: CIFS VFS: cifs_mount failed w/return code = -6 Aug 05 13:36:17 volumio volumio[1148]: info: Error mounting Fritz on IP : (6): No such device or address Aug 05 13:36:17 volumio volumio[1148]: Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

For me that looks fine?! But Fritz is not found?

May be there is something wrong with the config of FRITZ.NAS!
Is there a possibility to check if the nas is reachable in the browser?

Is it possible to reopen the thread as [not solved] - I think nobody is reading it :confused:


You don’t appear to have the samba shares that you are expecting on your NAS. After you run ‘smbclient -L’ the only share shown is “7490” If I check my NAS for shares then I get:

[code]Domain=[HOME] OS=[Windows 6.1] Server=[Samba 4.4.13]

    Sharename       Type      Comment
    ---------       ----      -------
    Computer        Disk      Stuff for the Computer
    DVDs            Disk      
    Ebooks          Disk      What it says on the tin
    homes           Disk      user home
    ian             Disk      Ian's stuff
    jeanette        Disk      Jeanette's Clutter
    Manuals         Disk      
    meg             Disk      Meg's pile
    Montages        Disk      
    Music           Disk      
    NetBackup       Disk      System default shared folder
    photo           Disk      System default shared folder
    Photos          Disk      
    sam             Disk      Sam's collection
    temp            Disk      Please clean up if you don't want stuff keeping in here
    Tools           Disk      
    video           Disk      System default shared folder
    IPC$            IPC       IPC Service ()


Can you double check on your NAS that you are actually sharing the directories you think you are?

… you are right.
But how can I add another share?

Obviously I have a knowledge gap.
How can I activate a share of a special folder on the FritzBox?

In my Windows environment music folders appear like that:




Try including ‘7490’ as the beginning of your path?

You could also try manual mounting just to check that you are using the correct path. Try from ssh:

sudo mount -t cifs -o username=whatever // /mnt/NAS/FRITZ

…, and alter the path to suit your exact music directory location. If it doesn’t give any errors, then change to the directory (‘cd /mnt/NAS/FRITZ’) and check your files are shown.

@Silentioso … Isnt it “Netzlaufwerk verbinden…” and using \volumio where it says “Ordner:…” and “Durchsuchen”? that should lead you to the (USB) folder you need…

If I try to “sudo mount …” I allways, what ever I try, get an error:

The problem, is that I do not really understand how to find the right name of the path.

while under Windows




is reachable as well.

under Volumio neither