Solution USBridge and some DACs (Dragonfly and USB 1.1 DACs)

Starting from Volumio 2.348, a new improved USB driver is included on the Sparky image, which will fix a problem with some USB DACs (no sound output).

If your DAC (such as the Dragonfly) produces no sound, do this to fix it:

sudo nano /boot/uenv.txt
  • Locate the line

and change it to


If you can’t find such line, just add it.

  • Save with ctrl and x
  • Reboot

This is the official comment from ALLO

Please report here if changing this setting solved your issue.


I have tried this solution on a new USBridge with my KEF X300AW. Unfortunately still no sound (only cracks and pops).

After adding the proposed line, the content of the uenv.txt is:

Is that correct?


I also tested with a Dragonfly Black and initially had the same issue. However, I edited the uenv.txt file again to append the new parameter at the end of the existing line instead of putting it on a new line. This seems to have solved the issue for the Dragonfly since it now works nicely.

The issue remains for the KEFs however: no sound. (FWIW there’s no issue when connecting them to a laptop.)