Second track always skipped when listening to the first album after starting Volumio

I apologize if the problem has already been discussed but I couldn’t find anything.
I have a problem with Volumio 3.396, I don’t know if it depends on some plugin or what else, but every time I start Volumio, on the first listen of an album, after listening to the first track, instead of starting the second one, it jumps to the third one.

Here’s the log:

In this case, after starting Volumio I selected the album “Jagged Little Pill” by Alanis Morissette. I started the first track “All I Really Want”. At the end of this, “You Oughta Know” (track 2) should have started, but instead “Perfect” (track 3) started.

This happens with whichever album I play first after starting Volumio.

Thanks in advance,

I’m sorry to write again in this old topic, but I’ve never actually resolved this issue. Every time I start Volumio the same thing happens with the first album I listen to. I start the album by clicking on the first track, and it plays correctly, but when it’s done, instead of playing the second track, it starts the third one!

Here’s the log:

****EDIT: I just realized that the links to the logs don’t work, is there any issue?

no, it works :wink:

1 Like

Thank you, to facilitate reading, scroll through the log until Sep 18 18:00:57, at that point I began playing the first track (Calexico - 01 - Gypsy’s Curse.flac).
At Sep 18 18:05:09, the second track “Calexico - 02 - Fake Fur.flac” was supposed to start, but instead, “Calexico - 03 - The Ride, Pt. II.flac” started.

For the record, after printing this log, I updated Volumio to the latest version. However, I tested it with another album on the first boot after the update and the issue occurred again.

Does anyone have an idea of what the cause could be? Should I try a clean reinstall, or do you recommend something less invasive first?

Uh, that’s tough! I see clrearly when it happens, but not why that is…

Few questions:

  • What device are you using ? (PI 1, 2 , 4 etc)
  • Can you try disabling plugin, restarting and retrying?

Thank you for the response!
I have a Raspberry Pi Model 3B+ with a Allo Digione.

So, I need to make a small correction regarding what was reported.
The issue is not that the second track is skipped. The second track is actually played, but on the player interface, the third track is displayed instead of the second one!
So, going back to the previous example, after “Calexico - 01 - Gypsy’s Curse.flac,” “Calexico - 02 - Fake Fur.flac” is indeed played, but on the interface, it shows that “Calexico - 03 - The Ride, Pt. II.flac” is playing!
And I confirm that the issue only occurs during the initial playback after system boot: later albums I play correctly queue the tracks.

I first tried disabling the LastFM plugin, and when that didn’t resolve the issue, I even removed it completely. No change, the same result.

So, I attempted a factory reset. Incredibly, the problem persists.

At this point, I think my only option left is to try a clean installation of Volumio, unless you have any other suggestions.

I downloaded the Volumio image from the website and flashed it onto a new SD card. I inserted the card into the Raspberry Pi, configured everything, boot the player and then confidently ran the test, thinking I had solved it.
Unbelievably, I still have the same issue :sob:
It’s clearly a hardware problem at this point, but I have no idea what the issue could be :smiling_face_with_tear:


If I’m reading your comments correctly it sounds like this bug here [3.512] Album ART & track info displays one track in front of whats playing

to confirm try an album or playlist where you know the first track is shorter than the second and it should not do it.

1 Like

It’s clearly the same issue!
I had a try, as you suggested, with an album where the second track is longer than the first, and indeed, the problem doesn’t occur!
I’ll also post my testimony in that bug discussion, hoping that the developers can identify the problem.
Thank you M1ck! I was really going crazy, and at least now I feel less alone :smiley: