Scanning from USB drive stops after about 4755 files

Volumio Information

Volumio Version: v2.909
Hardware: Allo Digione Signature
Here is the log

Have forced rescan, restarted mpd from command line but no luck.

This is typically seen when mpd scanning comes a cross a file/files that are corrupted in some fashion, or maybe certain file types (not too sure about this).

In your log, there are a number of tracks skipped eg.Saudade/13. One note samba(a.c. jobim).mp3, but mpd continues indexing ok.

There are a lot of tracks in ‘Recycle Bin’ that mpd doesn’t like … you would be better to totally remove this folder, or at least get Mpd to ignore it’s contents (have a read of how to exclude folders from Library update).

A.R. RAHMAN (SIGNATURE COLLECTION–2) All tracks give rise to a ffmpeg warning:

ffmpeg/mov,mp4,m4a,3gp,3g2,mj2: max_analyze_duration 5000000 reached

You would have to try a Google search to see if this is critical or just advisory.

No file headers on some tracks eg. Dhamaaka Hits - 06.

At this point, I have stopped looking at your log.

I suggest that you clean up your USB drive contents by isolating the files that mpd is skipping (as detailed in the log), until you get a completely indexed drive. You can then try reintroducing isolated tracks and check that they are successfully indexed, even if mpd is complaining a little.

Good luck with what looks to be a big job.

Have a look at this article/tutorial on how you can automate most of this part :slight_smile:

Thanks @chsims1 for taking the time to investigate the issues. And thanks @ashthespy for the tutorial. A couple of quick questions.

  1. I moved away some “wav” files and while I still get errors on many tracks at least mpd continued to scan. The weird thing is that there is no error reported on those “wav” files.

  2. Is there a tool I could run on Linux to find these corrupted files or at least check the files reported by mpd? Might be much easier to do and then plug the disk back to Allo.

  3. What is the correct way to do a rescan? Just hitting Recan from the UI doesn’t do it. I run tail -f /var/log/mpd.log in a ssh terminal and there is no output there. The only way I’ve found is to run systemctl restart mpd. Wait till it finishes. Then hit Rescan from the UI.

  4. Do I have to shutdown the Allo via the Volumio UI? Once the scan is completed are the disks mounted readonly? Is it safe to just poweroff the Allo without causing disk corruption?

Thanks again for all your help!

I’m not aware of any tools for checking file validity of audio files for mpd. Please post here if you find one. :wink: Note that any checker you find will need to specifically allow for mpd and it’s use of ffmpeg in indexing. Perhaps you could put a question to the mpd forums?

‘Rescan’ from the UI should be working ok, but system messages are not necessarily picked up in mpd.log. Try ‘sudo journalctl -f’ in your ssh terminal, and you should see nodeJS initiating the rescan.

It is best practice to shutdown your device from the UI. This will allow the graceful flushing of filesystem caches, and unmount filesystems. We all shutdown without rebooting at times, but if I were using a USB drive, I would be more inclined to do it the correct way.

I did post on the MPD board and I’ve got a reply that Volumio uses an old version of MPD so they can’t help.

I understand about switching off the device from the UI. But as Allo is a streamer it sits next in the rack next to the DAC/Amp and members in the family are used to turning off other devices using a remote and keep forgetting about the Allo. This is more of an Allo issue.

I will check the journalctl command and report back.

My reply to you was that you could (if you wished) enquire about whether anyone on the mpd boards was aware of audio checking software. This has absolutely nothing to do with Volumio… I was trying to be helpful in your checking of your audio tracks for potential problems. I remind you of my solution of isolating offending tracks, and then adding them back one by one.