how to exclude folders from Library update


I have Volumio running on a Pi 2 with a hard drive connected to it. There is my music stored and as well a folder for Transmission. Update Library does not work well for me and I think it could be because the transmission folder mess the daemon up. So how can I exclude this folder from the update process? Is the daemon called mpd? Where is the settings file stored?

:arrow_right: Symptoms I get:

  • not all music is shown
  • after updating music start and stops frequently

It look like the updating daemon hangs him self up and uses a lot of resources. That could also be caused from letters like @ * / ? Does somebody else has thous problems? If it’s could be cased by special characters, how do I rename all the files in the music folder by a terminal prompt?

Thanks for help

1 Like

From … abase.html

for example:

echo "*" > </path/to/directory/to/be/ignored/>.mpdignore

Cool, thank’s a lot!! :smiley: That makes it a lot easier. What I did so fare is a group where I did not include mpd.

Hello, this concerns me, what character did you put in the .mpdignore file?
How did you proceed? Do you automate this task for all folders?
Thank you

1 Like

To exclude all files and subdirectories add the ‘*’ wildcard to the .mpdignore file. You can use other wildcards in their normal fashion.

The previous post already explains how to do it. For example, to exclude all files in the folder /music/films, you would type at the command line:

echo "*" > /music/films/.mpdignore

I want to say thanks to the OP for asking the question in the first place, and also to chsims1 and loza for the answers.

I have all my music on a synology diskstation which has a habit of creating hidden @eaDir directories.
I’ve created a .mpdignore file in my music root folder with eaDir in it.

It works very well.

I’ve put .mpdignore as instructed into the root of the drive with the echo command of what folder to ignore and it still scans them annoyingly

Did you try to put a dot before the folder name you want to exclude/hide (.foldername)?

If my memory serves me right, I tried (only for a test and not for real need) last year to do just this and it worked.

I have a lot of files in my top directory, which I have excluded by the .mpdignore file. But I also have two subdirectories which I want to include. Is there any option for “reverting” the .mpdignore file in the subdirectories

I am trying to exclude a folder on an external hdd but it doesn’t seem to work.

I added the .mpdignore file by just creating the file on the hdd before connecting it to my pi. Does this not work? Do I have to use SSH to send an echo command?

I tried using ssh but I couldn’t figure out how to navigate to the correct folder, or put in the location correctly to write the .mpdignore file to the correct folder.

The folder is called “Media” and it is located in the root of the external HDD. The external HDD is named “Buffalo6TB”.Can anyone give me a correct echo command to write a .mpdignore file with the “*” wildcard?

Thank you for any help!

So, are you able to ssh to your Volumio installation on your pi?
If not, browse to http://your-volumio-host/dev/ and click ENABLE under SSH.
To connect to the SSH service, read this: SSH - Volumio Documentation

If you are connected to the pi over SSH, from that terminal session navigate to the folder you’d like to excluded from the library.

Then. like explained in replies above, enter:

echo "*" > .mpdignore

Or manually create a file in that folder called .mpdignore with content *
If it works you may copy that same file to other folders you’d like to exclude.