Room correction using your iPhone and HouseCurve

Thank you :pray:

Thankd! I’ll have a look tomorrow.
But how does it sound for you?

It sounds much better than without. Of course I can always redo HouseCurve procedures again separating L and R. Laziness and lack of a mic stand are my only obstacles:) I’m not sure if the mic position being slightly different b/w L and R measurements is a problem. Also bass modes are cumulative. no?

Yes, your files are mono, so the same correction for L and R. If the room and speaker placement are symmetrical, this is not a problem…

Perfect. Thank you for your time and effort

Hello again,
I tried loading conv. Filters to my Pi 3 in another room, but it kept crashing with it’s LED solid red. I assumed conv. filters need some horse power and the Pi 3 just can’t handle. So I moved to PEQ export from HouseCurve. Than there’s no sound and looking on the track progress, Tidal is fast forwarding. What am I doing wrong?
This happens even when I “disable effect”. Disabling the plugin altogether fixes the issue.
Thank you.filters.txt (310 Bytes)

Hummm. I use 65556 long conv filter with Rpi3 without issue.
Can you please provide log file for volumio and /tmp/camilladsp.log.
It should work…

Well I managed to get the Volumio log file. But Camilladsp.log I couldn’t figure out how.
://volumio-tv.local/tmp/camilladsp.log is this the way?
please see attachments. I hope it helps you diagnose the problem.
thank you

I see nothing… Can you please save volume mixer in volumio playback and reboot?
Can you play a local file (flac, mp3) or a WEBRADIO using volumio interface?

Hello. I’ve had a good look at your log. I am intrigued by mpd.conf…

audio_output {
		type		"alsa"
		name		"alsa"
		device		"volumio"
		dop			"no"
		mixer_device    "hw:5,0"
                mixer_control   "PCM"
                mixer_type      "hardware"


ALSA lib conf.c:4898:(parse_args) Unknown parameter 1
ALSA lib conf.c:5031:(snd_config_expand) Parse arguments error: No such file or directory
ALSA lib control.c:1375:(snd_ctl_open_noupdate) Invalid CTL hw:5,0
Jun 12 15:19 : exception: Failed to read mixer for 'alsa': failed to attach to hw:5,0: No such file or directory

his not look like a standard config… Did you tweak this (yes) :grimacing:?

Me? tweak a code? all I know about code is Basic from CS in high school.
I use the pie with USB input for the “Platin Hub” a Wisa transmitter. Known for sporadic USB behavior. If that’s an indication.
Btw I fixed the issue as you suggested; set mixer to None.
Thank you for all your support.

This is a post from Platin Support on FB.

The Raspberry Pi we have never tested for our USB-input and it sound like there is a driver-issue here in your case. We know there is a driver for Windows and MAC. The trick here is, that the USB chipset does not forward volume information from external devices, that is why we default set USB-input gain to 0dB and the input signal was adjusted on computer output instead - to avoid double volume control. So our volume control is completely isolated from the external device. So - when you say your device is adjusting the volume - it is most likely either adjusted on the RPI output and then something is not compatible with the USB chipset inside the device and messing up stuff due to driver mismatch. Our suggestion would be that you use the optical or coax input of the Hub instead of USB-input and let RPI adjust volume of SPDIF signal instead if you prefer the conveninence of that, and then set that input to fixed 0dB gain.

@balbuze hello,
is there a way to save several conv. filters as presets? I figured out peq, but conv, I’m at a loss.
thabk you. cenk

Yes, but this 'not (yet) implemented in the hub (right bottom memu). So to access, go in plugin settings in convolution mode. Scroll down and you will find preset!
Let me know :smiling_face:

I misread the help text as I can only have one set of filter files named myfilter-Xk.wav in the filters folder. I tried adding myfilter-Yk.wav, it works. I should have just tired, my fault. Thank you.

I want to play around with rephase. What taps number should I use in rephase to export to REW and later Camilla not to have a problem?

thank you for your help. cenk

I suggest 65536 taps filters… It’s a good compromise between quality and delay ( yes, delay introduces by Fir filter is related to the length)

1 Like

Hey Greg,
REW freq. resp. acquisition is way over detailed in parameters for a newbie like me. Do I loose any accuracy if I just import from HouseCurve?
Would you suggest I do the averaging in REW? Or HouseCurves averaging is close enough?
Thank you

Hi Cenk - Importing should be fine, there won’t be any loss. REW out of the box and HouseCurve should measure quite closely if you use the same microphone.

I think HouseCurve’s average is good enough (IMHO :slight_smile:). It averages the dB values, which favors the “tops” of the measurement, apparently that’s more reflective of what we hear. REW probably gives you more knobs to twist if you want to experiment.

Hi Greg, extra knobs is exactly what I’m running from. thank you

1 Like