Raspberry Pi Touch Display Port

volumio@volumio:~$ cat /var/log/Xorg.0.log
cat: /var/log/Xorg.0.log: No such file or directory

albumart.log boot.log btmp mpd.log wtmp

Touch Display is installed

Please start the plugin and post the result of

systemctl status -l volumio-kiosk.service

Touch Display
Failed: start volumio-kiosk.service: Error: Command failed: /usr/bin/sudo /bin/systemctl start volumio-kiosk.service Failed to start volumio-kiosk.service: Unit volumio-kiosk.service failed to load: No such file or directory.

Try uninstalling and reinstalling the plugin, please.

just did that. It says its active.

[ 38.295] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[ 38.295] (II) no primary bus or device found
[ 38.297] (II) LoadModule: “glx”
[ 38.307] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[ 38.381] (II) Module glx: vendor=“X.Org Foundation”
[ 38.381] compiled for 1.18.4, module version = 1.0.0
[ 38.381] ABI class: X.Org Server Extension, version 9.0
[ 38.381] (==) AIGLX enabled
[ 38.381] (II) LoadModule: “fbdev”
[ 38.384] (WW) Warning, couldn’t open module fbdev
[ 38.384] (II) UnloadModule: “fbdev”
[ 38.384] (II) Unloading fbdev
[ 38.384] (EE) Failed to load module “fbdev” (module does not exist, 0)
[ 38.384] (EE) No drivers available.
[ 38.384] (EE)
Fatal server error:
[ 38.384] (EE) no screens found(EE)

PRETTY_NAME=“Raspbian GNU/Linux 8 (jessie)”
NAME=“Raspbian GNU/Linux”
VERSION=“8 (jessie)”
VOLUMIO_BUILD_DATE=“Thu Sep 30 22:42:09 CEST 2021”


Please post the output of

ls -al /usr/lib/xorg/modules/drivers
ls -al /etc/X11/xorg.conf.d
ls -al /usr/share/X11/xorg.conf.d
ls -al /etc/X11
ls -al /dev/fb*

And also give

cat /var/log/Xorg.0.log

another try :wink:

One thought comes to mind: Are one or all of the .conf files you mentioned still present in your system?

If so, I guess they probably contain driver "fbdev" in Section "Device" (in accordance with post 14). Try changing the driver from “fbdev” to “fbturbo”.

I would also assume that Option "fbdev" "/dev/fb0" has to be Option "fbdev" "/dev/fb1" when using DisplayLink.

-rw-r–r-- 1 root root 956 Dec 7 2016 fbturbo_drv.la
-rw-r–r-- 1 root root 46172 Dec 7 2016 fbturbo_drv.so
-rw-r–r-- 1 root root 59956 Nov 11 2016 modesetting_drv.so

-rw-r–r-- 1 root root 316 Oct 7 20:14 95-touch_display-plugin.conf

-rw-r–r-- 1 root root 1350 Nov 11 2016 10-quirks.conf
-rw-r–r-- 1 root root 788 Sep 30 2016 40-libinput.conf
-rw-r–r-- 1 root root 2747 Oct 28 2016 70-wacom.conf
-rw-r–r-- 1 root root 607 Dec 7 2016 99-fbturbo.conf

-rwxr-xr-x 1 root root 709 Sep 25 2013 Xreset
drwxr-xr-x 1 root root 4096 Oct 7 20:04 Xreset.d
drwxr-xr-x 1 root root 4096 Oct 7 20:04 Xresources
-rwxr-xr-x 1 root root 3517 Sep 25 2013 Xsession
drwxr-xr-x 1 root root 4096 Oct 7 20:04 Xsession.d
-rw-r–r-- 1 root root 265 Sep 25 2013 Xsession.options
-rw-r–r-- 1 root root 601 Oct 7 20:07 Xwrapper.config
drwxr-xr-x 2 root root 4096 Oct 7 20:04 app-defaults
drwxr-xr-x 6 root root 4096 Oct 7 20:03 fonts
lrwxrwxrwx 1 root root 14 Dec 6 2016 openbox → …/xdg/openbox
-rw-r–r-- 1 root root 17394 Sep 25 2013 rgb.txt
drwxr-xr-x 2 root root 4096 Oct 7 20:04 xinit
drwxr-xr-x 2 root root 4096 Jun 6 2014 xkb
drwxr-xr-x 2 root root 4096 Oct 7 20:14 xorg.conf.d
drwxr-xr-x 2 root root 4096 Oct 7 20:04 xsm

crw-rw---- 1 root video 29, 0 Sep 30 20:42 /dev/fb0

Ok, no “custom” .conf files.

If I didn’t misread post #14 “fb1” appears if the MIMO display is connected by USB. As only “fb0” is showing up in /dev now I guess the display was not connected by USB. (?)

Did you try my suggestion after you reinstalled the plugin?

The problem I was having was I was using fbdev instead of fbturbo.

So, to get the Mimo UM-1080CP-B USB to work I added the following:

In /boot/userconfig.txt, I added:


In /usr/share/X11/xorg.conf.d/99-fbturbo.conf, I added:

Section “Device”
Identifier “Allwinner A10/A13 FBDEV”
Driver “fbturbo”
Option “fbdev” “/dev/fb0”
Option “SwapbuffersWait” “true”

Section "Device"
Identifier "FBDEV 1"
Driver "fbturbo "
Option “fbdev” "/dev/fb1"

Section "Screen"
Identifier "UGA"
Device "FBDEV 1"
Monitor "Monitor name 1"

Sorry for the trouble.
Thanks for your help. It works very well.

Glad it’s solved!

Hi Guys
Have a Raspberry Pi 4 with 8gb ram and 2 HDMI ports, and i instaled Volumio , but only One port HDMI works, Can you Help me
i will have a 7" display, and i will on another HDMI port to run Smart TV LG, but how i say, only one port on Raspberry Pi works, did i must go in Raspberry Pi set up to activate 2 HDMI or Volumio can run only one display ???

hello and welcome :smiley:

I don’t know if two HDMI’s work at the same time, @gvolt do you know if this works.
but you indicate that you have a smart tv … why not open a browser on your smart tv and then go to the ip address of that raspberry pi then you also get the volumio interface.


THX a LOT , its working for now

i have raspberry pi4 b 8gb
and i have 2 hdmi , can i run 2 display at same time ???, i have on HDM O port a 7"display with resolution 1024x600 i want to rub on HDMI a TV with the same resolution or Higher , is this posible ??
i already have input config.txt

initramfs volumio.initrd
hdmi_cvt=1024 600 60 6 0 0 0
include userconfig.txt

and in userconfig text

can you help me thx A LOT