Raspberry Pi Touch Display Port

The Raspberry Pi Touch Display Port may soon be deprecated. Most Raspberry Pi users connect displays via HDMI and touch matrix via USB. Another issue with Raspberry Pi display port is the only screens that can be connected is a 7” Raspberry Pi Touch Display.

Question: Will a Volumio be developed to handle HDMI displays?

What is the basis for this assumption?

That’s not correct: There are DSI display in various sizes from e.g. Waveshare and Osoyoo. There are other (no-name) DSI displays in the market, too. Just for example on Amazon.com : dsi display

You can already use HDMI screens with a Pi. It requires to install the Touch Display plugin and typically some additional steps which depend on the display and its touchscreen.

It would be nice to know what those additional steps are…

It’s mainly setting configuration parameters for the display in “/boot/userconfig.txt”.

But as I wrote, details depend on the display, so it would be nice to know what particular display we are talking about :wink:

Mimo UM-1080CP-B

  1. Before booting connect the display to the HDMI connector of your Pi (if it is a Pi 4 use HDMI 0). For touch also connect the screen to one of the Pi’s USB ports.

  2. Install the Touch Display plugin. After enabling the plugin you will probably already have a picture. Otherwise try rebooting Volumio. If the display is fine no further action has to be taken.

  3. If the display should not work correctly you might try the following:

a) Connect to Volumio via SSH.

b) Open “/boot/userconfig.txt” with nano (editor):

sudo nano /boot/userconfig.txt

c) Add the lines


to the file and save it by typing Ctrl+x, y and Enter.

“hdmi_mode=28” is for a display resolution of 1280x800 (which appears to be the native resolution) at a refesh rate of 60Hz.

With “hdmi_blanking=1” the HDMI output will be switched off and blanked when the operating system asks for the display to be put into standby. On the Pi 4 “hdmi_blanking=1” will not cause the HDMI output to be switched off (feature has not yet been implemented).

d) Reboot.

Thank you for the info. The Mimo UM-1080CP-B uses a proprietary protocol called Display-Link. I have to do some additional steps to get this thing to work. http://domoticx.com/raspberry-pi-displaylink-usb-screen/

Ah, ok. I thought that DisplayLink is just an option and you could alternatively use HDMI.

Since the “udlfb” driver for DisplayLink uses framebuffer fb1 you would have to edit “/usr/share/X11/xorg.conf.d/99-fbturbo.conf”:

sudo nano /usr/share/X11/xorg.conf.d/99-fbturbo.conf

and change

Option "fbdev" "/dev/fb0"


Option "fbdev" "/dev/fb1"

This didn’t work.

Where do I put all of this stuff that normally goes into /etc/X11/xorg.conf. This is what I did on my Linux box.

Section “Device”
Identifier “FBDEV 0”
Driver “fbdev”
Option “fbdev” “/dev/fb0”

Section “Device”
Identifier “FBDEV 1”
Driver “fbdev”
Option “fbdev” “/dev/fb1”

Section “Screen”
Identifier “HDMI”
Device “FBDEV 0”
Monitor “Monitor name 0”

Section “Screen”
Identifier “UGA”
Device “FBDEV 1”
Monitor “Monitor name 1”

Section “ServerLayout”
Identifier “Default Layout”
Screen 0 “HDMI”
Screen 1 “UGA” LeftOf “HDMI”

Before adding / changing more files, please post the result of

cat /var/log/Xorg.0.log

Correct me if I’m wrong, but that seems to be a configuration for two displays (HDMI and DisplayLink). Do you strive for two monitors on your Pi, too?

This gives an option for both types.

Any chance you can provide the requested log?

According to MIMO, using the RPi 3 with USB Displays is said to be much easier as the required Kernel components are said to be part of the stock build. I did find that plugging in a Mimo Display into the RPI 3 did turn screen solid green. They say this is a sign that the display is recognized, and the driver is loaded. The green screen says that the Pi doesn’t know what to display on it.

The two frame buffers fb0 and fb1 are present in /dev. fb0 is said to be for the onboard RPI display port and when I plug in the MIMO fb1 appears indicating the USB display.

I tried various configurations including: /etc/X11/xorg.conf.d/60-plugable.conf and /etc/X11/xorg.conf. Neigher worked. The screen is still not displaying volumio, just green.

Section “Device”
Identifier “uga”
driver “fbdev”
Option “fbdev” “/dev/fb0”
Option “ShadowFB” “off”

Section “Monitor”
Identifier “monitor”

Section “Screen”
Identifier “screen”
Device “uga”
Monitor “monitor”

Section “ServerLayout”
Identifier “default”
Screen 0 “screen” 0 0

How to set (options udlfb fb_defio=1)

Is volumio running straight X?


Please: Post the requested log…, i.e. the result of

cat /var/log/Xorg.0.log

Has the Touch Display plugin been started?

volumio@volumio:~$ cat /var/log/Xorg.0.log
cat: /var/log/Xorg.0.log: No such file or directory

albumart.log boot.log btmp mpd.log wtmp

Touch Display is installed

Please start the plugin and post the result of

systemctl status -l volumio-kiosk.service

Touch Display
Failed: start volumio-kiosk.service: Error: Command failed: /usr/bin/sudo /bin/systemctl start volumio-kiosk.service Failed to start volumio-kiosk.service: Unit volumio-kiosk.service failed to load: No such file or directory.

Try uninstalling and reinstalling the plugin, please.