Qnap NAS drive mount problem

Hi there,
I recently purchase a QNAP NAS (ts-212) update with last firmware and I started to add several FLAC files inside.
I also set the NAS to shutdown at 1AM and restart at 10.30PM.
The NAS has a static IP
But, at every restart of the NAS Volumio doesn’t recognize the nas drive and I have found a workaround, bit annoying: in the source folder on Volumio I have to edit my path to the drive, click on “save” and magically the drive is recognized.
I am using a Nvidia Shield with Kodi, and there is no problem at every startup to recognize the drive
I also try to add vers=2.0 in the option field but without result

What can I do?

Some screenshoot

my system:
Volumio 2.853
Raspberry Pi 3+B
LAN connection

Cheers from Italy!


no one have had this problem before?


up the request, thanks

I also observed this on my synology nas with cifs… Not with nfs

So with nfs mode have you solved? If I remember correctly I tried NFS mode but the Nas was not recognize by Volumio

The nfs used to work but I remove it and I could not make it work again… So I have tried with cifs… But I want my nfs back :frowning:

Yes, I tried the NFS mode but the NAS is not recognized. With CIFS the NAS is recognized.
So is there an option to work with the NAS without save every time I want to access?
How do you set everything?
Many thanks

Now I have cifs and if I restart the server I need to perform exactly what you have said

So, maybe it’s a bug? Any guru tech can provide us some info about this?


up, error continue so far…

So, maybe someone of MOD team can provide us a guide to solve this bug?

Error persist, is bit annoying…

I have just made a working cifs share on my Synology NAS. I rebooted the NAS, and the share was found successully by Volumio.

What I suggest you do is reboot your Volumio device and your NAS, and then post a system log after both have rebooted and you are sure that the share has not been found.

Would you share the system log please?

I found a partial solution to my problem, following this post (20/23):

I set to NFS the share in Volumio, and a shared path in my QNAP NAS.

But there is a problem.
Volumio doesn’t recognize the NAS folder when NAS wake up itself.
If I reboot Volumio when the NAS is active, the NAS folder is correctly recognize

Any solutions?

My goal is not keep active 24/24 the NAS as I wrote some post up before


Same comments as my last post: I did not make a new share, because I normally use NFS anyway, but the share is always refound when the NAS is rebooted. A system log would be helpful.

Yes, sure, I try to make one this evening!


here the log:

I try to recreate the conditions of the problem:

  1. quit Volumio and QNAP NAS
  2. power on Volumio
  3. power on NAS
    this time the NAS is correctly recognize as you can see from the log.
    I’ll post another log when Volumio doesn’t recognize the NAS


This morning Volumio doesn’t recognize the NAS power on, appear a red window with “Error: failed to decode /var/lib/mpd//music/NASpath; Failed to open /var/lib/mpd/music/NASpath; No such file or directory”
the NAS has a static IP:

here the new log:

many thanks

Nothing at all to see in the logs. Volumio reports trying 4 times to mount the share, and finally gives up.

Apr 27 07:02:55 volumio volumio[891]: info: Cannot mount NAS music at system boot, trial number 4 ,retrying in 5 seconds
Apr 27 07:03:00 volumio sudo[2938]: volumio : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/bin/mount -t nfs -o ro,soft,noauto /mnt/NAS/music

There is no explanation of why it can’t connect, which leads me to suspect that the problem might well lie at the other end.

I suggest that you look at the logs on your NAS for further clues, and also try the QNAP support forum.

I did do a quick Google for your NAS and saw a couple of similar problems, but back in 2018. One post was to reconfirm the NFS permissions after reboot, but obviously that isn’t a practical solution. Let us know how you get on, because there will be others with similar problems.

Well, first of all, thank you very much for your support!
Maybe, I can try a different path:
If I program the NAS to wake up before power on Volumio, maybe at the boot Volumio itself could mount correctly the NAS
I’ll let you know


You can also add a cron to reboot Volumio at 10.40PM, as QNAP needs it time to boot.