Project with PeppyMeter Screensaver Plugin for VOLUMIO v2.9xx and 3.0xx buster

I’ll give it a try and start with a fresh installation.

This combination should now work without any problems
Please enable the DSP integration in PeppyMeter plugin for this.

Tell me. If I turn on DSP intrgration Spotify integration disapear.

What it means?? Only DSP or Spotify??

Or on DSP integration Spotyfi integration is always on??

1 Like

okay new volumio installation.
setup dac and reboot - install FusionDSP configure (sound okay) install touchscreen plugin an configure and reboot - install spotify and check if everything still plays (okay) - install and configure peppymeter (Fusion DSP integration on) and reboot. after reboot no sound but vu meters work okay.

The only way to get sound out and see the VU meters working is via internet radio and “DSD native seperate pipe” on.
Spotify does produce sound, but meters do not work.
my dac doesn’t work without FusioDSP.

Because Peppy is for eyes not for ears :rofl:

1 Like

Im trying to get this to work properly using 27" LCD monitor. I am able to get the spectrum part to show up however its on one side of screen covering the Now playing etc. IM not able to get actual VU meters and seems I get a lot noise as well via USB with Peppy spectrum installed.

@eMCZe
That’s ok so. If you enable fusion DSP, no separate Spotify pipe is needed, therefore the switch for Spotify integration is hidden. Also DSD native isn’t available, if DSP active. Therefore the alsa configuration box is also hidden.

Please step by step and not all at once.
The first step is, enable DSD native, disable Spotify and DSP and play sound from internal sources or NAS, TIDAL or so. If sound working and meters?

In this configuration you have no meter moving for spotify but sound, and all other sources have pass through sound.
Is that so working?

yes.

Ok, the next step is enable Spotify integration and play Spotify. Then spotify use a separate pipe for audio and meters. Other sources still the same.
If that working with moving meters for Spotify?

no, Spotify doesn’t play at all, nothing happens.
internet radio everything is okay other source oke.

Starting Live Log...
process exited with code nulltime="2024-02-13T18:14:36+01:00" level=debug msg="fetched chunk 3/23, size: 524288"
time="2024-02-13T18:14:36+01:00" level=debug msg="fetched chunk 2/23, size: 524288"
time="2024-02-13T18:14:36+01:00" level=debug msg="fetched chunk 1/23, size: 524288"
time="2024-02-13T18:14:50+01:00" level=debug msg="handling resume player command from f85dcaf5d0db81ae74f22844a53b0f102aa98f00"
time="2024-02-13T18:14:50+01:00" level=warning msg="failed handling dealer request" error="no stream"
info: CALLMETHOD: system_controller system enableLiveLog true
info: CoreCommandRouter::executeOnPlugin: system , enableLiveLog
info: Launching a new LiveLog session
info: Killing previous LiveLog session
info: Live Log process terminated: null
time="2024-02-13T18:14:59+01:00" level=debug msg="handling skip_next player command from f85dcaf5d0db81ae74f22844a53b0f102aa98f00"
time="2024-02-13T18:14:59+01:00" level=debug msg="skip next track"
time="2024-02-13T18:14:59+01:00" level=debug msg="loading track spotify:track:0nsncaknBg9eWke0e7FPZJ (paused: true, position: 0ms)"
time="2024-02-13T18:14:59+01:00" level=debug msg="put connect state because PLAYER_STATE_CHANGED"
time="2024-02-13T18:14:59+01:00" level=trace msg="emitting websocket event: will_play"
SPOTIFY: received: {"type":"will_play","data":{"uri":"spotify:track:0nsncaknBg9eWke0e7FPZJ","play_origin":"com.spotify.gaia"}}
time="2024-02-13T18:14:59+01:00" level=debug msg="selected format OGG_VORBIS_320 for spotify:track:0nsncaknBg9eWke0e7FPZJ"
time="2024-02-13T18:14:59+01:00" level=debug msg="requested aes key for file 5fafac7944f81c8b503e4e2c9ac3c9798bcab360, gid: 0nsncaknBg9eWke0e7FPZJ"
time="2024-02-13T18:14:59+01:00" level=debug msg="fetched first chunk of 27, total size is 13668120 bytes"
time="2024-02-13T18:14:59+01:00" level=trace msg="seek to 0ms (diff: 0ms, samples: 0, bytes: 0)"
time="2024-02-13T18:14:59+01:00" level=warning msg="failed handling dealer request" error="failed loading current track (skip next): failed creating stream: ALSA error at snd_pcm_open: Device or resource busy"
time="2024-02-13T18:14:59+01:00" level=debug msg="fetched chunk 1/26, size: 524288"
time="2024-02-13T18:14:59+01:00" level=debug msg="fetched chunk 3/26, size: 524288"
time="2024-02-13T18:14:59+01:00" level=debug msg="fetched chunk 2/26, size: 524288"

Thank’s for your great job @2aCD . but unfortunately also in this new version there is the same issue that working togheter Peppy and Spotify plugin, tracks on spotify skips continuosly and it’s impossible to listen a complete track .

I haven’t this issue.

@Roberto_Grieco
Hey, it seems, that is depend on sound card. Can you please try to enable hdmi out instead and look if Spotify play without break.

1 Like

I have the same issue with skipping tracks on Spotify. Oddly, if I install and activate FusionDSP and Spotify, Spotify seems to play through tracks completely. Unfortunately I seem to have a different problem with that combination - I get crackles and pops in the music that I don’t get with Spotify (and no PPY/Fusion). Still trying to sort that out.
I know just enough to be dangerous but - wonder if something gets installed with FDSP that helps Spotify play tracks through?

@Roberto_Grieco
Please try the configuration with ‘modular alsa’ and disabled spotify integration.
With the most of sound cards this not working (scrampled sound for Spotify) but with HDMI output this works without problem. Maybe with your USB DAC. Can you try this

@michel8166
your pcm output device is busy. Please do not change any settings with running sound. Please select another song after change, not the same.
And when you switch the source press stop at first and search then another song.
In some circumstances a reboot is needed after switch the alsa mode.

Hey @fjmarch
Fusion DSP interrupts the audio pipeline and feeds back in after the DSP. Therefore the sensible Spotify output is not more the input for peppyalsa. The fusionDSP output works better as input for peppymeter.
Have you breaks with spotify, if DSP disabled, the also please try ‘modular alsa’ with disabled Spotify integration.

I did a new installation of volumio.
everything installed on DSD native separate pipe, internet radio plays and everything okay.
Spotify integration on and a reboot.
Spotify pressed play and then nothing happens, on the next song, nothing either.

I get this error every time and I really don’t press to the next number too quickly.
I first stop everything that is running before I use Spotify.

could it be that in my case it has something to do with the fact that in the new version (3.611) dtoverlay dac slave has been added to dacs that work in master mode.

Starting Live Log...
time="2024-02-13T20:17:38+01:00" level=debug msg="fetched first chunk of 16, total size is 7991800 bytes"
time="2024-02-13T20:17:39+01:00" level=trace msg="seek to 0ms (diff: 0ms, samples: 0, bytes: 0)"
time="2024-02-13T20:17:39+01:00" level=error msg="failed handling status request" error="failed loading context: failed loading current track (load context): failed creating stream: ALSA error at snd_pcm_open: Device or resource busy"
error: Failed to send command to Spotify local API: /player/play: Error: Internal Server Error
time="2024-02-13T20:17:39+01:00" level=debug msg="fetched chunk 1/15, size: 524288"
time="2024-02-13T20:17:39+01:00" level=debug msg="fetched chunk 2/15, size: 524288"
time="2024-02-13T20:17:39+01:00" level=debug msg="fetched chunk 3/15, size: 524288"
info: CALLMETHOD: system_controller system enableLiveLog true
info: CoreCommandRouter::executeOnPlugin: system , enableLiveLog
info: Launching a new LiveLog session