Project with PeppyMeter/PeppySpectrum Screensaver Plugin for VOLUMIO

There’s a link up in the thread – Peppymeter (peppyalsa) VU Meters with Roon? - #15 by 312Elements - Raspberry Pi - Roon Labs Community – that points to doing this with RoonBridge without Volumio (with pointers on how to get it going), but this Peppy screensaver doesn’t work on Volumio with Roon as a source. I hacked around a bit with asound.conf but it was above my skillset and couldn’t get it to work.

Perhaps it’s something we can request from @2aCD. :smile: I test Volumio every 6 months or so with Roon, and volroon was the last missing piece for me to move to Volumio for my various Pi streaming endpoints (super excited about volroon), but having Peppy would be icing on the cake.

i would not have your hopes up didn’t see him for a long time,
i think you could bake a lot of cakes in that time even with a lot of icing…:smile:

1 Like

Hi all! Stranger things. There is a Volumio 3.429 on RPi 4, USB DAC with an indication of the incoming frequency and several scenarios.

  1. Peppymeter is turned ON and the mixer type is set to Hardware or Not: only HiRes, DSD and Spotify are playing and the DAC displays all incoming frequencies. Peppymeter is working. I get an error when playing MP3: “Failed to open “alsa” (alsa); Error opening ALSA device “volumio”; snd_pcm_hw_psrams_set_period_time_near() failed: Invalid argument”

  2. Peppymeter is turned ON and the mixer type is set to Program: everything is playing, Peppymeter is working, but the DAC does not receive a frequency higher than 44.1K or 48k from any source.

  3. Peppymeter is OFF - everything works with any mixer settings and the DAC displays all incoming frequencies.

What should I fix to combine Peppymeter and correct HiRes playback?

1 Like

hi could PepppyMeter work with airplay on iphone?



Hello, I changed something but don’t remember what.
Can someone help me?

Hi guys,

Any news on the official plugin feature for peppy metter?

In my Volumio Primo the non-official way that peppy meter needs to install, does implies edition of protected files, so it kind of disables updates and so on.

This make me decide not to use it, but I really love it :slight_smile:


@Gelo5 Hello Gelo5,

My Setup is working really good. The decision which from your skins is my favorite, is very heavy. So I tried the list feature without effort. Do you have a hint once again? Thanks a lot, Dieter

I answer myself: an error “Failed to open “alsa” (alsa); Error opening ALSA device “volumio”; snd_pcm_hw_psrams_set_period_time_near() failed: Invalid argument” disappears when settings of the Peppymeter plugin - Alsa configuration is set to “DSD Native”. But at the same time Peppymeter stops working in Spotify. This struggle has already tired me. Is there a way to make it work everything everywhere all at once?

I read posts till the end but i didn’t understand how can i fix peppymeter and spotify problem. would you explain me step by step. Thanks

@isercan have you tried this.


i tried all of them . ssh enable and wrpte it on putty. but said now have folder. after looked sd card inside i didnt finde folder.

just tried it, the file is just visible to me.
have you tried in mixer type, hardware or software, do a reboot after adjustment and check.
what volumio version and dac are you using?

ssh in Volumio sudo nano /data/plugins/music_service/spop/volspotify.tmpl

1 Like

thank you @michel8166 it has started to work . But remaining time doesnt work. Can it work?

1 Like

Glad the meters are working now :+1:
I also suffer from the fact that time sometimes doesn’t run right.
I wouldn’t know the solution. maybe someone else knows or waiting for @2aCD

1 Like

Other skins dont work but gold name skin works better, we need to wait @2aCD

Hi, I have just made a fresh install, and everything works and it looks awesome, except that the needles doesn’t move.
Raspberry PI 4 Model B 4GB
DAC HIFIBerry Digi+ Pro
Volumio 3.435 march 6 2023 10.42.18 AM:CET
Peppymeter 1.3.0

I am still waiting for my display, so I am connecting to an external monitor 1920x1080.
I use Tidal Connect as source, have tried from USB connected HD as well as I could see in post that source cold matter.

Any suggestions to where I should edit something, and what?

Kind regards

@hifipi first of all welcome to the volumio forum :smiley:
take a look a few posts above yours :wink:

There is a screen with a resolution of 1024x600. When starting medium, the indicator shows in the upper left corner. How to move it to another position. For example, right in the middle? Where and what parameters need to be changed.?

1 Like

Hello , my screen is

  • 11.9inch IPS screen, 320 x 1480 resolution.
    1-Volumio and touch screen is working perfectly
    2-Peppymeter plugins installed as per video of Andy
    3-Custom 7 320x1480 installed but its not working
    4-copy and pest 320x1480 in to custom 5 folder ( deleted all content of customer 5 folder prior to pest)
    not working
    5- three times reinstalled the Volumio from fresh , still not working
    6 tried your help in page 691 , still not working
    7- rest of the plugins worked but not in full screen

I will appreciate your help

1 Like