Project with PeppyMeter/PeppySpectrum Screensaver Plugin for VOLUMIO


FYI Docs do not mention this, where the correct place to change this config. /etc/asound.conf is reseting after reboot. So I managed to solve it by editing \data\plugins\miscellanea\peppy_screensaver\asound\Peppyalsa.postPeppyalsa.5.conf file.

crazy question, is it also possible, for example when choosing active meter folder, to have an small image next to the text of the meter you want to choose.

I have seen more peculiar questions :wink:

The plugin page won’t allow images, so the answer is no,

pity that this is not allowed :sob:… would make selecting a lot easier and more beautiful :smiley:
but well it can’t.

1 Like

Hello everyone, I have a problem with Peppymeter, by enabling the Plugin I no longer hear the music, the DAC (Innomaker on GPIO) disconnects, the Plugin is installed correctly… where is the Problem?? Thanks


Hi Mario,
We don’t have crystal balls, don’t lay tarot cards, or are clairvoyant.
We do need more info then it’s not working.

  • What is your hardware
  • Which version Volumio are you running
  • Which plugins are installed
  • Please post a log from boot till it errors out.

With this we might even be able to help.

Hello everyone,

I have Volumio3 on RPI 4b. I had a 7 inch hdmi lcd 1024x600 with Touch Display Plugin 3.3.5 and PeppyMeter was working fine.

Now I changed the display to 11.9inch DSI LCD 320 x 1480:

After problems with installing the drivers, I managed to install them according to the instructions: Waveshare DSI LCD displays
and now i have the image from Volumio.

Unfortunately, the PeppyMeter doesn’t work.

I uploaded skins 1480x320 according to the instructions in this thread.
I reinstalled PeppyMeter but it didn’t help, the image does not appear even though there are no errors.

Could this be due to the DSI interface?
Has anyone had such a problem? Any ideas?


Please show the sdl.env section of the configuration file which you use:


cat /data/plugins/miscellanea/peppy_screensaver/peppymeter/config.txt

you could write here the settings added in the config.txt file
and/or in userconfig.txt ?

framebuffer.device = /dev/fb0
mouse.device = /dev/input/event0
mouse.driver = TSLIB
mouse.enabled = True
video.driver = dummy
video.display = :0
double.buffer = True
no.frame = True

initramfs volumio.initrd

include userconfig.txt

Touch Display gpu_mem setting below: do not alter


Add your custom config.txt options to this file, which will be preserved during updates


Please make sure that you have such devices as /dev/fb0 and /dev/input/event0. The rest looks OK to me.

Is it about:

drwxr-xr-x 4 root root 200 Jan 30 19:54 .
drwxr-xr-x 18 root root 4100 Jan 30 19:54 …
drwxr-xr-x 2 root root 60 Jan 30 19:54 by-id
drwxr-xr-x 2 root root 120 Jan 30 19:54 by-path
crw-rw---- 1 root input 13, 64 Jan 30 19:54 event0
crw-rw---- 1 root input 13, 65 Jan 30 19:54 event1
crw-rw---- 1 root input 13, 66 Jan 30 19:54 event2
crw-rw---- 1 root input 13, 67 Jan 30 19:54 event3
crw-rw---- 1 root input 13, 63 Jan 30 19:54 mice
crw-rw---- 1 root input 13, 32 Jan 30 19:54 mouse0

crw-rw---- 1 root video 29, 0 Jan 30 19:54 /dev/fb0

Yes, looks OK. Also make sure you set these parameters:

If it doesn’t help try to contact anybody in this thread who was able to use the same display.

My userconfig.txt file:


I have a display with a DSI interface and this is probably the problem.
In this thread there is information that Peppymeter works with smaller DSI displays: 4.3" 800x400 and 5" 800x480.
What could be the reason it doesn’t work with 11.9" 1480x320?

try: type in userconfig.txt
hdmi_cvt=1480 320 60 6 0 0 0

I added these three lines at the end userconfig.txt but nothing changed.

I managed to run Peppymeter (on 1480x320 display) with the resolution: small (320x240) and medium(480x320).

Additionally, I noticed that at these resolutions it only works after restarting Volumio. Setting a different resolution and back to small and medium causes Peppymeter to no longer work.

I tried to run the 1480x320 resolution from the created custom_7 (1480x320) directory and from custom_5 (1920x480) with uploaded 1480x320 files (according to Gelo5 instructions).

After manually starting with 1480x320 resolution:
export DISPLAY=:0

I get a message:

volumio@volumio:/data/plugins/miscellanea/peppy_screensaver/peppymeter$ python3
pygame 1.9.4.post1
Hello from the pygame community. Contribute - pygame wiki
Traceback (most recent call last):
File “”, line 113, in
File “/data/plugins/miscellanea/peppy_screensaver/peppymeter/”, line 121, in init_display
screen_w = self.util.meter_config[SCREEN_INFO][WIDTH]
KeyError: ‘width’

Any ideas?

I noticed that in the file /data/plugins/miscellanea/peppy_screensaver/peppymeter/config.txt in the field [current] values for width and height are empty:

meter = Gelo5_Technics
random.meter.interval = 15
meter.size = custom_7 (1480x320)
screen.width =
screen.height =

After manual completion:
screen.width = 1480
screen.height = 320

and restarting Volumio finally Peppymeter worked in 1480x320 resolution!

However, any change to the Peppymeter settings clears the resolution and you must re-enter them manually and restart Volumio again.


A post was merged into an existing topic: Questions and suggestions for templates