Project with PeppyMeter/PeppySpectrum Screensaver Plugin for VOLUMIO

I installed all modules according to the instructions from 2aCD.
All steps work, I have the VU meter with the test script.
But as soon as I install peppymeter, the USB drive is lost with all my music.
If I select home, library, screen stays empty. If there is something in the queue, before installing peppymeter, I can press play on a track in the queue but nothing happens.
I do see the VU meters, randomly.
I started from a fresh installation v 3.251. I downloaded all modules from the links this topic.
I have a RPI4 with 4 GB of memory, no wireless, cables ethernet connection.
I have the pi connected through HDMI to a Eizo monitor for the tests.
As soon as I unstall peppypeter, my library comes back, without a reboot.

1 Like

Easter is already here. I made a test version for 800x480 resolution. I can’t test because I don’t have a monitor - just pure math!
Copy everything to:
/ data / plugins / miscellanea / peppy_screensaver / peppymeter / custom_1 (800x480)
meters.txt contains original skins + my skins (test)

3 Likes

tried them (800x480) and Wow this looks very nice and it looks like the alignment is also reasonable and I think the whole can go more to the right.

@Gelo5 thank you very much :smiley:



Play the disc with a long track title. From the file, not from the radio.
And what to give right?

this is while spotify connect is playing.
I don’t have any music on a drive at the moment.

1 Like

Thank you very much! I will try your skins tomorrow!
Happy Easter!

Looking at the picture - I made the meters.txt correction. Check now. (There aren’t many items when you play the radio)

1 Like

this one is with the latest meters.txt adjustment, Spotify connect.

old one.

Sorry I didn’t see that last sentence.
I mean there is still a small line on the right and not on the left.
x axis is not in the middle, at least I think so.
the same for the top and bottom.
maybe i’m a bit too precise.

for the statistics I use this screen.
https://www.waveshare.com/4.3inch-dsi-lcd.htm

These skins are for my 1920x1080 resolution. I don’t have a 800x480 screen, I did it mathematically. If you want to do it yourself (Photoshop + Wiki).
I did this at the request of @ClaesM. I will not scale any more skins. This is not 10 minutes of work
Replace the file with the attachment

2 Likes

okay, I understand.
I will try to modify it myself with Photoshop.

anyway thank you very much for these beautiful screensavers :+1:

1 Like

did you adjust it.
very nice now and spot on :+1:

Thanks @Gelo5 for your work and efforts you put in to this plugin. I´m verry happy with your skins. Thanks for sharing, they look really nice!

Happy Easter everyone!

Project with PeppyMeter Screensaver Plugin for VOLUMIO v2.9xx and 3.0xx buster - #738 by Gelo5?

1 Like

I just made another video on how to install PeppyMeter for ASUS Tinkerboard S. I think it will work on Volumio Primo too (@pjorgenunes can confirm this).

I am not a professional on tutorial video but I do it because I have a passion and believe in Volumio so I’d like to share. :slight_smile:

4 Likes

Hi @naimnatnod, I confirm it works.

One issue: editing the sudo file turns updates impossible in Primo.
Solution 1: clean user settings or doing a factory reset, install this stuff again and here we go (for me is not an issue 'cause I quickly get settings done again and I only use Volumio Primo to play music on external HDD) (and I love vumeters :slight_smile: :slight_smile: :slight_smile: )
Possible solution 2: (yet to try it) making a backup of sudo file prior of editing and restore it again prior to updates - have to see if it works

What would be AWESOME is that the peppymeter author / creator, could make this candidate to an official plugin. It would be really the best thing… for us :slight_smile:

BR,
Paulo Nunes

Bravo, bravo, bravo!!!

Thanks bungie240…can you pls confirm if the below looks right –

hdmi_group = 2
hdmi_mode = 87
hdmi_cvt 1920 1080 60 3 0 0 0
hdmi_drive = 2

initramfs volumio.initrd
#GPU_MEM=32
max_usb_current=1
dtparam=audio=on
audio_pwm_mode=2
dtparam=i2c_arm=on
disable_splash=1
hdmi_force_hotplug=1
hdmi_group=2
hdmi_mode=1
hdmi_mode=87
hdmi_cvt 1024 600 60 6 0 0 0
hdmi_drive=1 No sound VIA HDMI
hdmi_drive=2 sound via hdmi

include userconfig.txt

Touch Display gpu_mem setting below: do not alter

gpu_mem=128

1 Like

Hi Sir,

Based upon your inputs I have made the following changes as I have a 4k resolution —

In userconfig.txt file –

hdmi_group = 2
hdmi_mode = 87
hdmi_cvt 1920 1080 60 3 0 0 0
hdmi_drive = 2

In Config.txt file –

initramfs volumio.initrd
#GPU_MEM=32
max_usb_current=1
dtparam=audio=on
audio_pwm_mode=2
dtparam=i2c_arm=on
disable_splash=1
hdmi_force_hotplug=1
hdmi_group=2
hdmi_mode=1
hdmi_mode=87
hdmi_cvt 1920 1080 60 3 0 0 0
hdmi_drive=1 No sound VIA HDMI
hdmi_drive=2 sound via hdmi

include userconfig.txt

Touch Display gpu_mem setting below: do not alter

gpu_mem=128

Please advise if this correct and good…

Looks ok, give it a try and see how it goes…maybe make a copy of the original file before replacing with this new one.

Hope it works out…